aboutsummaryrefslogtreecommitdiff
path: root/sysutils/baloo
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-03-26 11:48:13 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-03-26 11:48:13 +0000
commit0c191565ebc8fa2691a7d85c3a32b90c0955b562 (patch)
treee4120f408dede12497a5e1920659e1dd68381dc5 /sysutils/baloo
parenta3578aaa476405d62ba19c66b1310a184501291d (diff)
downloadports-0c191565ebc8fa2691a7d85c3a32b90c0955b562.tar.gz
ports-0c191565ebc8fa2691a7d85c3a32b90c0955b562.zip
Add "baloofiles" to the list of exported CMake libraries.
In practice, this means linking against "baloofiles" in CMake passes "/full/path/to/libbaloofiles.so" instead of "-lbaloofiles" to the linker. The latter may fail if -L/full/path/to is not passed as well.
Notes
Notes: svn path=/head/; revision=436959
Diffstat (limited to 'sysutils/baloo')
-rw-r--r--sysutils/baloo/Makefile2
-rw-r--r--sysutils/baloo/files/patch-src_file_lib_CMakeLists.txt28
2 files changed, 29 insertions, 1 deletions
diff --git a/sysutils/baloo/Makefile b/sysutils/baloo/Makefile
index 5e7eec87a40e..da228c445fbe 100644
--- a/sysutils/baloo/Makefile
+++ b/sysutils/baloo/Makefile
@@ -2,7 +2,7 @@
PORTNAME= baloo
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils kde kde-kde4
MAINTAINER= kde@FreeBSD.org
diff --git a/sysutils/baloo/files/patch-src_file_lib_CMakeLists.txt b/sysutils/baloo/files/patch-src_file_lib_CMakeLists.txt
new file mode 100644
index 000000000000..208c2b5c98dd
--- /dev/null
+++ b/sysutils/baloo/files/patch-src_file_lib_CMakeLists.txt
@@ -0,0 +1,28 @@
+Backport of the "export baloofiles with the rest of the targets" part.
+
+This is necessary so that the CMake exports file has an entry for baloofiles,
+and linking against it passes "/full/path/to/libbaloofiles.so" instead of
+"-lbaloofiles" to the linker. The latter may fail if -L/full/path/to is not
+passed as well.
+
+commit 66068074c64b2a4a68a3dda567904704b0ae1f02
+Author: Aleix Pol <aleixpol@kde.org>
+Date: Wed Mar 12 17:51:02 2014 +0100
+
+Improvements on Baloo's cmake architecture
+
+Install a file indicating the version
+Port linking variables into the proper targets
+Export baloofiles with the rest of the targets
+
+--- src/file/lib/CMakeLists.txt
++++ src/file/lib/CMakeLists.txt
+@@ -33,7 +33,7 @@ set_target_properties(baloofiles PROPERTIES
+ SOVERSION ${BALOO_VERSION_MAJOR}
+ )
+
+-install(TARGETS baloofiles ${INSTALL_TARGETS_DEFAULT_ARGS})
++install(TARGETS baloofiles EXPORT BalooLibraryTargets ${INSTALL_TARGETS_DEFAULT_ARGS})
+
+ install(FILES
+ file.h