aboutsummaryrefslogtreecommitdiff
path: root/sysutils/bsdfan/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-07-07 19:11:41 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-07-07 19:11:41 +0000
commit537bbafe6da68cf1f9710e125b19e43725dd0863 (patch)
treea770745e356a3f2040186d31c9da0652379af5df /sysutils/bsdfan/Makefile
parent84eb638a5bb097697a2d6d21a9a8b613ca7448c6 (diff)
downloadports-537bbafe6da68cf1f9710e125b19e43725dd0863.tar.gz
ports-537bbafe6da68cf1f9710e125b19e43725dd0863.zip
This is a simple utility to manage Lenovo ThinkPad fans on FreeBSD.
It automatically regulates the fan speed by the sensor temperature and user configuration. Suggested by: debdrup
Notes
Notes: svn path=/head/; revision=541448
Diffstat (limited to 'sysutils/bsdfan/Makefile')
-rw-r--r--sysutils/bsdfan/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/sysutils/bsdfan/Makefile b/sysutils/bsdfan/Makefile
new file mode 100644
index 000000000000..68bdc814f76c
--- /dev/null
+++ b/sysutils/bsdfan/Makefile
@@ -0,0 +1,26 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= bsdfan
+PORTVERSION= g20180112
+CATEGORIES= sysutils
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Utility to manage fans on Lenovo ThinkPad laptops
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= uidfix
+USE_GITHUB= yes
+GH_ACCOUNT= claudiozz
+GH_TAGNAME= d8428a7
+
+PLIST_FILES= bin/bsdfan man/man1/bsdfan.1.gz \
+ @sample\ etc/bsdfan.conf.sample
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/bsdfan.conf \
+ ${STAGEDIR}${PREFIX}/etc/bsdfan.conf.sample
+
+.include <bsd.port.mk>