aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cfengine317/Makefile
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2020-11-21 03:47:30 +0000
committerCy Schubert <cy@FreeBSD.org>2020-11-21 03:47:30 +0000
commit15e76a7e87cf580c1e6f21b9a7ecc61c5476a126 (patch)
tree8dd3faa0227642f50cc95e8f6bfefdf876abee64 /sysutils/cfengine317/Makefile
parent18bb2a47783ac556a4e78487e4d578829b5186c7 (diff)
downloadports-15e76a7e87cf580c1e6f21b9a7ecc61c5476a126.tar.gz
ports-15e76a7e87cf580c1e6f21b9a7ecc61c5476a126.zip
Welcome the new cfengine317 and cfengine-masterfiles317. They
become the default cfengine and cfengine-materfiles. cfengine315 and cfengine-masterfiles are deprected, expriring one year from today.
Notes
Notes: svn path=/head/; revision=555808
Diffstat (limited to 'sysutils/cfengine317/Makefile')
-rw-r--r--sysutils/cfengine317/Makefile71
1 files changed, 71 insertions, 0 deletions
diff --git a/sysutils/cfengine317/Makefile b/sysutils/cfengine317/Makefile
new file mode 100644
index 000000000000..5e06ea923a18
--- /dev/null
+++ b/sysutils/cfengine317/Makefile
@@ -0,0 +1,71 @@
+# Created by: jrhett@netconsonance.com
+# $FreeBSD$
+
+PORTNAME= cfengine
+PORTVERSION= 3.17.0
+CATEGORIES= sysutils
+MASTER_SITES= https://s3.amazonaws.com/cfengine-package-repos/tarballs/
+
+MAINTAINER= cy@FreeBSD.org
+# gjb@FreeBSD.org is also committer for this port
+# skreuzer@FreeBSD.org is also committer for this port
+COMMENT= Systems administration tool for networks
+
+LICENSE= GPLv3
+
+CPE_VENDOR= gnu
+
+CONFLICTS= cfengine3[0-9]-* cfengine31[0-689]-*
+.if !defined(MASTERDIR)
+PKGNAMESUFFIX= 317
+CONFLICTS+= cfengine-3.*
+.endif
+
+FETCH_BEFORE_ARGS= -o ${DISTDIR}/${DISTFILES}
+
+USE_RC_SUBR= cf-execd cf-serverd cf-monitord
+
+MAKE_JOBS_UNSAFE= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+USES= autoreconf cpe gmake gnome libtool localbase shebangfix ssl
+USE_GNOME= libxml2
+SHEBANG_FILES= examples/remake_outputs.pl
+CFLAGS+= -Wno-return-type -fcommon
+# EXAMPLESDIR= ${PREFIX}/share/examples/cfengine3
+DOCSDIR= ${PREFIX}/share/doc/cfengine
+MAKE_ENV= EXPLICIT_VERSION=${PORTVERSION}
+CONFIGURE_ENV= EXPLICIT_VERSION=${PORTVERSION}
+CONFIGURE_ARGS= --docdir=${DOCSDIR} \
+ --htmldir=${DOCSDIR}/html \
+ --libexecdir=${PREFIX}/libexec \
+ --libdir=${PREFIX}/libexec \
+ --mandir=${PREFIX}/man \
+ --with-workdir=/var/cfengine \
+ --with-pcre=${LOCALBASE} \
+ --with-lmdb=${LOCALBASE} \
+ --enable-fhs
+INSTALL_TARGET= install-strip
+
+LIB_DEPENDS+= libpcre.so:devel/pcre \
+ liblmdb.so:databases/lmdb \
+ libyaml.so:textproc/libyaml \
+ libcurl.so:ftp/curl
+
+OPTIONS_DEFINE= PGSQL MYSQL LIBVIRT
+
+PGSQL_USES= pgsql
+PGSQL_CONFIGURE_WITH= --with-postgresql=${LOCALBASE}
+PGSQL_CONFIGURE_OFF= --without-postgresql
+
+MYSQL_USES= mysql
+MYSQL_BROKEN= configure: error: MySQL client library exports symbols (EVP_CIPHER_CTX_init) clashing with OpenSSL.
+MYSQL_CONFIGURE_WITH= --with-mysql=${LOCALBASE}
+MYSQL_CONFIGURE_OFF= --without-mysql
+MYSQL_LIB_DEPENDS= libmysqlclient.so:${_MYSQL_CLIENT}
+MYSQL_LDFLAGS= -L${LOCALBASE}/lib/mysql
+
+LIBVIRT_CONFIGURE_WITH= --with-libvirt=${LOCALBASE}
+LIBVIRT_LIB_DEPENDS+= libvirt.so:devel/libvirt
+
+.include <bsd.port.mk>