aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cloudabi-utils
diff options
context:
space:
mode:
authorEd Schouten <ed@FreeBSD.org>2015-11-18 16:49:34 +0000
committerEd Schouten <ed@FreeBSD.org>2015-11-18 16:49:34 +0000
commit0ce6319a2f7bc7adc89966a1229631a1de4a56bf (patch)
tree4cda779c49f697b0355c43ef352644962039f7ba /sysutils/cloudabi-utils
parentdb53dfb4145518439e56e4d19b942c473857c39d (diff)
downloadports-0ce6319a2f7bc7adc89966a1229631a1de4a56bf.tar.gz
ports-0ce6319a2f7bc7adc89966a1229631a1de4a56bf.zip
Update cloudabi-utils to version 0.7.
This new version of cloudabi-utils now installs a library called libcloudabi. This library contains native ports of some of the APIs that are currently provided as part of CloudABI's runtime. These used to be built into cloudabi-run itself, but are now exposed as well. As cloudabi-utils is now becoming more complex, it now uses CMake as its build system. We can now remove our custom build targets. We do need to make sure to override CMAKE_INSTALL_MANDIR, as it is set to share/man by default. I'm slightly amazed that this isn't done by default. Reviewed by: beat Differential Revision: https://reviews.freebsd.org/D4176
Notes
Notes: svn path=/head/; revision=401882
Diffstat (limited to 'sysutils/cloudabi-utils')
-rw-r--r--sysutils/cloudabi-utils/Makefile25
-rw-r--r--sysutils/cloudabi-utils/distinfo4
-rw-r--r--sysutils/cloudabi-utils/pkg-plist7
3 files changed, 13 insertions, 23 deletions
diff --git a/sysutils/cloudabi-utils/Makefile b/sysutils/cloudabi-utils/Makefile
index 1f4df19207f0..f093ffd15c86 100644
--- a/sysutils/cloudabi-utils/Makefile
+++ b/sysutils/cloudabi-utils/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= cloudabi-utils
-PORTVERSION= 0.6
+PORTVERSION= 0.7
CATEGORIES= sysutils
MASTER_SITES= https://nuxi.nl/distfiles/cloudabi-utils/
@@ -16,27 +16,10 @@ LIB_DEPENDS= libyaml.so:${PORTSDIR}/textproc/libyaml
ONLY_FOR_ARCHS= aarch64 amd64
ONLY_FOR_ARCHS_REASON= CloudABI has not yet been ported to other architectures
-USES= compiler:c11 tar:xz
+USES= cmake compiler:c11 pkgconfig tar:xz
+USE_LDCONFIG= yes
-PLIST_FILES= bin/cloudabi-run \
- libexec/cloudabi-reexec \
- man/man1/cloudabi-run.1.gz
-
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
-do-build:
- @cd ${WRKSRC} && \
- ${SETENV} ${MAKE_ENV} \
- PREFIX=${PREFIX} \
- ${SH} build
-
-do-install:
- @cd ${WRKSRC} && \
- ARCH=${ARCH:S/amd64/x86_64/} \
- DESTDIR=${STAGEDIR} \
- PREFIX=${PREFIX} \
- ${SH} install
+CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR=man
.include <bsd.port.pre.mk>
diff --git a/sysutils/cloudabi-utils/distinfo b/sysutils/cloudabi-utils/distinfo
index 2a58479ca4d6..a50c00ed7577 100644
--- a/sysutils/cloudabi-utils/distinfo
+++ b/sysutils/cloudabi-utils/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cloudabi-utils-0.6.tar.xz) = 5020440d0ad15c8b0db55ec55444e9d44c056b0f7655c41dde85f0ba1d5045c2
-SIZE (cloudabi-utils-0.6.tar.xz) = 21928
+SHA256 (cloudabi-utils-0.7.tar.xz) = 193b115ca195ec56c24679916d7b38f8566a0a49b26b057e1567f1bbfb9ae5a2
+SIZE (cloudabi-utils-0.7.tar.xz) = 24496
diff --git a/sysutils/cloudabi-utils/pkg-plist b/sysutils/cloudabi-utils/pkg-plist
new file mode 100644
index 000000000000..d35aebbf7f8d
--- /dev/null
+++ b/sysutils/cloudabi-utils/pkg-plist
@@ -0,0 +1,7 @@
+bin/cloudabi-run
+include/cloudabi/argdata.h
+include/cloudabi/program.h
+lib/libcloudabi.so
+lib/libcloudabi.so.0
+libexec/cloudabi-reexec
+man/man1/cloudabi-run.1.gz