aboutsummaryrefslogtreecommitdiff
path: root/sysutils/consolehm
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-09-21 15:24:36 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-09-21 15:24:36 +0000
commit6f267705e9432b465e540d29ddc088d7b132a239 (patch)
treedbd5c99223ebb31317e1c051e77b47f630e05b99 /sysutils/consolehm
parent2460b9c47bc263beb44c65ac3e31313d627b0235 (diff)
downloadports-6f267705e9432b465e540d29ddc088d7b132a239.tar.gz
ports-6f267705e9432b465e540d29ddc088d7b132a239.zip
sysutils/consolehm: fix build on non-x86
outb requires including machine/pio.h and sys/types.h (for uint8_t). Approved by: linimon (mentor) Differential Revision: https://reviews.freebsd.org/D21633
Notes
Notes: svn path=/head/; revision=512513
Diffstat (limited to 'sysutils/consolehm')
-rw-r--r--sysutils/consolehm/Makefile3
-rw-r--r--sysutils/consolehm/files/patch-chm.c18
2 files changed, 11 insertions, 10 deletions
diff --git a/sysutils/consolehm/Makefile b/sysutils/consolehm/Makefile
index ec3d0112b454..b27077e2bceb 100644
--- a/sysutils/consolehm/Makefile
+++ b/sysutils/consolehm/Makefile
@@ -10,9 +10,6 @@ MASTER_SITES= LOCAL/fenner
MAINTAINER= ports@FreeBSD.org
COMMENT= Console based hardware monitor for FreeBSD
-ONLY_FOR_ARCHS= i386 amd64
-ONLY_FOR_ARCHS_REASON= uses x86-only assembly from machine/cpufunc.h
-
USES= uidfix
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/consolehm/consolehm
diff --git a/sysutils/consolehm/files/patch-chm.c b/sysutils/consolehm/files/patch-chm.c
index acf86381eaa9..38a169867eb0 100644
--- a/sysutils/consolehm/files/patch-chm.c
+++ b/sysutils/consolehm/files/patch-chm.c
@@ -1,14 +1,18 @@
---- chm.c.orig 2000-12-23 07:51:45.000000000 +0100
-+++ chm.c 2015-05-01 22:23:03.577465000 +0200
-@@ -25,6 +25,7 @@
+--- chm.c.orig 2000-12-23 06:51:45 UTC
++++ chm.c
+@@ -25,6 +25,11 @@
*
*/
+#include <osreldate.h>
++#if (__BYTE_ORDER__ == __ORDER_BIG_ENDIAN__) && defined(__FreeBSD__)
++#include <sys/types.h>
++#include <machine/pio.h>
++#endif
#include "chm.h"
static int io_file;
-@@ -165,6 +165,7 @@
+@@ -165,6 +170,7 @@ int main (int argc, char **argv)
printf("Delay: %d microseconds. \n\n",delay);
break;
default:
@@ -16,7 +20,7 @@
}
file_handle = OpenIO();
-@@ -279,7 +280,12 @@
+@@ -279,7 +285,12 @@ int OpenIO()
u_char smb_return;
struct smbcmd cmd;
cmd.slave=0x5a;
@@ -29,7 +33,7 @@
if((open_smb=open("/dev/smb0",000))<0){
fprintf(stderr, "Failed to open /dev/smb0.\n");
exit (-1);
-@@ -315,7 +321,12 @@
+@@ -315,7 +326,12 @@ int ReadByte(u_char *return_value, int addr)
u_char smb_return;
struct smbcmd cmd;
cmd.slave=0x5a;
@@ -42,7 +46,7 @@
cmd.cmd=addr;
if(ioctl(open_smb,SMB_READB,&cmd)==-1){
perror("IOCTL");
-@@ -342,9 +353,13 @@
+@@ -342,9 +358,13 @@ int WriteByte(int addr, int value)
u_char smb_return;
struct smbcmd cmd;
cmd.slave=0x5a;