aboutsummaryrefslogtreecommitdiff
path: root/sysutils/container-diff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:40:30 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:20:09 +0000
commit3241b01aaa7b45010c711cae976da5e65653e4e8 (patch)
treef6007c552662304575135ffc0e6a1527d98706b0 /sysutils/container-diff
parent6450f3ced44c09ce318caf45210f92e1cdd546a1 (diff)
downloadports-3241b01aaa7b45010c711cae976da5e65653e4e8.tar.gz
ports-3241b01aaa7b45010c711cae976da5e65653e4e8.zip
sysutils/container-diff: Fix c5187ab4770c77001c7c17ebfd110c1f26e755d1
- Fix USE_GITHUB/GH_* usage - Silence patch message
Diffstat (limited to 'sysutils/container-diff')
-rw-r--r--sysutils/container-diff/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/sysutils/container-diff/Makefile b/sysutils/container-diff/Makefile
index aee5b4c663cd..3dd10748d98b 100644
--- a/sysutils/container-diff/Makefile
+++ b/sysutils/container-diff/Makefile
@@ -12,18 +12,17 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= go
-USE_GITHUB= nodefault
-GH_TUPLE= golang:sys:v0.6.0:sys
GO_PKGNAME= github.com/${GH_ACCOUNT}/${GH_PROJECT}
PLIST_FILES= bin/container-diff
-GH_ACCOUNT= GoogleContainerTools
USE_GITHUB= yes
+GH_TUPLE= GoogleContainerTools:container-diff:v${PORTVERSION} \
+ golang:sys:v0.6.0:sys
pre-patch:
- ${RM} -r ${WRKSRC}/vendor/golang.org/x/sys
- ${LN} -s ${WRKDIR}/sys-* ${WRKSRC}/vendor/golang.org/x/sys
+ @${RM} -r ${WRKSRC}/vendor/golang.org/x/sys
+ @${LN} -s ${WRKDIR}/sys-* ${WRKSRC}/vendor/golang.org/x/sys
.include <bsd.port.mk>