aboutsummaryrefslogtreecommitdiff
path: root/sysutils/copytape
diff options
context:
space:
mode:
authorJustin M. Seger <jseger@FreeBSD.org>1998-12-20 21:14:43 +0000
committerJustin M. Seger <jseger@FreeBSD.org>1998-12-20 21:14:43 +0000
commit6299cff8f67fe10b62dc29dd6a9f0a9378ada978 (patch)
tree3c0ad50358b4de48ed7bdf65350e6f8caf227de4 /sysutils/copytape
parent0e453feea291f0c424c7e8b8aba812bfec3a222d (diff)
downloadports-6299cff8f67fe10b62dc29dd6a9f0a9378ada978.tar.gz
ports-6299cff8f67fe10b62dc29dd6a9f0a9378ada978.zip
Import of copytape 1.0
Copytape duplicates magtapes. It is intended for duplication of bootable or other non-file-structured (non-tar-structured) magtapes on systems with only one tape drive. Copytape is blissfully ignorant of tape formats. It merely makes a bit-for-bit copy of its input. PR: ports/8454 Submitted by: sjr@home.net
Notes
Notes: svn path=/head/; revision=15450
Diffstat (limited to 'sysutils/copytape')
-rw-r--r--sysutils/copytape/Makefile33
-rw-r--r--sysutils/copytape/distinfo1
-rw-r--r--sysutils/copytape/files/patch-aa20
-rw-r--r--sysutils/copytape/files/patch-ab11
-rw-r--r--sysutils/copytape/pkg-comment1
-rw-r--r--sysutils/copytape/pkg-descr4
-rw-r--r--sysutils/copytape/pkg-plist1
7 files changed, 71 insertions, 0 deletions
diff --git a/sysutils/copytape/Makefile b/sysutils/copytape/Makefile
new file mode 100644
index 000000000000..ca44e15f0672
--- /dev/null
+++ b/sysutils/copytape/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: copytape
+# Version required: 1.0
+# Date created: 23 October 1998
+# Whom: Stephen J. Roznowski <sjr@home.net>
+#
+# $Id$
+#
+
+DISTNAME= copytape
+PKGNAME= copytape-1.0
+CATEGORIES= sysutils
+MASTER_SITES= ftp://ftp.uu.net/usenet/comp.sources.unix/volume10/
+EXTRACT_SUFX= .Z
+
+MAINTAINER= ports@FreeBSD.ORG
+
+BUILD_DEPENDS= gunshar:${PORTSDIR}/archivers/gshar+gunshar
+
+NO_WRKSUBDIR= yes
+
+EXTRACT_CMD= zcat
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= | gunshar -d ${WRKDIR}
+
+MAN1= copytape.1
+MAN5= copytape.5
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/copytape ${PREFIX}/bin/copytape
+ @${INSTALL_MAN} ${WRKSRC}/copytape.1 ${PREFIX}/man/man1/copytape.1
+ @${INSTALL_MAN} ${WRKSRC}/copytape.5 ${PREFIX}/man/man5/copytape.5
+
+.include <bsd.port.mk>
diff --git a/sysutils/copytape/distinfo b/sysutils/copytape/distinfo
new file mode 100644
index 000000000000..3bb2c8d77eb4
--- /dev/null
+++ b/sysutils/copytape/distinfo
@@ -0,0 +1 @@
+MD5 (copytape.Z) = 63f035efbfeffd7a34cff86b0b6a6fed
diff --git a/sysutils/copytape/files/patch-aa b/sysutils/copytape/files/patch-aa
new file mode 100644
index 000000000000..0be1bdc8d526
--- /dev/null
+++ b/sysutils/copytape/files/patch-aa
@@ -0,0 +1,20 @@
+--- copytape.c.orig Fri Oct 23 17:23:06 1998
++++ copytape.c Fri Oct 23 17:23:46 1998
+@@ -36,7 +36,7 @@
+
+ extern int errno;
+
+-#define BUFLEN 262144 /* max tape block size */
++#define BUFLEN (1024*1024) /* max tape block size */
+ #define TAPE_MARK -100 /* return record length if we read a
+ * tape mark */
+ #define END_OF_TAPE -101 /* 2 consecutive tape marks */
+@@ -149,7 +149,7 @@
+ len = input(from);
+ } while (len > 0);
+ if (len == FORMAT_ERROR) {
+- perror(stderr, "copytape: format error on skip");
++ perror("copytape: format error on skip");
+ exit(-1);
+ };
+ if (len == END_OF_TAPE) {
diff --git a/sysutils/copytape/files/patch-ab b/sysutils/copytape/files/patch-ab
new file mode 100644
index 000000000000..265484767266
--- /dev/null
+++ b/sysutils/copytape/files/patch-ab
@@ -0,0 +1,11 @@
+--- Makefile.orig Fri Oct 23 17:31:20 1998
++++ Makefile Fri Oct 23 17:31:27 1998
+@@ -5,7 +5,7 @@
+ CFLAGS = -O
+ CC = cc $(CFLAGS)
+
+-copytape: copytape.c
++all copytape: copytape.c
+ $(CC) -o copytape copytape.c
+
+ install: copytape
diff --git a/sysutils/copytape/pkg-comment b/sysutils/copytape/pkg-comment
new file mode 100644
index 000000000000..f8cbc9d965db
--- /dev/null
+++ b/sysutils/copytape/pkg-comment
@@ -0,0 +1 @@
+A program that is used to duplicate magtapes.
diff --git a/sysutils/copytape/pkg-descr b/sysutils/copytape/pkg-descr
new file mode 100644
index 000000000000..20711cd50577
--- /dev/null
+++ b/sysutils/copytape/pkg-descr
@@ -0,0 +1,4 @@
+Copytape duplicates magtapes. It is intended for duplication of
+bootable or other non-file-structured (non-tar-structured) magtapes
+on systems with only one tape drive. Copytape is blissfully ignorant
+of tape formats. It merely makes a bit-for-bit copy of its input.
diff --git a/sysutils/copytape/pkg-plist b/sysutils/copytape/pkg-plist
new file mode 100644
index 000000000000..2dd838276e48
--- /dev/null
+++ b/sysutils/copytape/pkg-plist
@@ -0,0 +1 @@
+bin/copytape