aboutsummaryrefslogtreecommitdiff
path: root/sysutils/coreutils/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2019-03-13 15:49:22 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2019-03-13 15:49:22 +0000
commit826a3df314d6f9363e6e3630e1518ba2fe8f4e44 (patch)
tree4d3dc4c668c1a3e8e60784380a669f7400cb9af9 /sysutils/coreutils/Makefile
parent7c4c114a64adf9a53add80df98c588a0e9c059fb (diff)
downloadports-826a3df314d6f9363e6e3630e1518ba2fe8f4e44.tar.gz
ports-826a3df314d6f9363e6e3630e1518ba2fe8f4e44.zip
- Update GNU coreutils to the latest version 8.31
- Enable tests via our framework (set the TEST_TARGET) - Remove MAKE_JOBS_UNSAFE which was added in r306718 (due to "help2man: can't get '--help' info from man/stty.td/stty") as it looks like this very error had been fixed long time ago, per their ChangeLog: 2015-03-06 Padraig Brady <P@draigBrady.com> build: fix make dependencies for test.1 In certain parallel build situations this would give the error: help2man: can't get `--help' info from man/test.td/[ Makefile:14189: recipe for target 'man/test.1' failed That said, the port should have been jobs-safe for about four years now, but for some strange reason nobody had noticed that. Approved by: maintainer
Notes
Notes: svn path=/head/; revision=495588
Diffstat (limited to 'sysutils/coreutils/Makefile')
-rw-r--r--sysutils/coreutils/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/sysutils/coreutils/Makefile b/sysutils/coreutils/Makefile
index 345bb11f1078..3821f8f87efc 100644
--- a/sysutils/coreutils/Makefile
+++ b/sysutils/coreutils/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= coreutils
-PORTVERSION= 8.30
-PORTREVISION= 1
+PORTVERSION= 8.31
CATEGORIES= sysutils textproc
MASTER_SITES= GNU
@@ -16,10 +15,9 @@ CONFLICTS= idutils-[0-9]*
USES= cpe gmake iconv perl5 charsetfix tar:xz
CPE_VENDOR= gnu
-USE_PERL5= build # build - required for tests and man page generation
+USE_PERL5= build # required for tests and man page generation
USE_LDCONFIG= yes
-
-MAKE_JOBS_UNSAFE= yes
+TEST_TARGET= check
GNU_CONFIGURE= yes
# A rather nasty hack to stop gnustat from conflicting with base gstat
@@ -52,7 +50,4 @@ post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/g* \
${STAGEDIR}${PREFIX}/libexec/coreutils/libstdbuf.so
-#regression-test: build
-# (cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} check)
-
.include <bsd.port.mk>