aboutsummaryrefslogtreecommitdiff
path: root/sysutils/coreutils
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2024-02-27 06:02:22 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2024-02-27 06:02:22 +0000
commite01e0ed77d124c83e8a533356b32312d458eef21 (patch)
tree8ce2e322d37abd371ba2f830193c6d82bf19f774 /sysutils/coreutils
parent79fe36a9783404fe0af3ff0902f645a9b2eaabbb (diff)
downloadports-e01e0ed77d124c83e8a533356b32312d458eef21.tar.gz
ports-e01e0ed77d124c83e8a533356b32312d458eef21.zip
sysutils/coreutils: Fix malformed conditional expression
Diffstat (limited to 'sysutils/coreutils')
-rw-r--r--sysutils/coreutils/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/sysutils/coreutils/Makefile b/sysutils/coreutils/Makefile
index cc98dfcb555c..86d9611eee5a 100644
--- a/sysutils/coreutils/Makefile
+++ b/sysutils/coreutils/Makefile
@@ -24,9 +24,6 @@ GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
# bugs.freebsd.org/160060
CONFIGURE_ARGS= --program-prefix=g \
--program-transform-name=s/stat/nustat/
-.if ${ARCH} == i386
-CONFIGURE_ARGS+= --disable-year2038
-.endif
CONFIGURE_ENV= FORCE_UNSAFE_CONFIGURE=1
CONFLICTS_INSTALL= gdu geneweb gexpr rubygem-god # bin/gdu bin/gexpr bin/god bin/gwc
@@ -48,4 +45,10 @@ post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/g* \
${STAGEDIR}${PREFIX}/libexec/coreutils/libstdbuf.so
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == i386
+CONFIGURE_ARGS+= --disable-year2038
+.endif
+
.include <bsd.port.mk>