aboutsummaryrefslogtreecommitdiff
path: root/sysutils/curly
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-11-13 15:39:38 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-11-13 15:39:38 +0000
commit53f144b1419955aecce42da5e11dcaca9a8ad6cd (patch)
tree85f7a5f2e104e4b38a00ac76a75005a838cb4e81 /sysutils/curly
parentffbd8ed448b162b91fe427282e18785beab08cb8 (diff)
downloadports-53f144b1419955aecce42da5e11dcaca9a8ad6cd.tar.gz
ports-53f144b1419955aecce42da5e11dcaca9a8ad6cd.zip
Add curly 3.4, generalize listed filenames to csh-extended glob
patterns. Submitted by: Stephen Gunn <csg@fedex.com>
Notes
Notes: svn path=/head/; revision=70037
Diffstat (limited to 'sysutils/curly')
-rw-r--r--sysutils/curly/Makefile41
-rw-r--r--sysutils/curly/distinfo1
-rw-r--r--sysutils/curly/files/patch-machine.h13
-rw-r--r--sysutils/curly/pkg-comment1
-rw-r--r--sysutils/curly/pkg-descr2
-rw-r--r--sysutils/curly/pkg-plist2
6 files changed, 60 insertions, 0 deletions
diff --git a/sysutils/curly/Makefile b/sysutils/curly/Makefile
new file mode 100644
index 000000000000..2a452e88a1de
--- /dev/null
+++ b/sysutils/curly/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: curly
+# Date created: Nov 1 2002
+# Whom: Stephen Gunn <csg@fedex.com>, <csg@waterspout.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= curly
+PORTVERSION= 3.4
+CATEGORIES= sysutils
+MASTER_SITES= ftp://ftp.physics.purdue.edu/pub/pundits/ \
+ http://archive.progeny.com/pundits/
+DISTNAME= xapply-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= csg@fedex.com
+
+BUILD_DEPENDS= makeme:${PORTSDIR}/devel/msrc0 \
+ mkcmd:${PORTSDIR}/devel/mkcmd
+
+USE_REINPLACE= yes
+MAKE_FLAGS=
+MAKEFILE=
+MAN1= ${PORTNAME}.1
+MLINKS= ${PORTNAME}.1 un${PORTNAME}.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,CFLAGS=,CFLAGS+=,' -e 's,^DEBUG,#DEBUG,'\
+ -e 's,gcc,${CC},' ${WRKSRC}/bin/curly/Make.host
+
+do-build:
+ ( cd ${WRKSRC}/bin/${PORTNAME} && ${SETENV} ${MAKE_ENV} makeme \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET} )
+
+do-install:
+ ( cd ${WRKSRC}/bin/curly && ${SETENV} ${MAKENV} makeme \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET} )
+ ${INSTALL_MAN} ${WRKSRC}/bin/${PORTNAME}/${PORTNAME}.man \
+ ${PREFIX}/man/man1/${PORTNAME}.1
+
+.include <bsd.port.mk>
diff --git a/sysutils/curly/distinfo b/sysutils/curly/distinfo
new file mode 100644
index 000000000000..71994d72b2f5
--- /dev/null
+++ b/sysutils/curly/distinfo
@@ -0,0 +1 @@
+MD5 (xapply-3.4.tgz) = 6e8b976cd3696c3d478e61104cc866e9
diff --git a/sysutils/curly/files/patch-machine.h b/sysutils/curly/files/patch-machine.h
new file mode 100644
index 000000000000..417f055257f2
--- /dev/null
+++ b/sysutils/curly/files/patch-machine.h
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- bin/curly/machine.h.orig Wed Nov 13 08:08:13 2002
++++ bin/curly/machine.h Wed Nov 13 08:08:48 2002
+@@ -19,7 +19,7 @@
+ #endif
+
+ #if !defined(NEED_MALLOC_EXTERN)
+-#define NEED_MALLOC_EXTERN (!USE_MALLOC_H && !defined(NEXT2) && !defined(IRIX) && !defined(BSDI))
++#define NEED_MALLOC_EXTERN (!USE_MALLOC_H && !defined(NEXT2) && !defined(IRIX) && !defined(BSDI) && !defined(FREEBSD))
+ #endif
+
+ #if !defined(USE_STDLIB)
diff --git a/sysutils/curly/pkg-comment b/sysutils/curly/pkg-comment
new file mode 100644
index 000000000000..04a71ddfea5d
--- /dev/null
+++ b/sysutils/curly/pkg-comment
@@ -0,0 +1 @@
+Generalize listed filenames to csh-extended glob patterns
diff --git a/sysutils/curly/pkg-descr b/sysutils/curly/pkg-descr
new file mode 100644
index 000000000000..6077f44de4aa
--- /dev/null
+++ b/sysutils/curly/pkg-descr
@@ -0,0 +1,2 @@
+Curly filters a list of filenames to a greatest-common-denominator
+glob pattern used by most shells.
diff --git a/sysutils/curly/pkg-plist b/sysutils/curly/pkg-plist
new file mode 100644
index 000000000000..05c0f2ef3a2e
--- /dev/null
+++ b/sysutils/curly/pkg-plist
@@ -0,0 +1,2 @@
+bin/curly
+bin/uncurly