aboutsummaryrefslogtreecommitdiff
path: root/sysutils/devcpu-data/Makefile
diff options
context:
space:
mode:
authorMark Johnston <markj@FreeBSD.org>2018-08-28 21:51:59 +0000
committerMark Johnston <markj@FreeBSD.org>2018-08-28 21:51:59 +0000
commit8eb2352e2177e92735976f76cb7353fc3f44e082 (patch)
tree7b604544df08ef6f5dd372a4e52ab98e6c5365ac /sysutils/devcpu-data/Makefile
parentc237fd3384719903c314280cd407091cf2c9e8ba (diff)
downloadports-8eb2352e2177e92735976f76cb7353fc3f44e082.tar.gz
ports-8eb2352e2177e92735976f76cb7353fc3f44e082.zip
sysutils/devcpu-data: Provide a file for loading Intel updates at boot
Extend the port so that users may easily apply microcode updates using the method implemented in src r337715. For now, this just consists of providing all Intel microcode update files concatenated together as a single blob in /boot/firmware. Approved by: sbruno Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D16924
Notes
Notes: svn path=/head/; revision=478330
Diffstat (limited to 'sysutils/devcpu-data/Makefile')
-rw-r--r--sysutils/devcpu-data/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/sysutils/devcpu-data/Makefile b/sysutils/devcpu-data/Makefile
index 069034da8115..035751964878 100644
--- a/sysutils/devcpu-data/Makefile
+++ b/sysutils/devcpu-data/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= data
-PORTVERSION= 1.19
+PORTVERSION= 1.20
CATEGORIES= sysutils
MASTER_SITES= https://downloadmirror.intel.com/28039/eng/:intel \
LOCAL/sbruno:amd
@@ -23,11 +23,13 @@ NO_ARCH= yes
NO_WRKSUBDIR= yes
DATADIR= ${PREFIX}/share/cpucontrol
+FWDIR= /boot/firmware
USE_RC_SUBR= microcode_update
post-extract:
${CP} -p ${FILESDIR}/Makefile ${FILESDIR}/ucode-split.c ${WRKSRC}
+ ${CAT} ${WRKSRC}/intel-ucode/* ${WRKSRC}/intel-ucode-with-caveats/* > ${WRKSRC}/intel-ucode.bin
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}/
@@ -36,5 +38,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/microcode_amd_fam16h.bin ${STAGEDIR}${DATADIR}/
${INSTALL_DATA} ${WRKSRC}/microcode_amd_fam17h.bin ${STAGEDIR}${DATADIR}/
${INSTALL_DATA} ${WRKSRC}/mcodes/* ${STAGEDIR}${DATADIR}/
+ ${MKDIR} ${STAGEDIR}${FWDIR}
+ ${INSTALL_DATA} ${WRKSRC}/intel-ucode.bin ${STAGEDIR}${FWDIR}/
.include <bsd.port.mk>