aboutsummaryrefslogtreecommitdiff
path: root/sysutils/devcpu-data/Makefile
diff options
context:
space:
mode:
authorSean Bruno <sbruno@FreeBSD.org>2018-05-28 17:08:35 +0000
committerSean Bruno <sbruno@FreeBSD.org>2018-05-28 17:08:35 +0000
commit94732c2282c090a2891acb41ee4557a749030fd3 (patch)
tree9d974f39395d5181e91e6b1c239524b1786593c3 /sysutils/devcpu-data/Makefile
parent017436c004d8e87277222cf9900e146aee52c4f1 (diff)
downloadports-94732c2282c090a2891acb41ee4557a749030fd3.tar.gz
ports-94732c2282c090a2891acb41ee4557a749030fd3.zip
sysutils/devcpu-data
- Update AMD microcode https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/commit/amd-ucode?id=7518922bd5b98b137af7aaf3c836f5a498e91609 https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/commit/amd-ucode?id=77101513943ef198e2050667c87abf19e6cbb1d8 At least on my FX-8150, I can run spectre test code and it fails after applying the 15h update. I have not seen a system that needs the 17h update, and we think this only covers EPYC processors, not Ryzen. When I tested this on an EPYC at work, the tools detected that the 17h microcode was correct but uneeded for the Dell system. PR: 228567 Sponsored by: Limelight Networks Differential Revision: https://reviews.freebsd.org/D15523
Notes
Notes: svn path=/head/; revision=471058
Diffstat (limited to 'sysutils/devcpu-data/Makefile')
-rw-r--r--sysutils/devcpu-data/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/sysutils/devcpu-data/Makefile b/sysutils/devcpu-data/Makefile
index 901adbf71d63..f9578f5d679e 100644
--- a/sysutils/devcpu-data/Makefile
+++ b/sysutils/devcpu-data/Makefile
@@ -2,14 +2,13 @@
# $FreeBSD$
PORTNAME= data
-PORTVERSION= 1.16
-PORTREVISION= 2
+PORTVERSION= 1.17
CATEGORIES= sysutils
MASTER_SITES= https://downloadmirror.intel.com/27776/eng/:intel \
LOCAL/sbruno:amd
PKGNAMEPREFIX= devcpu-
DISTFILES= microcode-20180425.tgz:intel \
- amd64-microcode_3.20171205.1.tar.xz:amd
+ amd64-microcode.20180525.tar.xz:amd
MAINTAINER= sbruno@freebsd.org
COMMENT= Intel and AMD CPUs microcode updates
@@ -32,10 +31,10 @@ post-extract:
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}/
- ${INSTALL_DATA} ${WRKSRC}/amd64-microcode-3.20171205.1/microcode_amd.bin ${STAGEDIR}${DATADIR}/
- ${INSTALL_DATA} ${WRKSRC}/amd64-microcode-3.20171205.1/microcode_amd_fam15h.bin ${STAGEDIR}${DATADIR}/
- ${INSTALL_DATA} ${WRKSRC}/amd64-microcode-3.20171205.1/microcode_amd_fam16h.bin ${STAGEDIR}${DATADIR}/
- ${INSTALL_DATA} ${WRKSRC}/amd64-microcode-3.20171205.1/microcode_amd_fam17h.bin ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/microcode_amd.bin ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/microcode_amd_fam15h.bin ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/microcode_amd_fam16h.bin ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/microcode_amd_fam17h.bin ${STAGEDIR}${DATADIR}/
${INSTALL_DATA} ${WRKSRC}/mcodes/* ${STAGEDIR}${DATADIR}/
.include <bsd.port.mk>