aboutsummaryrefslogtreecommitdiff
path: root/sysutils/devcpu/Makefile
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2007-02-01 21:52:14 +0000
committerStanislav Sedov <stas@FreeBSD.org>2007-02-01 21:52:14 +0000
commitcef4580bcfeed80ac9122c293a2bbf5eaaccf146 (patch)
treeb803f69e0e32d0e9cf6af9c34301d27e038db57e /sysutils/devcpu/Makefile
parent6e321a8d108ca02c3e1665ebfedd81e1ec7d76a3 (diff)
downloadports-cef4580bcfeed80ac9122c293a2bbf5eaaccf146.tar.gz
ports-cef4580bcfeed80ac9122c293a2bbf5eaaccf146.zip
- Update to 0.8
- Add rcNG startup script that allows update cpucodes on startup - Add utility to extract cpucodes from Award BIOS update images - Add additional amd microcode upodate extracted from update images, provided by pav@ Thanks to netchild@ and pav@ for suggestions and information regarding BIOS updates.
Notes
Notes: svn path=/head/; revision=183891
Diffstat (limited to 'sysutils/devcpu/Makefile')
-rw-r--r--sysutils/devcpu/Makefile21
1 files changed, 20 insertions, 1 deletions
diff --git a/sysutils/devcpu/Makefile b/sysutils/devcpu/Makefile
index d63ccc9265b5..c531c7924f08 100644
--- a/sysutils/devcpu/Makefile
+++ b/sysutils/devcpu/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= devcpu
-PORTVERSION= 0.7
+PORTVERSION= 0.8
PORTREVISION= 0
CATEGORIES= sysutils
MASTER_SITES= http://mbsd.msk.ru/dist/
@@ -15,6 +15,11 @@ MAINTAINER= stas@FreeBSD.org
COMMENT= Kernel module that provides access to i386 MSRs and cpuid info
USE_BZIP2= yes
+USE_RC_SUBR= devcpu
+USE_RUBY= yes
+RUBY_NO_BUILD_DEPENDS= yes
+RUBY_NO_RUN_DEPENDS= yes
+RUBY_SHEBANG_FILES= tools/extract_mcodes.rb
ONLY_FOR_ARCHS= i386 amd64
NO_PACKAGE= depends on kernel
@@ -23,6 +28,8 @@ PLIST_SUB= KMODDIR="${KMODDIR:C,^/,,}"
KMODDIR= /boot/modules
MAKE_ENV+= KMODDIR="${KMODDIR}"
+OPTIONS= EXTRACTOR "Install Award Bios microcode extracting utility" off
+
MAN4= cpu.4
MAN8= cpu_microcode_tool.8
@@ -32,6 +39,14 @@ MAN8= cpu_microcode_tool.8
IGNORE= not supported
.endif
+.if defined(WITH_EXTRACTOR)
+RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/mmap.so:${PORTSDIR}/devel/ruby-mmap \
+ ${RUBY_SITEARCHLIBDIR}/lhalib.so:${PORTSDIR}/archivers/ruby-lha
+PLIST_SUB+= EXTRACTOR=""
+.else
+PLIST_SUB+= EXTRACTOR="@comment "
+.endif
+
MAKE_ENV+= KMODDIR="${KMODDIR}" \
BINDIR="${PREFIX}/bin"
@@ -57,6 +72,10 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
.endif
+.if defined(WITH_EXTRACTOR)
+ ${INSTALL_SCRIPT} ${WRKSRC}/tools/extract_mcodes.rb ${PREFIX}/libexec/
+.endif
+
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>