aboutsummaryrefslogtreecommitdiff
path: root/sysutils/djmount
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2012-02-12 14:10:36 +0000
committerPav Lucistnik <pav@FreeBSD.org>2012-02-12 14:10:36 +0000
commita7dc240b004f59257feddaf92ed43a76371993a8 (patch)
tree58e5467b7a5a26781c189d98a055e62a5733edae /sysutils/djmount
parent3239db5f44bc288077470440520075d1314ee43f (diff)
downloadports-a7dc240b004f59257feddaf92ed43a76371993a8.tar.gz
ports-a7dc240b004f59257feddaf92ed43a76371993a8.zip
- Unbreak
Submitted by: Vyacheslav I. <yohimba@mail.ru>
Notes
Notes: svn path=/head/; revision=291037
Diffstat (limited to 'sysutils/djmount')
-rw-r--r--sysutils/djmount/Makefile2
-rw-r--r--sysutils/djmount/files/patch-djmount35
2 files changed, 35 insertions, 2 deletions
diff --git a/sysutils/djmount/Makefile b/sysutils/djmount/Makefile
index c1a5639de4e6..9c38b815ed06 100644
--- a/sysutils/djmount/Makefile
+++ b/sysutils/djmount/Makefile
@@ -19,8 +19,6 @@ LIB_DEPENDS= fuse.2:${PORTSDIR}/sysutils/fusefs-libs \
BUILD_DEPENDS= iconv:${PORTSDIR}/converters/libiconv
RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
-BROKEN= does not compile
-
PLIST_FILES= bin/${PORTNAME}
GNU_CONFIGURE= yes
USE_GNOME= pkgconfig
diff --git a/sysutils/djmount/files/patch-djmount b/sysutils/djmount/files/patch-djmount
index fdaf6bd72e1f..7bb96331cb7e 100644
--- a/sysutils/djmount/files/patch-djmount
+++ b/sysutils/djmount/files/patch-djmount
@@ -61,3 +61,38 @@ diff -purN djmount/string_util.c djmount/string_util.c
res = talloc_size (result_context, size+1);
if (res) {
rewind (ss->file);
+diff -purN djmount/content_dir.c djmount/content_dir.c
+--- djmount/content_dir.c 2006-08-28 05:12:20.000000000 +0900
++++ djmount/content_dir.c 2012-02-12 21:14:11.000000000 +0900
+@@ -302,7 +302,7 @@ BrowseOrSearchAll (ContentDir* cds,
+ // Note: it is allowed to have nb_matched == 0 if it cannot be
+ // computed by the CDS.
+ int nb_retry = 0;
+- while (PtrArray_GetSize (objects) < nb_matched && nb_retry++ < 2) {
++ while (PtrArray_GetSize (objects) < nb_matched && ++nb_retry) {
+ Log_Printf (LOG_WARNING,
+ "ContentDir_BrowseId ObjectId=%s : "
+ "got %d results, expected %d. Retry %d ...",
+diff -purN djmount/content_dir.h djmount/content_dir.h
+--- djmount/content_dir.h 2006-08-28 05:12:20.000000000 +0900
++++ djmount/content_dir.h 2012-02-12 21:14:11.000000000 +0900
+@@ -46,7 +46,7 @@ typedef uint_fast32_t ContentDir_Index;
+
+ // ContentDirectory ServiceType
+ #define CONTENT_DIR_SERVICE_TYPE \
+- "urn:schemas-upnp-org:service:ContentDirectory:1"
++ "urn:schemas-upnp-org:service:ContentDirectory:2"
+
+
+
+diff -purN djmount/upnp_util.h djmount/upnp_util.h
+--- djmount/upnp_util.h 2006-08-28 05:12:20.000000000 +0900
++++ djmount/upnp_util.h 2012-02-12 21:14:11.000000000 +0900
+@@ -28,6 +28,7 @@
+
+
+ #include <upnp/upnptools.h>
++#include <upnp/upnp.h>
+
+
+ #ifdef __cplusplus