aboutsummaryrefslogtreecommitdiff
path: root/sysutils/docker-compose
diff options
context:
space:
mode:
authorNikolai Lifanov <lifanov@FreeBSD.org>2017-04-19 15:37:04 +0000
committerNikolai Lifanov <lifanov@FreeBSD.org>2017-04-19 15:37:04 +0000
commitec30fd6508c1130bcfe0e19f098c3aed2e7ea440 (patch)
tree27b610f2805003f29612026641ef1f3bac3426b5 /sysutils/docker-compose
parent79d35473938101b4029444e40a6176597963b1fe (diff)
downloadports-ec30fd6508c1130bcfe0e19f098c3aed2e7ea440.tar.gz
ports-ec30fd6508c1130bcfe0e19f098c3aed2e7ea440.zip
add sysutils/docker-compose
Compose is a tool for defining and running multi-container Docker applications. With Compose, you use a Compose file to configure your application's services. Then, using a single command, you create and start all the services from your configuration.
Notes
Notes: svn path=/head/; revision=438886
Diffstat (limited to 'sysutils/docker-compose')
-rw-r--r--sysutils/docker-compose/Makefile44
-rw-r--r--sysutils/docker-compose/distinfo3
-rw-r--r--sysutils/docker-compose/pkg-descr6
3 files changed, 53 insertions, 0 deletions
diff --git a/sysutils/docker-compose/Makefile b/sysutils/docker-compose/Makefile
new file mode 100644
index 000000000000..eafebdbd1f52
--- /dev/null
+++ b/sysutils/docker-compose/Makefile
@@ -0,0 +1,44 @@
+# $FreeBSD$
+
+PORTNAME= docker-compose
+PORTVERSION= 1.12.0
+CATEGORIES= sysutils python
+MASTER_SITES= CHEESESHOP
+
+MAINTAINER= lifanov@FreeBSD.org
+COMMENT= Define and run multi-container applications with Docker
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>=3.11:devel/py-yaml \
+ ${PYTHON_PKGNAMEPREFIX}cached-property>=1.2.0:devel/py-cached-property \
+ ${PYTHON_PKGNAMEPREFIX}colorama>=0.3.7:devel/py-colorama \
+ ${PYTHON_PKGNAMEPREFIX}docker>=2.2.1:sysutils/py-docker \
+ ${PYTHON_PKGNAMEPREFIX}dockerpty>=0.4.1:devel/py-dockerpty \
+ ${PYTHON_PKGNAMEPREFIX}docopt>=0.6.1:devel/py-docopt \
+ ${PYTHON_PKGNAMEPREFIX}ipaddress>=1.0.16:net/py-ipaddress \
+ ${PYTHON_PKGNAMEPREFIX}jsonschema>=2.5.1:devel/py-jsonschema \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.11.1:www/py-requests \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.10.0:devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}texttable>=0.8.4:textproc/py-texttable \
+ ${PYTHON_PKGNAMEPREFIX}websocket-client>=0.32.0:www/py-websocket-client
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_SUFFIX} < 35
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}backports.ssl_match_hostname>0:security/py-backports.ssl_match_hostname
+.endif
+
+.if ${PYTHON_SUFFIX} < 34
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}enum34>0:devel/py-enum34
+.endif
+
+.if ${PYTHON_SUFFIX} < 32
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}functools32>0:devel/py-functools32
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/docker-compose/distinfo b/sysutils/docker-compose/distinfo
new file mode 100644
index 000000000000..bd16078620ac
--- /dev/null
+++ b/sysutils/docker-compose/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1491864844
+SHA256 (docker-compose-1.12.0.tar.gz) = 3da6f465eac5704393d8acd95b1923ce0bda3f0312883527c92dfab7de5b313e
+SIZE (docker-compose-1.12.0.tar.gz) = 198453
diff --git a/sysutils/docker-compose/pkg-descr b/sysutils/docker-compose/pkg-descr
new file mode 100644
index 000000000000..30e86ab1971e
--- /dev/null
+++ b/sysutils/docker-compose/pkg-descr
@@ -0,0 +1,6 @@
+Compose is a tool for defining and running multi-container Docker applications.
+With Compose, you use a Compose file to configure your application's services.
+Then, using a single command, you create and start all the services from your
+configuration.
+
+WWW: https://github.com/docker/compose/