aboutsummaryrefslogtreecommitdiff
path: root/sysutils/docker-credential-pass
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2018-08-03 18:59:18 +0000
committerRene Ladan <rene@FreeBSD.org>2018-08-03 18:59:18 +0000
commitdb8f15fcd57692d0ba97adaa1791c231e923df99 (patch)
tree234dc6d0d8a0513dbd028ffaeb98e81f0f176d23 /sysutils/docker-credential-pass
parent07e4951365f83bc3c3252e635303c061b8186b03 (diff)
downloadports-db8f15fcd57692d0ba97adaa1791c231e923df99.tar.gz
ports-db8f15fcd57692d0ba97adaa1791c231e923df99.zip
eep Docker credentials safe.
WWW: https://github.com/docker/docker-credential-helpers PR: 230338 Submitted by: Dmitri Goutnik dg@syrec.org
Notes
Notes: svn path=/head/; revision=476317
Diffstat (limited to 'sysutils/docker-credential-pass')
-rw-r--r--sysutils/docker-credential-pass/Makefile33
-rw-r--r--sysutils/docker-credential-pass/distinfo3
-rw-r--r--sysutils/docker-credential-pass/pkg-descr4
3 files changed, 40 insertions, 0 deletions
diff --git a/sysutils/docker-credential-pass/Makefile b/sysutils/docker-credential-pass/Makefile
new file mode 100644
index 000000000000..8aa886c76f9d
--- /dev/null
+++ b/sysutils/docker-credential-pass/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= docker-credential-pass
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.6.1
+CATEGORIES= sysutils
+
+MAINTAINER= dg@syrec.org
+COMMENT= Helper to use sysutils/password-store as Docker credentials store
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/go:lang/go
+RUN_DEPENDS= ${LOCALBASE}/bin/pass:sysutils/password-store
+
+USE_GITHUB= yes
+GH_ACCOUNT= docker
+GH_PROJECT= docker-credential-helpers
+GH_SUBDIR= src/github.com/docker/docker-credential-helpers
+
+PLIST_FILES= bin/docker-credential-pass
+
+do-build:
+ ${CP} ${WRKSRC}/${GH_SUBDIR}/pass/cmd/main_linux.go ${WRKSRC}/${GH_SUBDIR}/pass/cmd/main_freebsd.go
+ ${CP} ${WRKSRC}/${GH_SUBDIR}/pass/pass_linux.go ${WRKSRC}/${GH_SUBDIR}/pass/pass_freebsd.go
+ cd ${WRKSRC}/${GH_SUBDIR}/pass && \
+ ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go build -o ${PORTNAME} ./cmd
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${GH_SUBDIR}/pass/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/sysutils/docker-credential-pass/distinfo b/sysutils/docker-credential-pass/distinfo
new file mode 100644
index 000000000000..780a069b4fba
--- /dev/null
+++ b/sysutils/docker-credential-pass/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1533314093
+SHA256 (docker-docker-credential-helpers-v0.6.1_GH0.tar.gz) = 9b36ae15d5bceaaf3496b80413acafa6325c633af3ae211ce10724dfa7046883
+SIZE (docker-docker-credential-helpers-v0.6.1_GH0.tar.gz) = 27723
diff --git a/sysutils/docker-credential-pass/pkg-descr b/sysutils/docker-credential-pass/pkg-descr
new file mode 100644
index 000000000000..153182cf1739
--- /dev/null
+++ b/sysutils/docker-credential-pass/pkg-descr
@@ -0,0 +1,4 @@
+docker-credential-pass provides a helper to use sysutils/password-store to
+keep Docker credentials safe.
+
+WWW: https://github.com/docker/docker-credential-helpers