aboutsummaryrefslogtreecommitdiff
path: root/sysutils/dvdbackup
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2020-04-01 08:52:40 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2020-04-01 08:52:40 +0000
commit75d7fd5db6a6000bd087e29d81c6b15616d9301b (patch)
tree7e844a7ab5759d36ad02b6e972ccb3914b5ee970 /sysutils/dvdbackup
parent0c29806abd65ce6b8564ebfe06d037a31c4e87ad (diff)
downloadports-75d7fd5db6a6000bd087e29d81c6b15616d9301b.tar.gz
ports-75d7fd5db6a6000bd087e29d81c6b15616d9301b.zip
Actually add patch (forgotten in previous commit). Also mention that parallel
to the launchpad bug a PR was created. PR: 245228 Submitted by: felix@palmen-it.de
Notes
Notes: svn path=/head/; revision=530205
Diffstat (limited to 'sysutils/dvdbackup')
-rw-r--r--sysutils/dvdbackup/Makefile2
-rw-r--r--sysutils/dvdbackup/files/patch-src__dvdbackup.c18
-rw-r--r--sysutils/dvdbackup/files/patch-src_dvdbackup.c102
3 files changed, 103 insertions, 19 deletions
diff --git a/sysutils/dvdbackup/Makefile b/sysutils/dvdbackup/Makefile
index 8ddffe038772..887651c2e56c 100644
--- a/sysutils/dvdbackup/Makefile
+++ b/sysutils/dvdbackup/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dvdbackup
PORTVERSION= 0.4.2
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= sysutils multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
diff --git a/sysutils/dvdbackup/files/patch-src__dvdbackup.c b/sysutils/dvdbackup/files/patch-src__dvdbackup.c
deleted file mode 100644
index cc414effd320..000000000000
--- a/sysutils/dvdbackup/files/patch-src__dvdbackup.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- ./src/dvdbackup.c.orig 2012-06-24 03:10:29.000000000 +0200
-+++ ./src/dvdbackup.c 2012-07-28 13:57:54.000000000 +0200
-@@ -1546,7 +1546,6 @@
-
- title_set_info = DVDGetFileSet(_dvd);
- if (!title_set_info) {
-- DVDClose(_dvd);
- return(1);
- }
-
-@@ -1573,7 +1572,6 @@
- title_set_info = DVDGetFileSet(_dvd);
-
- if (!title_set_info) {
-- DVDClose(_dvd);
- return(1);
- }
-
diff --git a/sysutils/dvdbackup/files/patch-src_dvdbackup.c b/sysutils/dvdbackup/files/patch-src_dvdbackup.c
new file mode 100644
index 000000000000..b7204ee40301
--- /dev/null
+++ b/sysutils/dvdbackup/files/patch-src_dvdbackup.c
@@ -0,0 +1,102 @@
+--- src/dvdbackup.c.orig 2012-06-24 01:10:29 UTC
++++ src/dvdbackup.c
+@@ -1132,7 +1132,7 @@ static int DVDCopyIfoBup(dvd_reader_t* dvd, title_set_
+ int size;
+
+ /* DVD handler */
+- ifo_handle_t* ifo_file = NULL;
++ dvd_file_t* ifo_file = NULL;
+
+
+ if (title_set_info->number_of_title_sets + 1 < title_set) {
+@@ -1181,7 +1181,7 @@ static int DVDCopyIfoBup(dvd_reader_t* dvd, title_set_
+ if ((streamout_ifo = open(targetname_ifo, O_WRONLY | O_CREAT | O_TRUNC, 0666)) == -1) {
+ fprintf(stderr, _("Error creating %s\n"), targetname_ifo);
+ perror(PACKAGE);
+- ifoClose(ifo_file);
++ DVDCloseFile(ifo_file);
+ free(buffer);
+ close(streamout_ifo);
+ close(streamout_bup);
+@@ -1191,7 +1191,7 @@ static int DVDCopyIfoBup(dvd_reader_t* dvd, title_set_
+ if ((streamout_bup = open(targetname_bup, O_WRONLY | O_CREAT | O_TRUNC, 0666)) == -1) {
+ fprintf(stderr, _("Error creating %s\n"), targetname_bup);
+ perror(PACKAGE);
+- ifoClose(ifo_file);
++ DVDCloseFile(ifo_file);
+ free(buffer);
+ close(streamout_ifo);
+ close(streamout_bup);
+@@ -1200,31 +1200,31 @@ static int DVDCopyIfoBup(dvd_reader_t* dvd, title_set_
+
+ /* Copy VIDEO_TS.IFO, since it's a small file try to copy it in one shot */
+
+- if ((ifo_file = ifoOpen(dvd, title_set))== 0) {
++ if ((ifo_file = DVDOpenFile(dvd, title_set, DVD_READ_INFO_FILE))== 0) {
+ fprintf(stderr, _("Failed opening IFO for title set %d\n"), title_set);
+- ifoClose(ifo_file);
++ DVDCloseFile(ifo_file);
+ free(buffer);
+ close(streamout_ifo);
+ close(streamout_bup);
+ return 1;
+ }
+
+- size = DVDFileSize(ifo_file->file) * DVD_VIDEO_LB_LEN;
++ size = DVDFileSize(ifo_file) * DVD_VIDEO_LB_LEN;
+
+ if ((buffer = (unsigned char *)malloc(size * sizeof(unsigned char))) == NULL) {
+ perror(PACKAGE);
+- ifoClose(ifo_file);
++ DVDCloseFile(ifo_file);
+ free(buffer);
+ close(streamout_ifo);
+ close(streamout_bup);
+ return 1;
+ }
+
+- DVDFileSeek(ifo_file->file, 0);
++ DVDFileSeek(ifo_file, 0);
+
+- if (DVDReadBytes(ifo_file->file,buffer,size) != size) {
++ if (DVDReadBytes(ifo_file,buffer,size) != size) {
+ fprintf(stderr, _("Error reading IFO for title set %d\n"), title_set);
+- ifoClose(ifo_file);
++ DVDCloseFile(ifo_file);
+ free(buffer);
+ close(streamout_ifo);
+ close(streamout_bup);
+@@ -1234,7 +1234,7 @@ static int DVDCopyIfoBup(dvd_reader_t* dvd, title_set_
+
+ if (write(streamout_ifo,buffer,size) != size) {
+ fprintf(stderr, _("Error writing %s\n"),targetname_ifo);
+- ifoClose(ifo_file);
++ DVDCloseFile(ifo_file);
+ free(buffer);
+ close(streamout_ifo);
+ close(streamout_bup);
+@@ -1243,7 +1243,7 @@ static int DVDCopyIfoBup(dvd_reader_t* dvd, title_set_
+
+ if (write(streamout_bup,buffer,size) != size) {
+ fprintf(stderr, _("Error writing %s\n"),targetname_bup);
+- ifoClose(ifo_file);
++ DVDCloseFile(ifo_file);
+ free(buffer);
+ close(streamout_ifo);
+ close(streamout_bup);
+@@ -1546,7 +1546,6 @@ int DVDMirror(dvd_reader_t * _dvd, char * targetdir,ch
+
+ title_set_info = DVDGetFileSet(_dvd);
+ if (!title_set_info) {
+- DVDClose(_dvd);
+ return(1);
+ }
+
+@@ -1573,7 +1572,6 @@ int DVDMirrorTitleSet(dvd_reader_t * _dvd, char * targ
+ title_set_info = DVDGetFileSet(_dvd);
+
+ if (!title_set_info) {
+- DVDClose(_dvd);
+ return(1);
+ }
+