aboutsummaryrefslogtreecommitdiff
path: root/sysutils/e2fsprogs/Makefile
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-02-06 15:42:06 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-02-06 15:42:06 +0000
commitcf41c5e996bc5b14022f02d0b60deb7ed4d717d2 (patch)
treec10ce5c1b6863b9d438f563b36c12de51313522a /sysutils/e2fsprogs/Makefile
parent4f9de99695bd52db901c722920d42f130b2aa6e1 (diff)
downloadports-cf41c5e996bc5b14022f02d0b60deb7ed4d717d2.tar.gz
ports-cf41c5e996bc5b14022f02d0b60deb7ed4d717d2.zip
sysutils/e2fsprogs: update to new upstream release v1.46.0
https://git.kernel.org/pub/scm/fs/ext2/e2fsprogs.git/plain/doc/RelNotes/v1.46.0.txt?h=v1.46.0 The major item in porting is to switch from GNU libc's qsort_r() interface to ours, but see https://reviews.freebsd.org/D17083 Also, it appears at cursory glance that it takes the FUSEFS option to get HAVE_PTHREAD_H #defined. Just pass -DHAVE_PTHREAD_H through CPPFLAGS without further investigation. Finally, there appears to be some confusion around __u64 vs. unsigned long long, we get format string complaints. Use <inttypes.h> and leverage the PRIu64 macro. I do not intend to MFH this.
Notes
Notes: svn path=/head/; revision=564228
Diffstat (limited to 'sysutils/e2fsprogs/Makefile')
-rw-r--r--sysutils/e2fsprogs/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index 7ad9a1fbc05e..283682d14df1 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= e2fsprogs
-PORTVERSION= 1.45.7
+PORTVERSION= 1.46.0
PORTREVISION?= 0
CATEGORIES?= sysutils
MASTER_SITES= KERNEL_ORG/linux/kernel/people/tytso/${PORTNAME}/v${PORTVERSION}
@@ -41,7 +41,8 @@ CONFIGURE_ARGS?=--disable-fsck \
--without-included-gettext \
LDFLAGS='${LDFLAGS} -L${LOCALBASE}/lib -Wl,--rpath -Wl,${LOCALBASE}/lib/e2fsprogs'
CONFIGURE_ENV?= LIBS='-Wl,--as-needed ${LIBS} -lexecinfo -lelf'
-CPPFLAGS+= -I${WRKSRC}/lib -I${LOCALBASE}/include # -D_EXT2_USE_C_VERSIONS
+# apparently HAVE_PTHREAD_H checks go missing if the FUSEFS option is unset, force it:
+CPPFLAGS+= -I${WRKSRC}/lib -I${LOCALBASE}/include -DHAVE_PTHREAD_H # -D_EXT2_USE_C_VERSIONS
MAKE_ARGS+= pkgconfigdir='${PREFIX}/libdata/pkgconfig'
MAKE_ENV+= CHECK_CMD=@true