aboutsummaryrefslogtreecommitdiff
path: root/sysutils/envconsul
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2017-04-08 16:44:54 +0000
committerSteve Wills <swills@FreeBSD.org>2017-04-08 16:44:54 +0000
commitd5f2e21245865ee8f3a5bda2d269a10851d29d38 (patch)
tree0a5ea387863b5baf2823958a084d39dfb1257e26 /sysutils/envconsul
parent8be9ea07feb37bdc41fa6469386a78be0c2ac537 (diff)
downloadports-d5f2e21245865ee8f3a5bda2d269a10851d29d38.tar.gz
ports-d5f2e21245865ee8f3a5bda2d269a10851d29d38.zip
sysutils/envconsul: update to 0.6.2
Notes
Notes: svn path=/head/; revision=438055
Diffstat (limited to 'sysutils/envconsul')
-rw-r--r--sysutils/envconsul/Makefile56
-rw-r--r--sysutils/envconsul/distinfo67
2 files changed, 14 insertions, 109 deletions
diff --git a/sysutils/envconsul/Makefile b/sysutils/envconsul/Makefile
index ed508f53b1a4..8a330e6202d7 100644
--- a/sysutils/envconsul/Makefile
+++ b/sysutils/envconsul/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= envconsul
-PORTVERSION= 0.6.0
+PORTVERSION= 0.6.2
DISTVERSIONPREFIX= v
CATEGORIES= sysutils
@@ -15,58 +15,24 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/go:lang/go
USE_GITHUB= yes
GH_ACCOUNT= hashicorp
-GH_TUPLE= \
- armon:go-metrics:6c5fa0d:gometrics/src/github.com/armon/go-metrics \
- armon:go-radix:fbd82e8:goradix/src/github.com/armon/go-radix \
- aws:aws-sdk-go:308eaa6:awssdkgo/src/github.com/aws/aws-sdk-go \
- coreos:etcd:6afd8e4:etcd/src/github.com/coreos/etcd \
- fatih:structs:a9f7daa:structs/src/github.com/fatih/structs \
- go-ini:ini:aea5e9f:ini/src/github.com/go-ini/ini \
- go-sql-driver:mysql:527bcd5:mysql/src/github.com/go-sql-driver/mysql \
- hashicorp:consul:809ed36:consul/src/github.com/hashicorp/consul \
- hashicorp:consul-template:ec11b92:consultemplate/src/github.com/hashicorp/consul-template \
- hashicorp:errwrap:7554cd9:errwrap/src/github.com/hashicorp/errwrap \
- hashicorp:go-cleanhttp:875fb67:gocleanhttp/src/github.com/hashicorp/go-cleanhttp \
- hashicorp:go-gatedio:8b8de10:gogatedio/src/github.com/hashicorp/go-gatedio \
- hashicorp:go-msgpack:fa3f638:gomsgpack/src/github.com/hashicorp/go-msgpack \
- hashicorp:go-multierror:d30f099:gomultierror/src/github.com/hashicorp/go-multierror \
- hashicorp:go-syslog:42a2b57:gosyslog/src/github.com/hashicorp/go-syslog \
- hashicorp:go-uuid:2951e8b:gouuid/src/github.com/hashicorp/go-uuid \
- hashicorp:golang-lru:17e3543:golanglru/src/github.com/hashicorp/golang-lru \
- hashicorp:hcl:4de5195:hcl/src/github.com/hashicorp/hcl \
- hashicorp:logutils:0dc08b1:logutils/src/github.com/hashicorp/logutils \
- hashicorp:serf:8d36400:serf/src/github.com/hashicorp/serf \
- hashicorp:vault:97820e2:vault/src/github.com/hashicorp/vault \
- jmespath:go-jmespath:bbaa094:gojmespath/src/github.com/jmespath/go-jmespath \
- lib:pq:ffe986a:pq/src/github.com/lib/pq \
- mitchellh:copystructure:6fc6626:copystructure/src/github.com/mitchellh/copystructure \
- mitchellh:iochan:87b45ff:iochan/src/github.com/mitchellh/iochan \
- mitchellh:mapstructure:281073e:mapstructure/src/github.com/mitchellh/mapstructure \
- mitchellh:reflectwalk:eecf4c7:reflectwalk/src/github.com/mitchellh/reflectwalk \
- samuel:go-zookeeper:913027e:gozookeeper/src/github.com/samuel/go-zookeeper \
- golang:crypto:c8b9e63:crypto/src/golang.org/x/crypto \
- golang:net:271cfc1:net/src/golang.org/x/net \
- hashicorp:envconsul:c2a1a65:envconsul
+GH_SUBDIR= src/github.com/${GH_ACCOUNT}/${PORTNAME}
PLIST_FILES= bin/envconsul
-STRIP= # stripping can break go binaries
-
OPTIONS_DEFINE= DOCS
PORTDOCS= README.md
-
-post-patch:
- @${MKDIR} ${WRKSRC}/src/github.com/hashicorp/envconsul
-.for src in .gitignore .travis.yml CHANGELOG.md Makefile README.md \
- cli.go cli_test.go config.go config_test.go flags.go main.go runner.go \
- runner_test.go scripts signals.go signals_windows.go
- @${MV} ${WRKSRC}/${src} \
- ${WRKSRC}/src/github.com/hashicorp/envconsul
-.endfor
+COMMIT= 7ece735
+GO_LDFLAGS= -ldflags="-s -w \
+ -X main.Name=${PORTNAME} \
+ -X main.Version=${PORTVERSION} \
+ -X main.GitCommit=${COMMIT}"
do-build:
- @cd ${WRKSRC}/src/github.com/hashicorp/envconsul; ${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} go build -o bin/envconsul
+ @cd ${WRKSRC}/src/github.com/hashicorp/envconsul; \
+ ${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} \
+ go build ${GO_LDFLAGS}\
+ -o bin/envconsul
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/hashicorp/envconsul/bin/envconsul ${STAGEDIR}${PREFIX}/bin/envconsul
diff --git a/sysutils/envconsul/distinfo b/sysutils/envconsul/distinfo
index a3fc9fc4dabc..9f4af40f93b5 100644
--- a/sysutils/envconsul/distinfo
+++ b/sysutils/envconsul/distinfo
@@ -1,64 +1,3 @@
-SHA256 (hashicorp-envconsul-v0.6.0_GH0.tar.gz) = ade72d4dd6ecfe4523556caec6f1c52fc62039eca81d1fe7a4e0ab15db44074e
-SIZE (hashicorp-envconsul-v0.6.0_GH0.tar.gz) = 32521
-SHA256 (armon-go-metrics-6c5fa0d_GH0.tar.gz) = d70e7e6d7243cb447eaf017a713952e421c948a303c96fe8052d2d060e20aec1
-SIZE (armon-go-metrics-6c5fa0d_GH0.tar.gz) = 13221
-SHA256 (armon-go-radix-fbd82e8_GH0.tar.gz) = a5999f535eab66b5302f5b629eac6b613fec171e8529e219596251f3c4aeced5
-SIZE (armon-go-radix-fbd82e8_GH0.tar.gz) = 5488
-SHA256 (aws-aws-sdk-go-308eaa6_GH0.tar.gz) = e0cd8827769846df79526bf7330221f846c37e78baa316a7d04b5281da6350d1
-SIZE (aws-aws-sdk-go-308eaa6_GH0.tar.gz) = 2613575
-SHA256 (coreos-etcd-6afd8e4_GH0.tar.gz) = ea760839bf9a3648f18946ec4d96ac5e21f32c776b4667d36b9f763fda0e5af9
-SIZE (coreos-etcd-6afd8e4_GH0.tar.gz) = 1841083
-SHA256 (fatih-structs-a9f7daa_GH0.tar.gz) = dfd5ad7383a88fb2f26e25d5a2bee2dfae8e03e2cfb6e8e965868a9257b3b1a0
-SIZE (fatih-structs-a9f7daa_GH0.tar.gz) = 11749
-SHA256 (go-ini-ini-aea5e9f_GH0.tar.gz) = 4d1ddc15e25e66f1e45f5ecee48f34716ef80006c7f705c198bd45ae968d24d7
-SIZE (go-ini-ini-aea5e9f_GH0.tar.gz) = 24398
-SHA256 (go-sql-driver-mysql-527bcd5_GH0.tar.gz) = e1af37c3b9ac10a1e8560d462dd5bd7a09e4de9c26fc0eec44390729eb9474ac
-SIZE (go-sql-driver-mysql-527bcd5_GH0.tar.gz) = 53131
-SHA256 (hashicorp-consul-809ed36_GH0.tar.gz) = 648ee7746e3d6c2c3b73d33d931858af01dd3c373f9d06c5ca5df0791ef0caa3
-SIZE (hashicorp-consul-809ed36_GH0.tar.gz) = 1890104
-SHA256 (hashicorp-consul-template-ec11b92_GH0.tar.gz) = fd1ef8bf0e9b9c04c2baf1cf97ab5204ff0140f284af31bded199aa6c6fff22f
-SIZE (hashicorp-consul-template-ec11b92_GH0.tar.gz) = 83551
-SHA256 (hashicorp-errwrap-7554cd9_GH0.tar.gz) = b800e361c15decd0ebb39a0ff02ad046a1fc81021267f8625232f3921617daa0
-SIZE (hashicorp-errwrap-7554cd9_GH0.tar.gz) = 8312
-SHA256 (hashicorp-go-cleanhttp-875fb67_GH0.tar.gz) = a09a1f166fb844ec7b648fc62011a8964cca0666ff536bc737498a20a350a083
-SIZE (hashicorp-go-cleanhttp-875fb67_GH0.tar.gz) = 7124
-SHA256 (hashicorp-go-gatedio-8b8de10_GH0.tar.gz) = 3561fbb4a3c456381d5fe4722433deb351c2e381fa9483c5a9760a85925df0e6
-SIZE (hashicorp-go-gatedio-8b8de10_GH0.tar.gz) = 8209
-SHA256 (hashicorp-go-msgpack-fa3f638_GH0.tar.gz) = 6353c623d5d58c7ca03e2bdac63f9da7da8848fb1f5f7f239b33e3ce6fe6c6bd
-SIZE (hashicorp-go-msgpack-fa3f638_GH0.tar.gz) = 49496
-SHA256 (hashicorp-go-multierror-d30f099_GH0.tar.gz) = 3a1ea11a45d9ec6aab4aeea142a6c8b73bfd1ae7613c77de6e53880b36539697
-SIZE (hashicorp-go-multierror-d30f099_GH0.tar.gz) = 8785
-SHA256 (hashicorp-go-syslog-42a2b57_GH0.tar.gz) = c092db8da3dc2c7279b4ad6afbb6ee7c4daae9ac3020a591096be59f94330544
-SIZE (hashicorp-go-syslog-42a2b57_GH0.tar.gz) = 4394
-SHA256 (hashicorp-go-uuid-2951e8b_GH0.tar.gz) = 427e01926ff148e9ac1659cd87afc1fd0994a8cdd976682a1d6b82c5922ec28d
-SIZE (hashicorp-go-uuid-2951e8b_GH0.tar.gz) = 6159
-SHA256 (hashicorp-golang-lru-17e3543_GH0.tar.gz) = 0626cb131f83f95e830361a4bf5f977f17a775c3d9a5925548e6014c162ca7ed
-SIZE (hashicorp-golang-lru-17e3543_GH0.tar.gz) = 8030
-SHA256 (hashicorp-hcl-4de5195_GH0.tar.gz) = 34614c227cec654726cdd053284db7df5f05fb0814a8d39c2f8a21f95c3f855e
-SIZE (hashicorp-hcl-4de5195_GH0.tar.gz) = 30879
-SHA256 (hashicorp-logutils-0dc08b1_GH0.tar.gz) = d1272f06f8df434ee06bf965028debe32686a240818729beed5468eedf7f845e
-SIZE (hashicorp-logutils-0dc08b1_GH0.tar.gz) = 7705
-SHA256 (hashicorp-serf-8d36400_GH0.tar.gz) = c4f399ac601acf44f44e64513d598e132075839e8066e8cd1005b42d33c955a4
-SIZE (hashicorp-serf-8d36400_GH0.tar.gz) = 573251
-SHA256 (hashicorp-vault-97820e2_GH0.tar.gz) = 9ef0dfa8ee0c3fe2c544b02afd05a01e92f2ed38468feb7c5d389ccc64857423
-SIZE (hashicorp-vault-97820e2_GH0.tar.gz) = 1925721
-SHA256 (jmespath-go-jmespath-bbaa094_GH0.tar.gz) = fd0ba523b298637eba37968500853eba9716e6c872d72d3a9d2fea596caf043c
-SIZE (jmespath-go-jmespath-bbaa094_GH0.tar.gz) = 46447
-SHA256 (lib-pq-ffe986a_GH0.tar.gz) = 26c33c35fdde3a2e78abb658bf4d90abefc7520d3612856e4650ca52f3aa6c63
-SIZE (lib-pq-ffe986a_GH0.tar.gz) = 67246
-SHA256 (mitchellh-copystructure-6fc6626_GH0.tar.gz) = b632b0536ab26766989d11287d798417b7583e4f55928ee2c1100d11a222d64a
-SIZE (mitchellh-copystructure-6fc6626_GH0.tar.gz) = 4029
-SHA256 (mitchellh-iochan-87b45ff_GH0.tar.gz) = f929e7740412611e37e5c3984dc32828bc2b47df91351eafefb36460abee4565
-SIZE (mitchellh-iochan-87b45ff_GH0.tar.gz) = 1782
-SHA256 (mitchellh-mapstructure-281073e_GH0.tar.gz) = e511fe333b7ce7cbe2b1d03e35f8a3d9ed1bf52eb3aca32859fe5f7acb54ea33
-SIZE (mitchellh-mapstructure-281073e_GH0.tar.gz) = 13968
-SHA256 (mitchellh-reflectwalk-eecf4c7_GH0.tar.gz) = a681b9f5f9a8c24d01d9e05a088dc2053fa637060cf4fa8a4232d5ef4f00ca11
-SIZE (mitchellh-reflectwalk-eecf4c7_GH0.tar.gz) = 4272
-SHA256 (samuel-go-zookeeper-913027e_GH0.tar.gz) = 782bdc942459205fb548c66fa4e35f368e39631d127cf0190d862adb6061888b
-SIZE (samuel-go-zookeeper-913027e_GH0.tar.gz) = 26529
-SHA256 (golang-crypto-c8b9e63_GH0.tar.gz) = 071aa15bcf36aabc1e24263f876d23e4562a4362f7e7aec8a687631bc884065a
-SIZE (golang-crypto-c8b9e63_GH0.tar.gz) = 895576
-SHA256 (golang-net-271cfc1_GH0.tar.gz) = 84001b9f7ffa2e5c57a0767b5af91eb5c74017f56c7e049c2d6b5e830c50a243
-SIZE (golang-net-271cfc1_GH0.tar.gz) = 695232
-SHA256 (hashicorp-envconsul-c2a1a65_GH0.tar.gz) = f8f2fbb29b05287176eecb407c1410d0d2756945a2de2fcea5489a9e31604f21
-SIZE (hashicorp-envconsul-c2a1a65_GH0.tar.gz) = 32569
+TIMESTAMP = 1491667668
+SHA256 (hashicorp-envconsul-v0.6.2_GH0.tar.gz) = 9e89e1075edea52d8e8d76e9de49c83419632073dca260a023b737cfcb60bc47
+SIZE (hashicorp-envconsul-v0.6.2_GH0.tar.gz) = 4209639