aboutsummaryrefslogtreecommitdiff
path: root/sysutils/exa
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-04-17 07:33:34 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-04-17 07:33:34 +0000
commit23e6c4fb94bc3eb08c1378ef00a32cf91feef35d (patch)
treee05f59866e6139badbc92c7524966ba640a8fed5 /sysutils/exa
parentf5673163420976de6f0f27abae2e7c701e9a309b (diff)
downloadports-23e6c4fb94bc3eb08c1378ef00a32cf91feef35d.tar.gz
ports-23e6c4fb94bc3eb08c1378ef00a32cf91feef35d.zip
Mk/Uses/cargo.mk: Push lib dependencies back down into ports
Some crates are optional via Cargo features or are only used during tests, however the framework has no way to discriminate between test or run dependencies using just CARGO_CRATES leading to more run dependencies than necessary for some packages. With more ported Rust applications it's time to let individual ports make that decision now. The environmental setup to use dependencies from ports instead of bundled ones and implied build dependencies (cmake, gmake, pkgconf) are left in place for now. Assign cargo.mk to rust@ while here.
Notes
Notes: svn path=/head/; revision=499149
Diffstat (limited to 'sysutils/exa')
-rw-r--r--sysutils/exa/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/sysutils/exa/Makefile b/sysutils/exa/Makefile
index 72b7ff2bf32b..40427791f110 100644
--- a/sysutils/exa/Makefile
+++ b/sysutils/exa/Makefile
@@ -12,6 +12,8 @@ COMMENT= Modern replacement for ls
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENCE
+LIB_DEPENDS= libgit2.so:devel/libgit2
+
USES= cargo
USE_GITHUB= yes
GH_ACCOUNT= ogham