aboutsummaryrefslogtreecommitdiff
path: root/sysutils/freeipmi/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2010-08-04 07:19:01 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2010-08-04 07:19:01 +0000
commite0fc87e711b15a52aaa01fe92e4fd95a98e36188 (patch)
tree7da47bbf08e10bbca68f206bafa319eea50ad06e /sysutils/freeipmi/Makefile
parentc2d957d119c7550c84a33d334e3fd5048e9d5fd4 (diff)
downloadports-e0fc87e711b15a52aaa01fe92e4fd95a98e36188.tar.gz
ports-e0fc87e711b15a52aaa01fe92e4fd95a98e36188.zip
Freeipmi:
- Update to 0.8.8 - Update MASTER_SITES - Pass maintainership to submitter Ipmitool: - Bump PORTREVISION for its conditional dependency on freeipmi PR: ports/149074 Submitted by: Sunpoet Po-Chuan Hsieh <sunpoet _at_ sunpoet.net> (maintainer) Approved by: jadawin@ (co-mentor)
Notes
Notes: svn path=/head/; revision=258743
Diffstat (limited to 'sysutils/freeipmi/Makefile')
-rw-r--r--sysutils/freeipmi/Makefile108
1 files changed, 52 insertions, 56 deletions
diff --git a/sysutils/freeipmi/Makefile b/sysutils/freeipmi/Makefile
index 6a7232c33cd6..cc5a9e85cb70 100644
--- a/sysutils/freeipmi/Makefile
+++ b/sysutils/freeipmi/Makefile
@@ -8,96 +8,92 @@
#
# WITH_DEBUG - Enable debugging features.
# WITH_IOPERM - Use i386_set_ioperm(2) instead of io(4) to gain access
-# to I/O ports (i386 only). Note: there is a bug in
-# FreeBSD 5 before 5.5-RELEASE that causes SIGBUS to the
-# process sometimes when i386_set_ioperm is used (PR
-# 84842).
+# to I/O ports (i386 only).
#
PORTNAME= freeipmi
-PORTVERSION= 0.7.1
-PORTREVISION= 2
+PORTVERSION= 0.8.8
CATEGORIES= sysutils
-MASTER_SITES= http://ftp.zresearch.com/pub/freeipmi/${PORTVERSION}/ \
- ftp://freebsd.riss-telecom.ru/pub/mirrors/ftp.zresearch.com/pub/freeipmi/${PORTVERSION}/
+MASTER_SITES= GNU/${PORTNAME}/ \
+ http://ftp.gluster.com/pub/${PORTNAME}/${PORTVERSION}/ \
+ http://sunpoet.net/distfiles/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@sunpoet.net
COMMENT= Library and tools to support IPMI-capable hardware
-LIB_DEPENDS+= gcrypt:${PORTSDIR}/security/libgcrypt \
- argp:${PORTSDIR}/devel/argp-standalone
+LIB_DEPENDS= argp:${PORTSDIR}/devel/argp-standalone \
+ gcrypt:${PORTSDIR}/security/libgcrypt
+CONFIGURE_ARGS+=--disable-init-scripts \
+ --disable-logdir \
+ --disable-logrotate-config \
+ --localstatedir=/var \
+ --sysconfdir=${CONF_DIR} \
+ --with-ipmi-monitoring-sdr-cache-dir=${CACHE_DIR}/ipmimonitoringsdrcache
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" PTHREAD_LIBS=${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include
+GNU_CONFIGURE= yes
+LDFLAGS+= -L${LOCALBASE}/lib
+ONLY_FOR_ARCHS= i386 amd64
+ONLY_FOR_ARCHS_REASON= "invokes i386 asm"
USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
- PTHREAD_LIBS=-pthread
-CONFIGURE_ARGS+= --disable-init-scripts --disable-logrotate-config \
- --disable-logdir --localstatedir=/var \
- --with-ipmi-monitoring-sdr-cache-dir=${CACHE_DIR}/ipmimonitoringsdrcache \
- --sysconfdir=${CONF_DIR}
USE_LDCONFIG= yes
-ONLY_FOR_ARCHS= i386 amd64
-ONLY_FOR_ARCHS_REASON= "invokes i386 asm"
+OPTIONS= DEBUG "Debugging features" off \
+ IOPERM "Use i386_set_ioperm (i386 only)" off
+INFO= freeipmi-faq
+MAN3= libfreeipmi.3 libipmiconsole.3 libipmidetect.3 libipmimonitoring.3
+MAN5= bmc-config.conf.5 freeipmi.conf.5 ipmi_monitoring_sensors.conf.5 \
+ ipmiconsole.conf.5 ipmidetect.conf.5 ipmidetectd.conf.5 \
+ ipmimonitoring.conf.5 ipmimonitoring_sensors.conf.5 \
+ ipmipower.conf.5 libipmimonitoring.conf.5
+MAN7= freeipmi.7
+MAN8= bmc-config.8 bmc-device.8 bmc-info.8 bmc-watchdog.8 \
+ ipmi-chassis-config.8 ipmi-chassis.8 ipmi-dcmi.8 ipmi-fru.8 \
+ ipmi-locate.8 ipmi-oem.8 ipmi-pef-config.8 ipmi-raw.8 ipmi-sel.8 \
+ ipmi-sensors-config.8 ipmi-sensors.8 ipmiconsole.8 ipmidetect.8 \
+ ipmidetectd.8 ipmimonitoring.8 ipmiping.8 ipmipower.8 \
+ pef-config.8 rmcpping.8
PLIST_SUB+= FREEIPMI_SHLIBVER=${FREEIPMI_SHLIBVER} \
- IPMICONSOLE_SHLIBVER=${IPMICONSOLE_SHLIBVER} \
- IPMIDETECT_SHLIBVER=${IPMIDETECT_SHLIBVER} \
- IPMIMONITORING_SHLIBVER=${IPMIMONITORING_SHLIBVER} \
- CACHE_DIR=${CACHE_DIR} LOG_DIR=${LOG_DIR} RUN_DIR=${RUN_DIR}
-MAN3+= libfreeipmi.3 libipmiconsole.3 libipmidetect.3 \
- libipmimonitoring.3
-MAN5+= bmc-config.conf.5 freeipmi.conf.5 ipmiconsole.conf.5 \
- ipmidetect.conf.5 ipmidetectd.conf.5 ipmipower.conf.5
-MAN7+= freeipmi.7
-MAN8+= bmc-config.8 bmc-device.8 bmc-info.8 bmc-watchdog.8 \
- ipmi-chassis-config.8 ipmi-chassis.8 ipmi-fru.8 \
- ipmi-locate.8 ipmi-oem.8 ipmi-raw.8 ipmi-sel.8 \
- ipmi-sensors-config.8 ipmi-sensors.8 ipmiconsole.8 \
- ipmidetect.8 ipmidetectd.8 ipmimonitoring.8 ipmiping.8 \
- ipmipower.8 pef-config.8 rmcpping.8
-INFO+= freeipmi-faq
+ IPMICONSOLE_SHLIBVER=${IPMICONSOLE_SHLIBVER} \
+ IPMIDETECT_SHLIBVER=${IPMIDETECT_SHLIBVER} \
+ IPMIMONITORING_SHLIBVER=${IPMIMONITORING_SHLIBVER} \
+ CACHE_DIR=${CACHE_DIR} LOG_DIR=${LOG_DIR} RUN_DIR=${RUN_DIR}
CACHE_DIR?= /var/db/${PORTNAME}
LOG_DIR= /var/log/${PORTNAME}
RUN_DIR= /var/lib/${PORTNAME}
CONF_DIR?= ${PREFIX}/etc/${PORTNAME}
-FREEIPMI_SHLIBVER= 7
-IPMICONSOLE_SHLIBVER= 2
-IPMIDETECT_SHLIBVER= 0
-IPMIMONITORING_SHLIBVER= 2
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+FREEIPMI_SHLIBVER= 10
+IPMICONSOLE_SHLIBVER= 3
+IPMIDETECT_SHLIBVER= 0
+IPMIMONITORING_SHLIBVER= 4
.include <bsd.port.pre.mk>
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+=--enable-debug --enable-trace
+.endif
+
.if defined(WITH_IOPERM)
.if ${ARCH} == "i386"
CPPFLAGS+= -DUSE_IOPERM
.else
-BROKEN= IOPERM option is only available on i386 and You are building for ${ARCH}
+BROKEN= IOPERM option is only available on i386 and You are building for ${ARCH}
.endif
.endif
-.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+= --enable-debug --enable-trace
-STRIP= # empty
-.endif
-
+post-patch:
+ @${FIND} ${WRKSRC} -name '*.man' -o -name '*.pre.in' | ${XARGS} -I % ${REINPLACE_CMD} -e '/^\.\\\"/ s|$$|"|' %
.if defined(NOPORTDOCS)
-EXTRA_PATCHES+= ${FILESDIR}/extra-noportdocs.patch
-.else
-PORTDOCS= *
+ @${REINPLACE_CMD} -e '/^install-data-am:/ s| install-docDATA||' \
+ ${WRKSRC}/Makefile.in ${WRKSRC}/doc/Makefile.in
.endif
post-install:
@${MKDIR} ${LOG_DIR}
@${CHMOD} 0700 ${CACHE_DIR} ${LOG_DIR} ${RUN_DIR}
- [ -f ${CONF_DIR}/freeipmi.conf ] || \
- ${CP} -p ${CONF_DIR}/freeipmi.conf.sample ${CONF_DIR}/freeipmi.conf
- [ -f ${CONF_DIR}/ipmi_monitoring_sensors.conf ] || \
- ${CP} -p ${CONF_DIR}/ipmi_monitoring_sensors.conf.sample \
- ${CONF_DIR}/ipmi_monitoring_sensors.conf
.include <bsd.port.post.mk>