aboutsummaryrefslogtreecommitdiff
path: root/sysutils/froxlor
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-03-21 00:37:33 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-03-21 00:37:33 +0000
commitb2ac5f0650f6b73ec159e6510f0a70e22175b398 (patch)
tree13c5d65c593c7e296837932b100a303268b71374 /sysutils/froxlor
parentd02a2a54fe302cddbcb7fbf595745166bf7c0b18 (diff)
downloadports-b2ac5f0650f6b73ec159e6510f0a70e22175b398.tar.gz
ports-b2ac5f0650f6b73ec159e6510f0a70e22175b398.zip
- update to 0.9.27
- adopt optionsNG PR: 176975 Submitted by: maintainer, coco@executive-computing.de
Notes
Notes: svn path=/head/; revision=314793
Diffstat (limited to 'sysutils/froxlor')
-rw-r--r--sysutils/froxlor/Makefile97
-rw-r--r--sysutils/froxlor/distinfo4
-rw-r--r--sysutils/froxlor/files/pkg-deinstall.in4
-rw-r--r--sysutils/froxlor/pkg-descr2
-rw-r--r--sysutils/froxlor/pkg-plist3
5 files changed, 76 insertions, 34 deletions
diff --git a/sysutils/froxlor/Makefile b/sysutils/froxlor/Makefile
index 13f624c5ea8e..770e9517f507 100644
--- a/sysutils/froxlor/Makefile
+++ b/sysutils/froxlor/Makefile
@@ -1,83 +1,120 @@
-# New ports collection makefile for: froxlor
-# Date created: 2010-10-13
-# Whom: Marco Steinbach <coco@executive-computing.de>
-#
+# Created by: Marco Steinbach <coco@executive-computing.de>
# $FreeBSD$
-#
PORTNAME= froxlor
-DISTVERSION= 0.9.26
+DISTVERSION= 0.9.27
CATEGORIES= sysutils www
MASTER_SITES= http://files.froxlor.org/releases/
MAINTAINER= coco@executive-computing.de
COMMENT= PHP-based ISP Server Management Panel
+LICENSE= GPLv2
+
WRKSRC= ${WRKDIR}
NO_BUILD= YES
SUB_FILES+= pkg-message pkg-deinstall
-USE_PHP= xml bcmath posix filter session ftp mysqli gettext
+USE_PHP= xml bcmath posix filter session ftp mysql mysqli gettext
USE_GETTEXT= RUN
-OPTIONS= APACHE "Use Apache (2.2) as http server" On \
- MYSQL "Use MySQL as database server" On \
- POSTFIX "Use Postfix as smtp server" On \
- DKIM "Use OpenDKIM" Off \
- DOVECOT "Use Dovecot as imap/pop3 server" On \
- PROFTPD "Use Proftpd-mysql as ftp server (implies MySQL)" On \
- POWERDNS "Use Powerdns as dns server" Off \
- LIBNSS "Use Libnss-mysql for authentication (impl. MySQL)" Off \
- WEBALIZER "Use webalizer" On \
- AWSTATS "Use awstats" Off \
- LOGROTATE "Use logrotate" Off
+OPTIONS_DEFINE= POWERDNS LIBNSS LOGROTATE MYSQLS DKIM
+
+OPTIONS_SINGLE= WEB SMTP IMAPPOP3 FTP
+OPTIONS_SINGLE_WEB= APACHE LIGHTTPD NGINX
+OPTIONS_SINGLE_SMTP= POSTFIX EXIM
+OPTIONS_SINGLE_IMAPPOP3= DOVECOT COURIER
+OPTIONS_SINGLE_FTP= PROFTPD PUREFTPD
+OPTIONS_MULTI= WWWST
+OPTIONS_MULTI_WWWST= WEBALIZER AWSTATS
+
+APACHE_DESC= Apache (2.2) as HTTP server
+LIGHTTPD_DESC= Lighttpd as HTTP server
+NGINX_DESC= Nginx as HTTP server
+MYSQLC_DESC= MySQL database client only
+MYSQLS_DESC= MySQL database server and client
+POSTFIX_DESC= Postfix as SMTP server
+EXIM_DESC= Exim as SMTP server
+DKIM_DESC= OpenDKIM for DomainKeys Identified Mail
+DOVECOT_DESC= Dovecot as IMAP/POP3 server
+COURIER_DESC= Courier as IMAP/POP3 server
+PROFTPD_DESC= ProFTPd as FTP server
+PUREFTPD_DESC= Pure-FTPd as FTP server
+POWERDNS_DESC= Powerdns as DNS server
+LIBNSS_DESC= Libnss-mysql for authentication
+WEBALIZER_DESC= Webalizer for web statistics
+AWSTATS_DESC= Awstats for web statistics
+LOGROTATE_DESC= Logrotate for log rotation
+MYSQLS_DESC= Install/depend on MySQL server
+
+OPTIONS_DEFAULT= APACHE MYSQLS POSTFIX DOVECOT PROFTPD WEBALIZER MYSQLS
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_APACHE)
+.if ${PORT_OPTIONS:MAPACHE}
USE_APACHE_RUN= 22
.endif
-.if !defined(WITHOUT_MYSQL)
-USE_PHP+= mysql
+.if ${PORT_OPTIONS:MLIGHTTPD}
+RUN_DEPENDS+= lighttpd:${PORTSDIR}/www/lighttpd
+.endif
+
+.if ${PORT_OPTIONS:MNGINX}
+RUN_DEPENDS+= nginx:${PORTSDIR}/www/nginx
.endif
-.if !defined(WITHOUT_POSTFIX)
+.if ${PORT_OPTIONS:MMYSQLS}
+USE_MYSQL= server
+.endif
+
+.if ${PORT_OPTIONS:MPOSTFIX}
RUN_DEPENDS+= postfix:${PORTSDIR}/mail/postfix
.endif
-.if defined(WITH_DKIM)
+.if ${PORT_OPTIONS:MEXIM}
+RUN_DEPENDS+= exim:${PORTSDIR}/mail/exim
+.endif
+
+.if ${PORT_OPTIONS:MDKIM}
RUN_DEPENDS+= opendkim:${PORTSDIR}/mail/opendkim
.endif
-.if !defined(WITHOUT_DOVECOT)
+.if ${PORT_OPTIONS:MDOVECOT}
RUN_DEPENDS+= dovecot:${PORTSDIR}/mail/dovecot
.endif
-.if !defined(WITHOUT_PROFTPD)
+.if ${PORT_OPTIONS:MCOURIER}
+RUN_DEPENDS+= courier:${PORTSDIR}/mail/courier
+.endif
+
+.if ${PORT_OPTIONS:MPROFTPD}
RUN_DEPENDS+= ${LOCALBASE}/libexec/proftpd/mod_sql_mysql.so:${PORTSDIR}/databases/proftpd-mod_sql_mysql
.endif
-.if defined(WITH_POWERDNS)
+.if ${PORT_OPTIONS:MPUREFTPD}
+RUN_DEPENDS+= pure-ftpd:${PORTSDIR}/ftp/pure-ftpd
+.endif
+
+.if ${PORT_OPTIONS:MPOWERDNS}
RUN_DEPENDS+= powerdns:${PORTSDIR}/dns/powerdns
.endif
-.if defined(WITH_LIBNSS)
+.if ${PORT_OPTIONS:MLIBNSS}
RUN_DEPENDS+= ${LOCALBASE}/lib/nss_mysql.so:${PORTSDIR}/net/libnss-mysql
.endif
-.if !defined(WITHOUT_WEBALIZER)
+.if ${PORT_OPTIONS:MWEBALIZER}
RUN_DEPENDS+= webalizer:${PORTSDIR}/www/webalizer
.endif
-.if defined(WITH_AWSTATS)
+.if ${PORT_OPTIONS:MAWSTATS}
RUN_DEPENDS+= awstats>=6.8:${PORTSDIR}/www/awstats
.endif
-.if defined(WITH_LOGROTATE)
+.if ${PORT_OPTIONS:MLOGROTATE}
RUN_DEPENDS+= logrotate:${PORTSDIR}/sysutils/logrotate
.endif
diff --git a/sysutils/froxlor/distinfo b/sysutils/froxlor/distinfo
index 7205a4bbbba8..2efa759d2a81 100644
--- a/sysutils/froxlor/distinfo
+++ b/sysutils/froxlor/distinfo
@@ -1,2 +1,2 @@
-SHA256 (froxlor-0.9.26.tar.gz) = 99c47a7127d672778e898e1916b0a1be74378ae7694669bb9c01f4b887951e5c
-SIZE (froxlor-0.9.26.tar.gz) = 1602312
+SHA256 (froxlor-0.9.27.tar.gz) = 0468811f545d93ca98e9346e4c207b57fbbcd7669fa4435cb37cf046e2e3c031
+SIZE (froxlor-0.9.27.tar.gz) = 1662621
diff --git a/sysutils/froxlor/files/pkg-deinstall.in b/sysutils/froxlor/files/pkg-deinstall.in
index 42a25be7133f..03a9387b4b7a 100644
--- a/sysutils/froxlor/files/pkg-deinstall.in
+++ b/sysutils/froxlor/files/pkg-deinstall.in
@@ -1,7 +1,8 @@
#!/bin/sh
# $FreeBSD$
-if [ "$2" = DEINSTALL ]; then
+if [ "$2" == "POST-DEINSTALL" ]; then
+if [ -d %%WWWDIR%% ]; then
echo ""
echo "-------------------------------------------------------"
echo "Run the following command, if you plan to permanently"
@@ -11,3 +12,4 @@ if [ "$2" = DEINSTALL ]; then
echo "-------------------------------------------------------"
echo ""
fi
+fi
diff --git a/sysutils/froxlor/pkg-descr b/sysutils/froxlor/pkg-descr
index 09d097510c21..243bfdd83eb6 100644
--- a/sysutils/froxlor/pkg-descr
+++ b/sysutils/froxlor/pkg-descr
@@ -4,4 +4,4 @@ more.
Froxlor is a fork of SysCP. Froxlor saw its first release on February 15 2010.
-WWW: http://www.froxlor.org/
+WWW: http://www.froxlor.org/
diff --git a/sysutils/froxlor/pkg-plist b/sysutils/froxlor/pkg-plist
index 730de5c558f3..e5619fd3fb78 100644
--- a/sysutils/froxlor/pkg-plist
+++ b/sysutils/froxlor/pkg-plist
@@ -39,6 +39,7 @@ www/froxlor/admin_updates.php
www/froxlor/cache/.keep
www/froxlor/css/jquery.jqplot.css
www/froxlor/css/jquery.jqplot.min.css
+www/froxlor/css/jquery.jquery-ui.css
www/froxlor/customer_aps.php
www/froxlor/customer_autoresponder.php
www/froxlor/customer_domains.php
@@ -239,6 +240,8 @@ www/froxlor/install/updates/syscp/1.2/update_1.2.19_1.4.inc.php
www/froxlor/install/updates/syscp/1.4/update_1.4.inc.php
www/froxlor/install/updatesql.php
www/froxlor/js/excanvas.min.js
+www/froxlor/js/jquery-ui-1.8.13.min.js
+www/froxlor/js/jquery-ui.min.js
www/froxlor/js/jquery.jqplot.min.js
www/froxlor/js/jquery.min.js
www/froxlor/js/jquery.tablesorter.min.js