aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-sshfs
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-11-05 23:30:50 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-11-05 23:30:50 +0000
commite51bdde5a4e12465090fa82a2e603f570b62a868 (patch)
tree20b3cc8d13b34ec2de07c9ba1416c194f0941af8 /sysutils/fusefs-sshfs
parent2554ea9c97db2177620c1d76524229051722859a (diff)
downloadports-e51bdde5a4e12465090fa82a2e603f570b62a868.tar.gz
ports-e51bdde5a4e12465090fa82a2e603f570b62a868.zip
On architectures that use GCC in base, the "-Wno-unused-result" flag
must be disabled to fix the build. PR: 231944 Submitted by: Piotr Kubaj Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=484258
Diffstat (limited to 'sysutils/fusefs-sshfs')
-rw-r--r--sysutils/fusefs-sshfs/Makefile2
-rw-r--r--sysutils/fusefs-sshfs/files/patch-meson.build22
2 files changed, 19 insertions, 5 deletions
diff --git a/sysutils/fusefs-sshfs/Makefile b/sysutils/fusefs-sshfs/Makefile
index b540312e0a98..439fbcbc720a 100644
--- a/sysutils/fusefs-sshfs/Makefile
+++ b/sysutils/fusefs-sshfs/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= rst2man:textproc/py-docutils
-USES= fuse:3 gettext meson pkgconfig
+USES= fuse:3 gettext gnome meson pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= libfuse
diff --git a/sysutils/fusefs-sshfs/files/patch-meson.build b/sysutils/fusefs-sshfs/files/patch-meson.build
index 7922ced06d4f..e63e4db55cfb 100644
--- a/sysutils/fusefs-sshfs/files/patch-meson.build
+++ b/sysutils/fusefs-sshfs/files/patch-meson.build
@@ -1,13 +1,27 @@
---- meson.build.orig 2017-10-25 18:32:34 UTC
+--- meson.build.orig 2018-06-29 08:34:57 UTC
+++ meson.build
-@@ -63,10 +63,5 @@ else
+@@ -19,12 +19,7 @@ int main(void) {
+ (void) get_4();
+ return 0;
+ }'''
+-if not cc.compiles(code, args: [ '-O0', '-Werror=unused-result' ])
+- message('Compiler warns about unused result even when casting to void')
+- add_global_arguments('-Wno-unused-result', language: 'c')
+-endif
+
+-
+ rst2man = find_program('rst2man', required: false)
+
+ cfg = configuration_data()
+@@ -62,11 +57,6 @@ if rst2man.found()
+ else
message('rst2man not found, not building manual page.')
endif
-
+-
-meson.add_install_script('utils/install_helper.sh',
- get_option('sbindir'),
- get_option('bindir'))
-
--
+
subdir('test')