aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-zip
diff options
context:
space:
mode:
authorVeniamin Gvozdikov <vg@FreeBSD.org>2013-10-17 07:38:22 +0000
committerVeniamin Gvozdikov <vg@FreeBSD.org>2013-10-17 07:38:22 +0000
commit6b8e996d9f99e9901d436e83344690c05f18d38e (patch)
tree933043596fafffb307880b836594d6c351d4ed3d /sysutils/fusefs-zip
parentc57a9101a6b6a3ecc895be68d2735a4fce35f293 (diff)
downloadports-6b8e996d9f99e9901d436e83344690c05f18d38e.tar.gz
ports-6b8e996d9f99e9901d436e83344690c05f18d38e.zip
- Fix build with clang
PR: ports/182885 Submitted by: Oleg Ginzburg <olevole@olevole.ru> (maintainer) Approved by: eadler, osa, rm (mentors, implicit)
Notes
Notes: svn path=/head/; revision=330615
Diffstat (limited to 'sysutils/fusefs-zip')
-rw-r--r--sysutils/fusefs-zip/Makefile22
-rw-r--r--sysutils/fusefs-zip/files/patch-lib_bigBuffer.h10
2 files changed, 19 insertions, 13 deletions
diff --git a/sysutils/fusefs-zip/Makefile b/sysutils/fusefs-zip/Makefile
index 219541d35ed1..26e1b1978018 100644
--- a/sysutils/fusefs-zip/Makefile
+++ b/sysutils/fusefs-zip/Makefile
@@ -10,33 +10,29 @@ COMMENT= FUSE filesystem to mount ZIP archives with write support
LICENSE= LGPL3
-LIB_DEPENDS= zip:${PORTSDIR}/archivers/libzip
+LIB_DEPENDS= libzip.so:${PORTSDIR}/archivers/libzip
BUILD_DEPENDS= libzip>=0.11.1:${PORTSDIR}/archivers/libzip
-USE_GMAKE= yes
-USES= fuse pkgconfig
+USES= gmake fuse pkgconfig
-PLIST_FILES= bin/${PORTNAME}
-MAN1= ${PORTNAME}.1
+PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
PORTDOCS= README TODO changelog
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
-do-build:
- (cd ${WRKSRC} && ${GMAKE} -C lib && \
- ${GMAKE} CXXFLAGS="-I${LOCALBASE}/include")
+post-patch:
+ @${REINPLACE_CMD} -e 's|make|$${MAKE}|' ${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/sysutils/fusefs-zip/files/patch-lib_bigBuffer.h b/sysutils/fusefs-zip/files/patch-lib_bigBuffer.h
new file mode 100644
index 000000000000..12de3e6f4655
--- /dev/null
+++ b/sysutils/fusefs-zip/files/patch-lib_bigBuffer.h
@@ -0,0 +1,10 @@
+--- lib/bigBuffer.h.orig 2013-10-11 01:12:58.000000000 +0400
++++ lib/bigBuffer.h 2013-10-11 01:13:02.000000000 +0400
+@@ -26,6 +26,7 @@
+ #include <unistd.h>
+
+ #include <vector>
++#include <string>
+
+ #include "types.h"
+