aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gapcmon
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-10-04 13:22:46 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-10-04 13:22:46 +0000
commitcdc05a5c5171ab97cdb3a6f78d7dc164f3b7c89a (patch)
tree22729e486dd51d16e42640fecebdd6cbb8ac4ce5 /sysutils/gapcmon
parent2866a78221ed3b2b7d7c57eb4ee74e8b52e15ca6 (diff)
downloadports-cdc05a5c5171ab97cdb3a6f78d7dc164f3b7c89a.tar.gz
ports-cdc05a5c5171ab97cdb3a6f78d7dc164f3b7c89a.zip
- Update to 0.8.6
PR: ports/116884 Submitted by: Jason E. Hale <bsdkaffee at gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=200820
Diffstat (limited to 'sysutils/gapcmon')
-rw-r--r--sysutils/gapcmon/Makefile17
-rw-r--r--sysutils/gapcmon/distinfo6
-rw-r--r--sysutils/gapcmon/files/patch-gapcmon.c10
3 files changed, 24 insertions, 9 deletions
diff --git a/sysutils/gapcmon/Makefile b/sysutils/gapcmon/Makefile
index 52a458f2c450..abd24ec6fdee 100644
--- a/sysutils/gapcmon/Makefile
+++ b/sysutils/gapcmon/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gapcmon
-PORTVERSION= 0.8.4
-PORTREVISION= 1
+PORTVERSION= 0.8.6
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,11 +16,16 @@ COMMENT= Montior apcupsd with GTK+2 GUI
USE_BZIP2= yes
USE_GMAKE= yes
-USE_ICONV= yes
-USE_GNOME= gnomehack gnometarget gnomevfs2
+USE_GNOME= gconf2
GNU_CONFIGURE= yes
-PORTDOCS= AUTHORS ChangeLog INSTALL
+PORTDOCS= AUTHORS ChangeLog INSTALL README
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 601103
+IGNORE= needs gethostbyname_r(3)
+.endif
post-extract:
@${REINPLACE_CMD} "s|/usr/share/pixmaps/|${PREFIX}/share/pixmaps/|" \
@@ -36,4 +40,5 @@ post-install:
.endif
@${CAT} pkg-message
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
+
diff --git a/sysutils/gapcmon/distinfo b/sysutils/gapcmon/distinfo
index a33ff4432830..332eb78b0f36 100644
--- a/sysutils/gapcmon/distinfo
+++ b/sysutils/gapcmon/distinfo
@@ -1,3 +1,3 @@
-MD5 (gapcmon-0.8.4.tar.bz2) = fe27c144da76af5e4d41d65dfeebec05
-SHA256 (gapcmon-0.8.4.tar.bz2) = dfd39df2a0709bac23af41e082e647be85bcdf75e33eaebf1c4bfcdb10036674
-SIZE (gapcmon-0.8.4.tar.bz2) = 120468
+MD5 (gapcmon-0.8.6.tar.bz2) = c8f4c2a2cb6f863b36dbeeedbbe8e8e9
+SHA256 (gapcmon-0.8.6.tar.bz2) = fdd2227ecd82f1b9557234615e49e65f696540147ae5c2792c7c6d638a795159
+SIZE (gapcmon-0.8.6.tar.bz2) = 122337
diff --git a/sysutils/gapcmon/files/patch-gapcmon.c b/sysutils/gapcmon/files/patch-gapcmon.c
new file mode 100644
index 000000000000..912b14333a10
--- /dev/null
+++ b/sysutils/gapcmon/files/patch-gapcmon.c
@@ -0,0 +1,10 @@
+--- src/gapcmon.c.orig Wed Oct 3 19:53:05 2007
++++ src/gapcmon.c Wed Oct 3 19:53:32 2007
+@@ -74,6 +74,7 @@
+ #include <unistd.h> /* close() */
+ #include <sys/types.h> /* socket() */
+ #include <sys/socket.h> /* socket() */
++#include <netinet/in.h>
+ #include <arpa/inet.h> /* ntohs() */
+ #include <netdb.h> /* gethostbyname() */
+ #include <errno.h>