aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnome-control-center1
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-02-07 13:46:49 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-02-07 13:46:49 +0000
commit7d412b8e6e71e47c499eca0dc81e11fafcb62d17 (patch)
tree342c7dd254509faec3a3f8545870a76fdf30ad3e /sysutils/gnome-control-center1
parenta1abd52f9a95ef7ca5aa84ea4beb677031d27ae3 (diff)
downloadports-7d412b8e6e71e47c499eca0dc81e11fafcb62d17.tar.gz
ports-7d412b8e6e71e47c499eca0dc81e11fafcb62d17.zip
Update to 1.4.0.3.
Notes
Notes: svn path=/head/; revision=54310
Diffstat (limited to 'sysutils/gnome-control-center1')
-rw-r--r--sysutils/gnome-control-center1/Makefile9
-rw-r--r--sysutils/gnome-control-center1/distinfo2
-rw-r--r--sysutils/gnome-control-center1/files/patch-Makefile.in14
-rw-r--r--sysutils/gnome-control-center1/files/patch-ltmain.sh45
-rw-r--r--sysutils/gnome-control-center1/files/patch-po::Makefile.in.in14
-rw-r--r--sysutils/gnome-control-center1/pkg-plist19
6 files changed, 84 insertions, 19 deletions
diff --git a/sysutils/gnome-control-center1/Makefile b/sysutils/gnome-control-center1/Makefile
index 04fe27dc0860..e08c854a6ff1 100644
--- a/sysutils/gnome-control-center1/Makefile
+++ b/sysutils/gnome-control-center1/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnomecontrolcenter
-PORTVERSION= 1.4.0.1
+PORTVERSION= 1.4.0.3
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/control-center
@@ -20,16 +20,15 @@ LIB_DEPENDS= gnomecanvaspixbuf.1:${PORTSDIR}/graphics/gnomecanvas \
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOMELIBS= yes
-USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
- `gdk-pixbuf-config --cflags`" \
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
diff --git a/sysutils/gnome-control-center1/distinfo b/sysutils/gnome-control-center1/distinfo
index 2d889c5c8570..271e9c261fc3 100644
--- a/sysutils/gnome-control-center1/distinfo
+++ b/sysutils/gnome-control-center1/distinfo
@@ -1 +1 @@
-MD5 (control-center-1.4.0.1.tar.gz) = 53e3d628a0d53a4b74e1ae8d8cb057ff
+MD5 (control-center-1.4.0.3.tar.gz) = b81b2599dbeb2e5204b8b4cecd455ad1
diff --git a/sysutils/gnome-control-center1/files/patch-Makefile.in b/sysutils/gnome-control-center1/files/patch-Makefile.in
new file mode 100644
index 000000000000..feb63528f70a
--- /dev/null
+++ b/sysutils/gnome-control-center1/files/patch-Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- Makefile.in 2002/02/05 09:46:12 1.1
++++ Makefile.in 2002/02/05 09:46:25
+@@ -151,7 +151,7 @@
+ cxxflags_set = @cxxflags_set@
+ l = @l@
+
+-always_built_SUBDIRS = control-center capplets idl doc omf-install man
++always_built_SUBDIRS = control-center capplets idl doc omf-install
+
+ SUBDIRS = intl po macros \
+ $(always_built_SUBDIRS)
diff --git a/sysutils/gnome-control-center1/files/patch-ltmain.sh b/sysutils/gnome-control-center1/files/patch-ltmain.sh
new file mode 100644
index 000000000000..91713d2306f8
--- /dev/null
+++ b/sysutils/gnome-control-center1/files/patch-ltmain.sh
@@ -0,0 +1,45 @@
+
+$FreeBSD$
+
+--- ltmain.sh.orig Wed Jan 23 11:38:40 2002
++++ ltmain.sh Sun Feb 3 01:44:17 2002
+@@ -1037,8 +1037,16 @@
+ continue
+ ;;
+
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
++
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+
+@@ -2412,6 +2420,9 @@
+ *-*-netbsd*)
+ # Don't link with libc until the a.out ld.so is fixed.
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test "$build_libtool_need_lc" = "yes"; then
+@@ -4179,10 +4190,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/sysutils/gnome-control-center1/files/patch-po::Makefile.in.in b/sysutils/gnome-control-center1/files/patch-po::Makefile.in.in
new file mode 100644
index 000000000000..02994b404219
--- /dev/null
+++ b/sysutils/gnome-control-center1/files/patch-po::Makefile.in.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- po/Makefile.in.in 2002/02/05 08:03:55 1.1
++++ po/Makefile.in.in 2002/02/05 08:04:08
+@@ -106,7 +106,7 @@
+ @catalogs='$(CATALOGS)'; \
+ for cat in $$catalogs; do \
+ cat=`basename $$cat`; \
+- lang=`echo $$cat | sed 's/\.gmo$$//'`; \
++ lang=`echo $$cat | sed 's/\.mo$$//'`; \
+ dir=$(localedir)/$$lang/LC_MESSAGES; \
+ $(mkinstalldirs) $(DESTDIR)$$dir; \
+ if test -r $$cat; then \
diff --git a/sysutils/gnome-control-center1/pkg-plist b/sysutils/gnome-control-center1/pkg-plist
index a2007948fbb8..384fba38b220 100644
--- a/sysutils/gnome-control-center1/pkg-plist
+++ b/sysutils/gnome-control-center1/pkg-plist
@@ -12,7 +12,7 @@ bin/url-properties
bin/wm-properties-capplet
etc/CORBA/servers/gnomecc.gnorba
etc/cappletConf.sh
-include/capplet-widget.h
+include/libcapplet1/capplet-widget.h
lib/libcapplet.a
lib/libcapplet.so
lib/libcapplet.so.5
@@ -50,7 +50,6 @@ share/gnome/control-center/.data/Compass.desktop
share/gnome/control-center/.data/Coral.desktop
share/gnome/control-center/.data/Critical.desktop
share/gnome/control-center/.data/Crystal.desktop
-share/gnome/control-center/.data/crystal.png
share/gnome/control-center/.data/Cynosure.desktop
share/gnome/control-center/.data/Decayscreen.desktop
share/gnome/control-center/.data/Deco.desktop
@@ -143,6 +142,7 @@ share/gnome/control-center/.data/braid.png
share/gnome/control-center/.data/bsod.png
share/gnome/control-center/.data/bubbles.png
share/gnome/control-center/.data/coral.png
+share/gnome/control-center/.data/crystal.png
share/gnome/control-center/.data/cynosure.png
share/gnome/control-center/.data/decayscreen.png
share/gnome/control-center/.data/deco.png
@@ -198,12 +198,9 @@ share/gnome/control-center/UIOptions/.directory
share/gnome/control-center/UIOptions/application.desktop
share/gnome/control-center/UIOptions/dialogs.desktop
share/gnome/control-center/UIOptions/mdi.desktop
-share/gnome/help/control-center/C/alf.html
-share/gnome/help/control-center/C/authors.html
-share/gnome/help/control-center/C/desktop-intro.html
share/gnome/help/control-center/C/control-center.sgml
+share/gnome/help/control-center/C/desktop-intro.html
share/gnome/help/control-center/C/doc-handlers.html
-share/gnome/help/control-center/C/docbook.css
share/gnome/help/control-center/C/figures/bg-capplet.png
share/gnome/help/control-center/C/figures/gccalf.png
share/gnome/help/control-center/C/figures/gccappdef.png
@@ -225,14 +222,8 @@ share/gnome/help/control-center/C/figures/screensave-capplet.png
share/gnome/help/control-center/C/figures/theme-select.png
share/gnome/help/control-center/C/figures/wm-add.png
share/gnome/help/control-center/C/figures/wm-main.png
-share/gnome/help/control-center/C/filetypes.html
-share/gnome/help/control-center/C/gccui.html
share/gnome/help/control-center/C/index.html
-share/gnome/help/control-center/C/license.html
share/gnome/help/control-center/C/ln7.html
-share/gnome/help/control-center/C/multimedia-intro.html
-share/gnome/help/control-center/C/peripherals.html
-share/gnome/help/control-center/C/session.html
share/gnome/help/control-center/C/stylesheet-images/caution.gif
share/gnome/help/control-center/C/stylesheet-images/home.gif
share/gnome/help/control-center/C/stylesheet-images/important.gif
@@ -278,6 +269,7 @@ share/locale/ja/LC_MESSAGES/control-center.mo
share/locale/ko/LC_MESSAGES/control-center.mo
share/locale/lt/LC_MESSAGES/control-center.mo
share/locale/nl/LC_MESSAGES/control-center.mo
+share/locale/nn/LC_MESSAGES/control-center.mo
share/locale/no/LC_MESSAGES/control-center.mo
share/locale/pl/LC_MESSAGES/control-center.mo
share/locale/pt/LC_MESSAGES/control-center.mo
@@ -291,7 +283,7 @@ share/locale/tr/LC_MESSAGES/control-center.mo
share/locale/uk/LC_MESSAGES/control-center.mo
share/locale/wa/LC_MESSAGES/control-center.mo
share/locale/zh_CN.GB2312/LC_MESSAGES/control-center.mo
-share/locale/zh_TW.Big5/LC_MESSAGES/control-center.mo
+share/locale/zh_TW/LC_MESSAGES/control-center.mo
@dirrm share/gnome/wm-properties
@dirrm share/gnome/omf/control-center
@dirrm share/gnome/help/control-center/C/stylesheet-images
@@ -314,5 +306,6 @@ share/locale/zh_TW.Big5/LC_MESSAGES/control-center.mo
@dirrm share/gnome/apps/Settings/Desktop
@dirrm share/gnome/apps/Settings
@dirrm share/gnome/apps
+@dirrm include/libcapplet1
@dirrm etc/CORBA/servers
@dirrm etc/CORBA