aboutsummaryrefslogtreecommitdiff
path: root/sysutils/goawk/Makefile
diff options
context:
space:
mode:
authorDmitri Goutnik <dmgk@FreeBSD.org>2019-09-29 22:34:31 +0000
committerDmitri Goutnik <dmgk@FreeBSD.org>2019-09-29 22:34:31 +0000
commitfc95b3f0cf943e760e906eac92aac51eff4d0c1c (patch)
tree8b41993e1df35d7245f4013a2d3adcb758a276a1 /sysutils/goawk/Makefile
parent67c4b925b7fd606361a2152563b80da493232dfb (diff)
downloadports-fc95b3f0cf943e760e906eac92aac51eff4d0c1c.tar.gz
ports-fc95b3f0cf943e760e906eac92aac51eff4d0c1c.zip
Go ports: cleanup, finish transition to USES=go started with r505321 (cat. sysutils-x11)
- Remove custom build/install targets left in place after r505321 - Switch to the new GO_TARGET tuple syntax introduced in r512001 Reviewed by: tobik Approved by: araujo (mentor), portmgr (adamw) Differential Revision: https://reviews.freebsd.org/D21744
Notes
Notes: svn path=/head/; revision=513276
Diffstat (limited to 'sysutils/goawk/Makefile')
-rw-r--r--sysutils/goawk/Makefile12
1 files changed, 2 insertions, 10 deletions
diff --git a/sysutils/goawk/Makefile b/sysutils/goawk/Makefile
index 214348535ab5..174ca8914bbd 100644
--- a/sysutils/goawk/Makefile
+++ b/sysutils/goawk/Makefile
@@ -9,22 +9,14 @@ MAINTAINER= yuri@FreeBSD.org
COMMENT= AWK interpreter written in Go
LICENSE= MIT
-LICENSE_FILE= ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}/LICENSE.txt
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
USES= go
-USE_GITHUB= nodefault # the main code is in GH_TUPLE
+USE_GITHUB= yes
GH_ACCOUNT= benhoyt
-GH_TUPLE= benhoyt:goawk:${DISTVERSIONFULL}:main/src/github.com/benhoyt/goawk
GH_SUBDIR= src/github.com/${GH_ACCOUNT}/${PORTNAME}
PLIST_FILES= bin/${PORTNAME}
-do-build:
- @cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME} && \
- ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go install ./...
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
-
.include <bsd.port.mk>