aboutsummaryrefslogtreecommitdiff
path: root/sysutils/hal
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2016-09-23 00:21:04 +0000
committerSteve Wills <swills@FreeBSD.org>2016-09-23 00:21:04 +0000
commit33a47c73764307d5c7171438ba797eaa3624d2f6 (patch)
treee00c6258da28243f25be0d7cdda51a3cb6434f63 /sysutils/hal
parent5d61e835f341df5ce29b2952cc353411aa244a36 (diff)
downloadports-33a47c73764307d5c7171438ba797eaa3624d2f6.tar.gz
ports-33a47c73764307d5c7171438ba797eaa3624d2f6.zip
sysutils/hal: fix cd support
PR: 210354 Submitted by: Ivan Klymenko <fidaj@ukr.net> Approved by: gnome@ (kwm)
Notes
Notes: svn path=/head/; revision=422642
Diffstat (limited to 'sysutils/hal')
-rw-r--r--sysutils/hal/Makefile2
-rw-r--r--sysutils/hal/files/patch-hald_freebsd_hf-scsi.c9
2 files changed, 10 insertions, 1 deletions
diff --git a/sysutils/hal/Makefile b/sysutils/hal/Makefile
index 539fecb14e3d..6d352fe59f5c 100644
--- a/sysutils/hal/Makefile
+++ b/sysutils/hal/Makefile
@@ -4,7 +4,7 @@
PORTNAME= hal
DISTVERSION= 0.5.14
-PORTREVISION= 30
+PORTREVISION= 31
CATEGORIES= sysutils
MASTER_SITES= http://hal.freedesktop.org/releases/
diff --git a/sysutils/hal/files/patch-hald_freebsd_hf-scsi.c b/sysutils/hal/files/patch-hald_freebsd_hf-scsi.c
index 02c2878e5185..f3c17f7d7029 100644
--- a/sysutils/hal/files/patch-hald_freebsd_hf-scsi.c
+++ b/sysutils/hal/files/patch-hald_freebsd_hf-scsi.c
@@ -9,6 +9,15 @@
{
hal_device_property_set_string(device, "storage.bus", "usb");
hal_device_property_set_string(device, "storage.originating_device", hal_device_get_udi(parent));
+@@ -301,7 +301,7 @@
+
+ driver = hal_device_property_get_string(child, "freebsd.driver");
+ /* ATAPI devices: CD-ROM (acd), tape (ast) or floppy (afd) */
+- if (! driver || (strcmp(driver, "acd") && strcmp(driver, "ast") && strcmp(driver, "afd")))
++ if (! driver || (strcmp(driver, "acd") && strcmp(driver, "ast") && strcmp(driver, "afd") && strcmp(driver, "cd")))
+ continue;
+
+ phys_device = hal_device_property_get_string(child, "storage.originating_device");
@@ -508,6 +508,16 @@
if (! parent || ! hal_device_property_get_bool(parent, "info.ignore"))
{