aboutsummaryrefslogtreecommitdiff
path: root/sysutils/hexyl/Makefile
diff options
context:
space:
mode:
authorMikael Urankar <mikael@FreeBSD.org>2022-12-08 07:49:54 +0000
committerMikael Urankar <mikael@FreeBSD.org>2022-12-08 17:17:34 +0000
commitbf6fc2c8ca2d3fd5642d1a1c9b808cc3d7e8cae6 (patch)
treec52970e5f70e819371ea2d84bd651f58b04eb35f /sysutils/hexyl/Makefile
parent5ee11f4522728e16e7c50c8ec99a53cb4f8b744f (diff)
downloadports-bf6fc2c8ca2d3fd5642d1a1c9b808cc3d7e8cae6.tar.gz
ports-bf6fc2c8ca2d3fd5642d1a1c9b808cc3d7e8cae6.zip
sysutils/hexyl: Update to 0.12.0
Diffstat (limited to 'sysutils/hexyl/Makefile')
-rw-r--r--sysutils/hexyl/Makefile88
1 files changed, 54 insertions, 34 deletions
diff --git a/sysutils/hexyl/Makefile b/sysutils/hexyl/Makefile
index 41b193004308..398fcbc5ffd1 100644
--- a/sysutils/hexyl/Makefile
+++ b/sysutils/hexyl/Makefile
@@ -1,7 +1,6 @@
PORTNAME= hexyl
DISTVERSIONPREFIX= v
-DISTVERSION= 0.10.0
-PORTREVISION= 5
+DISTVERSION= 0.12.0
CATEGORIES= sysutils
MAINTAINER= mikael@FreeBSD.org
@@ -17,55 +16,76 @@ USES= cargo
USE_GITHUB= yes
GH_ACCOUNT= sharkdp
-CARGO_CRATES= aho-corasick-0.7.18 \
- ansi_term-0.12.1 \
- anyhow-1.0.57 \
- assert_cmd-2.0.4 \
+CARGO_CRATES= aho-corasick-0.7.20 \
+ anyhow-1.0.66 \
+ assert_cmd-2.0.7 \
atty-0.2.14 \
autocfg-1.1.0 \
bitflags-1.3.2 \
- bstr-0.2.17 \
- clap-3.1.18 \
- clap_lex-0.2.0 \
- const_format-0.2.23 \
- const_format_proc_macros-0.2.22 \
+ bstr-1.0.1 \
+ cc-1.0.77 \
+ clap-4.0.29 \
+ clap_lex-0.3.0 \
+ const_format-0.2.30 \
+ const_format_proc_macros-0.2.29 \
+ ctor-0.1.26 \
+ diff-0.1.13 \
difflib-0.4.0 \
doc-comment-0.3.3 \
- either-1.6.1 \
+ either-1.8.0 \
+ errno-0.2.8 \
+ errno-dragonfly-0.1.2 \
float-cmp-0.9.0 \
- hashbrown-0.11.2 \
hermit-abi-0.1.19 \
- indexmap-1.8.1 \
- itertools-0.10.3 \
- lazy_static-1.4.0 \
- libc-0.2.126 \
+ hermit-abi-0.2.6 \
+ io-lifetimes-1.0.3 \
+ is-terminal-0.4.1 \
+ is_ci-1.1.1 \
+ itertools-0.10.5 \
+ libc-0.2.138 \
+ linux-raw-sys-0.1.3 \
memchr-2.5.0 \
normalize-line-endings-0.3.0 \
num-traits-0.2.15 \
- os_str_bytes-6.0.1 \
- predicates-2.1.1 \
- predicates-core-1.0.3 \
- predicates-tree-1.0.5 \
- proc-macro2-1.0.39 \
- quote-1.0.18 \
- regex-1.5.6 \
+ once_cell-1.16.0 \
+ os_str_bytes-6.4.1 \
+ output_vt100-0.1.3 \
+ owo-colors-3.5.0 \
+ predicates-2.1.4 \
+ predicates-core-1.0.5 \
+ predicates-tree-1.0.7 \
+ pretty_assertions-1.3.0 \
+ proc-macro2-1.0.47 \
+ quote-1.0.21 \
+ regex-1.7.0 \
regex-automata-0.1.10 \
- regex-syntax-0.6.26 \
+ regex-syntax-0.6.28 \
+ rustix-0.36.5 \
+ serde-1.0.149 \
strsim-0.10.0 \
- syn-1.0.95 \
+ supports-color-1.3.1 \
+ syn-1.0.105 \
termcolor-1.1.3 \
- terminal_size-0.1.17 \
- termtree-0.2.4 \
- textwrap-0.15.0 \
- thiserror-1.0.31 \
- thiserror-impl-1.0.31 \
- unicode-ident-1.0.0 \
- unicode-xid-0.2.3 \
+ terminal_size-0.2.3 \
+ termtree-0.4.0 \
+ thiserror-1.0.37 \
+ thiserror-impl-1.0.37 \
+ unicode-ident-1.0.5 \
+ unicode-xid-0.2.4 \
wait-timeout-0.2.0 \
winapi-0.3.9 \
winapi-i686-pc-windows-gnu-0.4.0 \
winapi-util-0.1.5 \
- winapi-x86_64-pc-windows-gnu-0.4.0
+ winapi-x86_64-pc-windows-gnu-0.4.0 \
+ windows-sys-0.42.0 \
+ windows_aarch64_gnullvm-0.42.0 \
+ windows_aarch64_msvc-0.42.0 \
+ windows_i686_gnu-0.42.0 \
+ windows_i686_msvc-0.42.0 \
+ windows_x86_64_gnu-0.42.0 \
+ windows_x86_64_gnullvm-0.42.0 \
+ windows_x86_64_msvc-0.42.0 \
+ yansi-0.5.1
PLIST_FILES= bin/hexyl