aboutsummaryrefslogtreecommitdiff
path: root/sysutils/htop
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-07-18 04:14:47 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-07-18 04:14:47 +0000
commita275b9de9c636542509a35090412ef470acc1f45 (patch)
treee5ccffd8467bbb2e4b23b4fb9cf18f896ce5829b /sysutils/htop
parent8ea6ff969f64eed115f923fd89f7bba84463bba9 (diff)
downloadports-a275b9de9c636542509a35090412ef470acc1f45.tar.gz
ports-a275b9de9c636542509a35090412ef470acc1f45.zip
- Update to 0.8
- Enable unicode support - Disable plsa lib (CPU affinity) PR: ports/125671 Submitted by: Yi-Jheng Lin <yzlin at cs.nctu.edu.tw> Approved by: Tony Shadwick <tshadwick at oss-solutions.com> (maintainer)
Notes
Notes: svn path=/head/; revision=217004
Diffstat (limited to 'sysutils/htop')
-rw-r--r--sysutils/htop/Makefile20
-rw-r--r--sysutils/htop/distinfo6
-rw-r--r--sysutils/htop/files/patch-Makefile.am18
-rw-r--r--sysutils/htop/files/patch-Process.c28
-rw-r--r--sysutils/htop/files/patch-Process.h24
-rw-r--r--sysutils/htop/files/patch-configure.ac14
-rw-r--r--sysutils/htop/files/patch-htop.c41
7 files changed, 145 insertions, 6 deletions
diff --git a/sysutils/htop/Makefile b/sysutils/htop/Makefile
index 949a95c7e599..9102c08eb645 100644
--- a/sysutils/htop/Makefile
+++ b/sysutils/htop/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= htop
-PORTVERSION= 0.6.6
+PORTVERSION= 0.8
CATEGORIES= sysutils
MASTER_SITES= SF
@@ -16,10 +16,24 @@ COMMENT= A better top(1) - interactive process viewer
NOT_FOR_ARCHS= sparc64
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-proc=/compat/linux/proc
+CONFIGURE_ARGS= --with-proc=/compat/linux/proc --enable-unicode
+USE_AUTOTOOLS= autoconf:261 aclocal:19 automake:19 libtool:15
+ACLOCAL_ARGS= -I ${ACLOCAL_DIR}
+
+USE_PYTHON_BUILD= yes
+
MAN1= htop.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 602107 || (${OSVERSION} > 700000 && ${OSVERSION} < 700033)
+LIB_DEPENDS+= ncursesw.5:${PORTSDIR}/devel/ncurses
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's:/usr/bin/python:${LOCALBASE}/bin/python:' ${WRKSRC}/scripts/MakeHeader.py
+
pre-configure:
@[ -f /compat/linux/proc/stat ] || { ${CAT} ${PKGMESSAGE}; ${FALSE}; }
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/htop/distinfo b/sysutils/htop/distinfo
index dec768c1eced..2fc4c35500e9 100644
--- a/sysutils/htop/distinfo
+++ b/sysutils/htop/distinfo
@@ -1,3 +1,3 @@
-MD5 (htop-0.6.6.tar.gz) = 12c8e6e97bd50a4e0a4730d23675fc7b
-SHA256 (htop-0.6.6.tar.gz) = b2e2ef39afc870c9ef7228959b53fbd38fab02be74bb0d3e91ebf4fdbaa752e0
-SIZE (htop-0.6.6.tar.gz) = 141140
+MD5 (htop-0.8.tar.gz) = b6955f8d75cdb5a3ccea83415cb18815
+SHA256 (htop-0.8.tar.gz) = eb0076376542b68d4ce37c7ba87c3cabc92ca85ca3d28607d6fcdf2ce20383d7
+SIZE (htop-0.8.tar.gz) = 412672
diff --git a/sysutils/htop/files/patch-Makefile.am b/sysutils/htop/files/patch-Makefile.am
new file mode 100644
index 000000000000..4fcb676427e2
--- /dev/null
+++ b/sysutils/htop/files/patch-Makefile.am
@@ -0,0 +1,18 @@
+--- Makefile.am.orig 2008-07-16 11:16:00.000000000 +0800
++++ Makefile.am 2008-07-16 11:16:14.000000000 +0800
+@@ -1,5 +1,5 @@
+
+-SUBDIRS = plpa-1.1
++SUBDIRS =
+
+ bin_PROGRAMS = htop
+ dist_man_MANS = htop.1
+@@ -34,7 +34,7 @@
+
+ BUILT_SOURCES = $(myhtopheaders)
+ htop_SOURCES = $(myhtopheaders) $(myhtopsources) config.h debug.h
+-htop_LDADD = $(top_builddir)/plpa-1.1/src/libplpa_included.la
++htop_LDADD =
+
+ profile:
+ $(MAKE) all CFLAGS="-pg -O2"
diff --git a/sysutils/htop/files/patch-Process.c b/sysutils/htop/files/patch-Process.c
new file mode 100644
index 000000000000..811adb52ff45
--- /dev/null
+++ b/sysutils/htop/files/patch-Process.c
@@ -0,0 +1,28 @@
+--- Process.c.orig 2008-03-15 02:35:05.000000000 +0800
++++ Process.c 2008-07-16 12:51:24.000000000 +0800
+@@ -28,7 +28,9 @@
+ #include <pwd.h>
+ #include <sched.h>
+
++#if 0
+ #include <plpa.h>
++#endif
+
+ // This works only with glibc 2.1+. On earlier versions
+ // the behavior is similar to have a hardcoded page size.
+@@ -478,6 +480,7 @@
+ return (err == 0);
+ }
+
++#if 0
+ unsigned long Process_getAffinity(Process* this) {
+ unsigned long mask = 0;
+ plpa_sched_getaffinity(this->pid, sizeof(unsigned long), (plpa_cpu_set_t*) &mask);
+@@ -487,6 +490,7 @@
+ bool Process_setAffinity(Process* this, unsigned long mask) {
+ return (plpa_sched_setaffinity(this->pid, sizeof(unsigned long), (plpa_cpu_set_t*) &mask) == 0);
+ }
++#endif
+
+ void Process_sendSignal(Process* this, int signal) {
+ kill(this->pid, signal);
diff --git a/sysutils/htop/files/patch-Process.h b/sysutils/htop/files/patch-Process.h
new file mode 100644
index 000000000000..444d406f6af5
--- /dev/null
+++ b/sysutils/htop/files/patch-Process.h
@@ -0,0 +1,24 @@
+--- Process.h.orig 2008-03-15 02:42:15.000000000 +0800
++++ Process.h 2008-07-16 12:52:37.000000000 +0800
+@@ -31,7 +31,9 @@
+ #include <pwd.h>
+ #include <sched.h>
+
++#if 0
+ #include <plpa.h>
++#endif
+
+ // This works only with glibc 2.1+. On earlier versions
+ // the behavior is similar to have a hardcoded page size.
+@@ -166,9 +168,11 @@
+
+ bool Process_setPriority(Process* this, int priority);
+
++#if 0
+ unsigned long Process_getAffinity(Process* this);
+
+ bool Process_setAffinity(Process* this, unsigned long mask);
++#endif
+
+ void Process_sendSignal(Process* this, int signal);
+
diff --git a/sysutils/htop/files/patch-configure.ac b/sysutils/htop/files/patch-configure.ac
new file mode 100644
index 000000000000..044e1d5b9a60
--- /dev/null
+++ b/sysutils/htop/files/patch-configure.ac
@@ -0,0 +1,14 @@
+--- configure.ac.orig 2008-07-16 10:48:24.000000000 +0800
++++ configure.ac 2008-07-16 10:48:36.000000000 +0800
+@@ -84,11 +84,5 @@
+ AC_CHECK_FILE($PROCDIR/stat,,AC_MSG_ERROR(Cannot find /proc/stat. Make sure you have a Linux-compatible /proc filesystem mounted. See the file README for help.))
+ AC_CHECK_FILE($PROCDIR/meminfo,,AC_MSG_ERROR(Cannot find /proc/meminfo. Make sure you have a Linux-compatible /proc filesystem mounted. See the file README for help.))
+
+-PLPA_INCLUDED(plpa-1.1)
+-PLPA_INIT(plpa_happy=yes, plpa_happy=no)
+-if test "x$plpa_happy" = xno; then
+- AC_MSG_ERROR([Failed to initialize PLPA.])
+-fi
+-
+ AC_CONFIG_FILES([Makefile])
+ AC_OUTPUT
diff --git a/sysutils/htop/files/patch-htop.c b/sysutils/htop/files/patch-htop.c
new file mode 100644
index 000000000000..4b44d1b917e8
--- /dev/null
+++ b/sysutils/htop/files/patch-htop.c
@@ -0,0 +1,41 @@
+--- htop.c.orig 2008-04-27 13:56:38.000000000 +0800
++++ htop.c 2008-07-16 12:54:44.000000000 +0800
+@@ -110,9 +110,11 @@
+ mvaddstr(15, 0, " F9 k: kill process/tagged processes P: sort by CPU%");
+ mvaddstr(16, 0, " + [ F7: lower priority (+ nice) M: sort by MEM%");
+ mvaddstr(17, 0, " - ] F8: higher priority (root only) T: sort by TIME");
++#if 0
+ if (pl->processorCount > 1)
+ mvaddstr(18, 0, " a: set CPU affinity F4 I: invert sort order");
+ else
++#endif
+ mvaddstr(18, 0, " F4 I: invert sort order");
+ mvaddstr(19, 0, " F2 S: setup F6 >: select sort column");
+ mvaddstr(20, 0, " F1 h: show this help screen");
+@@ -129,8 +131,10 @@
+ mvaddstr(16, 0, " + [ F7"); mvaddstr(16,40, " M");
+ mvaddstr(17, 0, " - ] F8"); mvaddstr(17,40, " T");
+ mvaddstr(18,40, " F4 I");
++#if 0
+ if (pl->processorCount > 1)
+ mvaddstr(18, 0, " a:");
++#endif
+ mvaddstr(19, 0, " F2 S"); mvaddstr(19,40, " F6 >");
+ mvaddstr(20, 0, " F1 h");
+ mvaddstr(21, 0, " F10 q"); mvaddstr(21,40, " s");
+@@ -625,6 +629,7 @@
+ refreshTimeout = 0;
+ break;
+ }
++#if 0
+ case 'a':
+ {
+ if (pl->processorCount == 1)
+@@ -660,6 +665,7 @@
+ refreshTimeout = 0;
+ break;
+ }
++#endif
+ case KEY_F(10):
+ case 'q':
+ quit = 1;