aboutsummaryrefslogtreecommitdiff
path: root/sysutils/incron
diff options
context:
space:
mode:
authorTrenton Schulz <trueos@norwegianrockcat.com>2023-07-31 08:28:05 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-08-13 16:41:05 +0000
commitba7720b45c318713be97c1739af97d468e5241eb (patch)
tree2959499bc07f93097b247dbd7db2a64e4e87a6a8 /sysutils/incron
parent0a4f7ff84bcc9f2c277218faaa2ed16851be2afe (diff)
downloadports-ba7720b45c318713be97c1739af97d468e5241eb.tar.gz
ports-ba7720b45c318713be97c1739af97d468e5241eb.zip
sysutils/incron: fix dependency on hard-coded /bin/bash
PR: 272800 Reported by: trueos@norwegianrockcat.com Approved by: joh.hendriks@gmail.com (maintainer, timeout > 2 weeks)
Diffstat (limited to 'sysutils/incron')
-rw-r--r--sysutils/incron/Makefile2
-rw-r--r--sysutils/incron/files/patch-usertable.cpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/sysutils/incron/Makefile b/sysutils/incron/Makefile
index 82a7d3537038..2967f44c7d1f 100644
--- a/sysutils/incron/Makefile
+++ b/sysutils/incron/Makefile
@@ -1,6 +1,6 @@
PORTNAME= incron
DISTVERSION= 2017-11-13
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MAINTAINER= joh.hendriks@gmail.com
diff --git a/sysutils/incron/files/patch-usertable.cpp b/sysutils/incron/files/patch-usertable.cpp
new file mode 100644
index 000000000000..3aa95dfec2ee
--- /dev/null
+++ b/sysutils/incron/files/patch-usertable.cpp
@@ -0,0 +1,11 @@
+--- usertable.cpp.orig 2023-07-29 17:29:34 UTC
++++ usertable.cpp
+@@ -608,7 +608,7 @@ void UserTable::RunAsUser(std::string cmd) const
+ }
+ }
+
+- execlp("/bin/bash","/bin/bash", "-c", cmd.c_str(), (char *)NULL);
++ execlp("/bin/sh","/bin/sh", "-c", cmd.c_str(), (char *)NULL);
+
+ failed:
+