aboutsummaryrefslogtreecommitdiff
path: root/sysutils/inotify-tools/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2017-08-18 15:25:32 +0000
committerSteve Wills <swills@FreeBSD.org>2017-08-18 15:25:32 +0000
commit4168e81bc95f1c4e0be794317513dd1c9688debb (patch)
tree056558d641c2795af6ffe73bec27089ab7bd081b /sysutils/inotify-tools/Makefile
parent93990ae798939caaac2aef867c1d5a36fe75485c (diff)
downloadports-4168e81bc95f1c4e0be794317513dd1c9688debb.tar.gz
ports-4168e81bc95f1c4e0be794317513dd1c9688debb.zip
sysutils/inotify-tools: multiple cleanups
* Added STATIC option * Fixed license * Simplified patches * Switched to USES=localbase * Reorganized sections PR: 221595 Submitted by: Yuri Victorovich <yuri@rawbw.com> (maintainer)
Notes
Notes: svn path=/head/; revision=448240
Diffstat (limited to 'sysutils/inotify-tools/Makefile')
-rw-r--r--sysutils/inotify-tools/Makefile25
1 files changed, 20 insertions, 5 deletions
diff --git a/sysutils/inotify-tools/Makefile b/sysutils/inotify-tools/Makefile
index 321458c8679c..5917ff46b723 100644
--- a/sysutils/inotify-tools/Makefile
+++ b/sysutils/inotify-tools/Makefile
@@ -4,26 +4,41 @@
PORTNAME= inotify-tools
PORTVERSION= 3.14.01
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= sysutils
MAINTAINER= yuri@rawbw.com
COMMENT= Command-line utilities to watch for file events
-LICENSE= AGPLv3
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libinotify.so:devel/libinotify
+USES= autoreconf gmake libtool localbase
USE_GITHUB= yes
GH_ACCOUNT= rvoicilas
GH_TAGNAME= 1df9af4
-
-USES= autoreconf gmake libtool
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-doxygen
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+OPTIONS_DEFINE= STATIC
+OPTIONS_SUB= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|stat64|stat|' \
+ ${WRKSRC}/src/common.c \
+ ${WRKSRC}/libinotifytools/src/inotifytools.c
+
+post-build-STATIC-on:
+ @cd ${WRKSRC}/src && \
+ ${CC} -pthread ${LDFLAGS} -static -o inotifywait.static inotifywait.o common.o ../libinotifytools/src/.libs/libinotifytools.a ${LOCALBASE}/lib/libinotify.a && \
+ ${CC} -pthread ${LDFLAGS} -static -o inotifywatch.static inotifywatch.o common.o ../libinotifytools/src/.libs/libinotifytools.a ${LOCALBASE}/lib/libinotify.a
+
+post-install-STATIC-on:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/inotifywait.static ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/inotifywatch.static ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>