aboutsummaryrefslogtreecommitdiff
path: root/sysutils/intel-pcm
diff options
context:
space:
mode:
authorWarner Losh <imp@FreeBSD.org>2015-01-21 04:31:17 +0000
committerWarner Losh <imp@FreeBSD.org>2015-01-21 04:31:17 +0000
commit9e5d37221b0c6915951ac9df098fda8be99ae943 (patch)
tree87fc3b5b9d6282d7fbf071e3b84cf30fe0296155 /sysutils/intel-pcm
parentbf8999168deb7cb85ed08da6e19e0057f02c082a (diff)
downloadports-9e5d37221b0c6915951ac9df098fda8be99ae943.tar.gz
ports-9e5d37221b0c6915951ac9df098fda8be99ae943.zip
Update to 2.8.
Notes
Notes: svn path=/head/; revision=377572
Diffstat (limited to 'sysutils/intel-pcm')
-rw-r--r--sysutils/intel-pcm/Makefile3
-rw-r--r--sysutils/intel-pcm/distinfo4
-rw-r--r--sysutils/intel-pcm/files/patch-cpucounters-cpp12
-rw-r--r--sysutils/intel-pcm/files/patch-cpuctl_check60
4 files changed, 3 insertions, 76 deletions
diff --git a/sysutils/intel-pcm/Makefile b/sysutils/intel-pcm/Makefile
index cc035d4ce042..4b5f7faab06d 100644
--- a/sysutils/intel-pcm/Makefile
+++ b/sysutils/intel-pcm/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= intel-pcm
-PORTVERSION= 2.6
-PORTREVISION= 2
+PORTVERSION= 2.8
CATEGORIES= sysutils
MASTER_SITES= LOCAL/imp
DISTNAME= intelperformancecountermonitorv${PORTVERSION}
diff --git a/sysutils/intel-pcm/distinfo b/sysutils/intel-pcm/distinfo
index ce29514d933d..0336c2f44999 100644
--- a/sysutils/intel-pcm/distinfo
+++ b/sysutils/intel-pcm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (intelperformancecountermonitorv2.6.zip) = 781dcaa0bfa49593878e16db131c31e8f0a401e6e58f8c2786a6d70b1be67857
-SIZE (intelperformancecountermonitorv2.6.zip) = 907379
+SHA256 (intelperformancecountermonitorv2.8.zip) = 3c51b2fc7b772f16f746ea6fda0471d280c0f27bfd52fa51dd78433ca5a6ca6a
+SIZE (intelperformancecountermonitorv2.8.zip) = 931374
diff --git a/sysutils/intel-pcm/files/patch-cpucounters-cpp b/sysutils/intel-pcm/files/patch-cpucounters-cpp
deleted file mode 100644
index e029cf2b4e5c..000000000000
--- a/sysutils/intel-pcm/files/patch-cpucounters-cpp
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ru cpucounters.cpp cpucounters.cpp
---- cpucounters.cpp 2013-11-04 05:43:31.000000000 -0700
-+++ cpucounters.cpp 2014-03-07 05:47:24.000000000 -0700
-@@ -681,7 +681,7 @@
- else
- apic_ids_per_core = 1;
-
-- for (i = 0; i < num_cores; i++)
-+ for (int i = 0; i < num_cores; i++)
- {
- char cpuctl_name[64];
- int apic_id;
diff --git a/sysutils/intel-pcm/files/patch-cpuctl_check b/sysutils/intel-pcm/files/patch-cpuctl_check
deleted file mode 100644
index 092f657bd5ca..000000000000
--- a/sysutils/intel-pcm/files/patch-cpuctl_check
+++ /dev/null
@@ -1,60 +0,0 @@
-commit f87e1f30a39055cdb3b10964a805a9b5e41e6a77
-Author: Jim Harris <james.r.harris@intel.com>
-Date: Mon Apr 14 22:59:44 2014 -0700
-
- FreeBSD: ensure cpuctl(4) driver is loaded.
-
- Also do a couple of sanity checks on some of the apic cpuid parsing.
- This just ensures we get a sensible error messages rather than an
- FPE if some logic bug is found in the apic parsing code.
-
-diff --git cpucounters.cpp cpucounters.cpp
-index df8a802..0a9fc26 100644
---- cpucounters.cpp
-+++ cpucounters.cpp
-@@ -63,6 +63,8 @@ int convertUnknownToInt(size_t size, char* value);
- #endif
-
- #if defined (__FreeBSD__)
-+#include <sys/param.h>
-+#include <sys/module.h>
- #include <sys/types.h>
- #include <sys/sysctl.h>
- #include <sys/sem.h>
-@@ -735,11 +737,23 @@ PCM::PCM() :
- std::cerr << "Unable to get kern.smp.cpus from sysctl." << std::endl;
- return;
- }
-+
-+ if (modfind("cpuctl") == -1)
-+ {
-+ std::cout << "cpuctl(4) not loaded." << std::endl;
-+ return;
-+ }
-
- do_cpuid(1, cpuid_args.data);
-
- apic_ids_per_package = (cpuid_args.data[1] & 0x00FF0000) >> 16;
-
-+ if (apic_ids_per_package == 0)
-+ {
-+ std::cout << "apic_ids_per_package == 0" << std::endl;
-+ return;
-+ }
-+
- cpuid_count(0xb, 0x0, cpuid_args.data);
-
- if ((cpuid_args.data[2] & 0xFF00) == 0x100)
-@@ -747,6 +761,12 @@ PCM::PCM() :
- else
- apic_ids_per_core = 1;
-
-+ if (apic_ids_per_core == 0)
-+ {
-+ std::cout << "apic_ids_per_core == 0" << std::endl;
-+ return;
-+ }
-+
- for (int i = 0; i < num_cores; i++)
- {
- char cpuctl_name[64];