aboutsummaryrefslogtreecommitdiff
path: root/sysutils/iocell
diff options
context:
space:
mode:
authorBartek Rutkowski <robak@FreeBSD.org>2016-12-16 20:21:16 +0000
committerBartek Rutkowski <robak@FreeBSD.org>2016-12-16 20:21:16 +0000
commit84bdb2399d686a1fc21b6242a9a8145e6998f325 (patch)
tree7bb253b7876e3b2a1fd06f45fcfe1e57629a30f9 /sysutils/iocell
parent3f7340128cded0f4fafef38f998e57c32b7d935a (diff)
downloadports-84bdb2399d686a1fc21b6242a9a8145e6998f325.tar.gz
ports-84bdb2399d686a1fc21b6242a9a8145e6998f325.zip
sysutils/iocell: NEW PORT - Feature rich Jail containers manager (iocage fork)
iocell is a zero dependency drop in jail/container manager amalgamating some of the best features and technologies FreeBSD operating system has to offer. It is geared for ease of use with a simple and easy to understand command syntax. iocell has been forked from iocage with the goal of keeping original iocage experience available, providing bugfixes and new features. WWW: https://github.com/bartekrutkowski/iocell Submitted by: Bartek Rutkowski <robak@FreeBSD.org> Sponsored by: Pixeware LTD
Notes
Notes: svn path=/head/; revision=428695
Diffstat (limited to 'sysutils/iocell')
-rw-r--r--sysutils/iocell/Makefile39
-rw-r--r--sysutils/iocell/distinfo3
-rw-r--r--sysutils/iocell/pkg-descr12
-rw-r--r--sysutils/iocell/pkg-plist19
4 files changed, 73 insertions, 0 deletions
diff --git a/sysutils/iocell/Makefile b/sysutils/iocell/Makefile
new file mode 100644
index 000000000000..bd228ba4ef50
--- /dev/null
+++ b/sysutils/iocell/Makefile
@@ -0,0 +1,39 @@
+# Created by: Bartek Rutkowski <robak@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= iocell
+PORTVERSION= 2.0.0
+DISTVERSIONPREFIX=v
+CATEGORIES= sysutils
+
+MAINTAINER= robak@FreeBSD.org
+COMMENT= Feature rich Jail containers manager (iocage fork)
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= uclcmd:devel/uclcmd
+
+CONFLICTS= iocage-*
+
+USE_GITHUB= yes
+GH_ACCOUNT= bartekrutkowski
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+IGNORE_FreeBSD_9= requires FreeBSD 10.x or newer
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|/usr/local/lib/iocell|${PREFIX}/lib/iocell|g" ${WRKSRC}/iocell
+
+pre-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/iocell
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/rc.d/iocell ${STAGEDIR}${PREFIX}/etc/rc.d
+ ${INSTALL_SCRIPT} ${WRKSRC}/iocell ${STAGEDIR}${PREFIX}/sbin
+ (cd ${WRKSRC}/lib/ && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/lib/iocell)
+ ${INSTALL_MAN} ${WRKSRC}/iocell.8 ${STAGEDIR}${PREFIX}/man/man8
+
+.include <bsd.port.mk>
diff --git a/sysutils/iocell/distinfo b/sysutils/iocell/distinfo
new file mode 100644
index 000000000000..4a776fc34734
--- /dev/null
+++ b/sysutils/iocell/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1481915244
+SHA256 (bartekrutkowski-iocell-v2.0.0_GH0.tar.gz) = a175e6e5177a8ea8771d4443b766384b1c9db65093fe56d6d9e1cb942dea1a3f
+SIZE (bartekrutkowski-iocell-v2.0.0_GH0.tar.gz) = 371045
diff --git a/sysutils/iocell/pkg-descr b/sysutils/iocell/pkg-descr
new file mode 100644
index 000000000000..144e57a8b41d
--- /dev/null
+++ b/sysutils/iocell/pkg-descr
@@ -0,0 +1,12 @@
+iocell is a zero dependency drop in jail/container manager
+amalgamating some of the best features and technologies
+FreeBSD operating system has to offer.
+
+It is geared for ease of use with a simple and easy to
+understand command syntax.
+
+iocell has been forked from iocage with the goal of keeping
+original iocage experience available, providing bugfixes
+and new features.
+
+WWW: https://github.com/bartekrutkowski/iocell
diff --git a/sysutils/iocell/pkg-plist b/sysutils/iocell/pkg-plist
new file mode 100644
index 000000000000..45d6085abadf
--- /dev/null
+++ b/sysutils/iocell/pkg-plist
@@ -0,0 +1,19 @@
+etc/rc.d/iocell
+lib/iocell/ioc-cmd
+lib/iocell/ioc-common
+lib/iocell/ioc-configure
+lib/iocell/ioc-git
+lib/iocell/ioc-globals
+lib/iocell/ioc-hacks
+lib/iocell/ioc-help
+lib/iocell/ioc-image
+lib/iocell/ioc-info
+lib/iocell/ioc-network
+lib/iocell/ioc-rc
+lib/iocell/ioc-rctl
+lib/iocell/ioc-send
+lib/iocell/ioc-snapshot
+lib/iocell/ioc-upgrade
+lib/iocell/ioc-zfs
+man/man8/iocell.8.gz
+sbin/iocell