aboutsummaryrefslogtreecommitdiff
path: root/sysutils/k3b
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2019-04-14 21:41:23 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2019-04-14 21:41:23 +0000
commitbec9b29568ce3145027d17911dd217352e8df445 (patch)
tree6f64361fe4f7cdd8f79cdbe0684eb8ad489bd28a /sysutils/k3b
parent299341010b98ea81f246e9366093f60ad05c0531 (diff)
downloadports-bec9b29568ce3145027d17911dd217352e8df445.tar.gz
ports-bec9b29568ce3145027d17911dd217352e8df445.zip
sysutils/k3b Add missing runtime dependencies
- While libburn and cdrskin aren't *mandatory*, it's nicer to have them by default and avoids a warning popup on start. - Polish up the pkg-message to better match current usage, and mention the (preferred) BSDISKS option for Solid. PR: 228408
Notes
Notes: svn path=/head/; revision=498952
Diffstat (limited to 'sysutils/k3b')
-rw-r--r--sysutils/k3b/Makefile6
-rw-r--r--sysutils/k3b/pkg-message16
2 files changed, 16 insertions, 6 deletions
diff --git a/sysutils/k3b/Makefile b/sysutils/k3b/Makefile
index c8c33859bf84..8ae74be950ef 100644
--- a/sysutils/k3b/Makefile
+++ b/sysutils/k3b/Makefile
@@ -2,6 +2,7 @@
PORTNAME= k3b
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= sysutils multimedia kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -34,7 +35,7 @@ USE_QT= core dbus gui network webkit widgets xml \
# The ffmpeg-plugin needs patching
CMAKE_ARGS= -DK3B_BUILD_FFMPEG_DECODER_PLUGIN:BOOL=FALSE
-OPTIONS_DEFINE= CDRDAO DVDPLUSRW EMOVIX VCDIMAGER DOCS
+OPTIONS_DEFINE= CDRDAO CDRSKIN DVDPLUSRW EMOVIX VCDIMAGER DOCS
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
CDRDAO_DESC= Burning: cdrdao
@@ -49,4 +50,7 @@ EMOVIX_RUN_DEPENDS= mkmovixiso:multimedia/emovix
VCDIMAGER_DESC= Burning: VCDImager (video CDs)
VCDIMAGER_RUN_DEPENDS= vcdxrip:multimedia/vcdimager
+CDRSKIN_DESC= Burning: cdrskin (improved performance)
+CDRSKIN_RUN_DEPENDS= cdrskin:devel/libburn
+
.include <bsd.port.mk>
diff --git a/sysutils/k3b/pkg-message b/sysutils/k3b/pkg-message
index de2da15867e4..ebce8911437d 100644
--- a/sysutils/k3b/pkg-message
+++ b/sysutils/k3b/pkg-message
@@ -7,15 +7,16 @@
'man cdrecord' discusses this.
b. Set the vfs.usermount sysctl variable to 1.
# sysctl vfs.usermount=1
- Add the line vfs.usermount=1 to /etc/sysctl.conf
+ Add this line to /etc/sysctl.conf to make it permanent:
+ vfs.usermount=1
Note that this has negative security implications
c. Every user must have read and write access to /dev/cdX:
- add to your /etc/devfs.rules under '[system=10]':
add path 'cd*' mode 666
- or if you prefer allow access for a group XXX only add instead:
add path 'cd*' mode 660 group XXX
- - to enable it, add to your /etc/rc.conf a
- devfs_system_ruleset="system"
+ - to enable it, add to your /etc/rc.conf
+ # sysrc devfs_system_ruleset="system"
d. Every user who should be able to use k3b must have read and write access
to all pass through devices connected with CD and DVD drives and to the
/dev/xpt0 device. Run 'camcontrol devlist' to identify those devices (seek
@@ -28,9 +29,14 @@
add path 'pass*' mode 660 group XXX
add path 'xpt0' mode 660 group XXX
- to enable it, add to your /etc/rc.conf
- devfs_system_ruleset="system"
+ # sysrc devfs_system_ruleset="system"
- to apply these changes without reboot, run as root:
- /etc/rc.d/devfs restart
+ # service devfs restart
3. Create a directory on a partition, which has enough disk space to hold a CDs
or DVDs content (usually below /usr). Enter this directory in Settings->
Configure K3b...->Misc.
+4. You must configure devel/kf5-solid appropriately:
+ a. Either use the (default) HAL backend, and enable HAL in /etc/rc.conf via
+ # sysrc hald_enable="YES"
+ b. *or* use the (experimental) BSDISKS backend.
+