aboutsummaryrefslogtreecommitdiff
path: root/sysutils/kapp
diff options
context:
space:
mode:
authorPavel Timofeev <timp87@gmail.com>2023-01-25 21:56:31 +0000
committerMikael Urankar <mikael@FreeBSD.org>2023-01-26 12:15:57 +0000
commit2efc2d43d762a65f2ae0107d7340d3f0b37cbf5c (patch)
tree86a5985e5fb4cde5797368596fd261b09199bd24 /sysutils/kapp
parent416eecd6af0612ab510dc607f8988bb5a0a1b034 (diff)
downloadports-2efc2d43d762a65f2ae0107d7340d3f0b37cbf5c.tar.gz
ports-2efc2d43d762a65f2ae0107d7340d3f0b37cbf5c.zip
sysutils/kapp: Add new port
kapp is a simple deployment tool for k8s kapp CLI encourages Kubernetes users to manage resources in bulk by working with "Kubernetes applications" (sets of resources with the same label). It focuses on resource diffing, labeling, deployment and deletion. Unlike tools like Helm, kapp considers YAML templating and management of packages outside of its scope, though it works great with tools that generate Kubernetes configuration. PR: 255075
Diffstat (limited to 'sysutils/kapp')
-rw-r--r--sysutils/kapp/Makefile19
-rw-r--r--sysutils/kapp/distinfo5
-rw-r--r--sysutils/kapp/pkg-descr6
3 files changed, 30 insertions, 0 deletions
diff --git a/sysutils/kapp/Makefile b/sysutils/kapp/Makefile
new file mode 100644
index 000000000000..67492b22e4c2
--- /dev/null
+++ b/sysutils/kapp/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= kapp
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.54.2
+CATEGORIES= sysutils
+
+MAINTAINER= timp87@gmail.com
+COMMENT= Simple deployment tool for Kubernetes
+WWW= https://github.com/carvel-dev/kapp
+
+LICENSE= APACHE20
+
+USES= go:modules
+GO_MODULE= github.com/carvel-dev/${PORTNAME}
+GO_BUILDFLAGS= -ldflags="-X github.com/vmware-tanzu/carvel-kapp/pkg/kapp/version.Version=v${PORTVERSION}"
+GO_TARGET= ./cmd/${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/sysutils/kapp/distinfo b/sysutils/kapp/distinfo
new file mode 100644
index 000000000000..53d607443ec9
--- /dev/null
+++ b/sysutils/kapp/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1674680246
+SHA256 (go/sysutils_kapp/kapp-v0.54.2/v0.54.2.mod) = ed781981d428246580499f9726da395827598fcf931f336ba08a8bbf456c5c13
+SIZE (go/sysutils_kapp/kapp-v0.54.2/v0.54.2.mod) = 3624
+SHA256 (go/sysutils_kapp/kapp-v0.54.2/v0.54.2.zip) = 8a82d698b4d717e3a5b000515e7d2d5935250676cc5c521879e7af273429a60f
+SIZE (go/sysutils_kapp/kapp-v0.54.2/v0.54.2.zip) = 1421442
diff --git a/sysutils/kapp/pkg-descr b/sysutils/kapp/pkg-descr
new file mode 100644
index 000000000000..48f9ef364ccb
--- /dev/null
+++ b/sysutils/kapp/pkg-descr
@@ -0,0 +1,6 @@
+kapp CLI encourages Kubernetes users to manage resources in bulk by working with
+"Kubernetes applications" (sets of resources with the same label).
+It focuses on resource diffing, labeling, deployment and deletion.
+Unlike tools like Helm, kapp considers YAML templating and management of
+packages outside of its scope,
+though it works great with tools that generate Kubernetes configuration.