aboutsummaryrefslogtreecommitdiff
path: root/sysutils/kio-fuse/files
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2024-01-14 04:16:48 +0000
committerJason E. Hale <jhale@FreeBSD.org>2024-01-14 04:18:44 +0000
commit085d19d9fe100cd7419ea2ba1d17165eef22ed3a (patch)
treeaca161705253027ec4cd98f460e8748e997e81e3 /sysutils/kio-fuse/files
parent16feaa08e732697407b4e6162857b6d3203f2f51 (diff)
downloadports-085d19d9fe100cd7419ea2ba1d17165eef22ed3a.tar.gz
ports-085d19d9fe100cd7419ea2ba1d17165eef22ed3a.zip
sysutils/kio-fuse: Update to 5.1.0
Diffstat (limited to 'sysutils/kio-fuse/files')
-rw-r--r--sysutils/kio-fuse/files/patch-CMakeLists.txt19
-rw-r--r--sysutils/kio-fuse/files/patch-git-a98b95f49cd34be7da6371c74b871b8b1f7e734b25
-rw-r--r--sysutils/kio-fuse/files/patch-git-daed23c4d7b944e486308d5f71fd48854a32cb2d32
3 files changed, 19 insertions, 57 deletions
diff --git a/sysutils/kio-fuse/files/patch-CMakeLists.txt b/sysutils/kio-fuse/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..f6a3612f75c0
--- /dev/null
+++ b/sysutils/kio-fuse/files/patch-CMakeLists.txt
@@ -0,0 +1,19 @@
+--- CMakeLists.txt.orig 2024-01-14 03:25:35 UTC
++++ CMakeLists.txt
+@@ -72,10 +72,12 @@ ecm_generate_dbus_service_file(
+ DESTINATION ${KDE_INSTALL_DBUSSERVICEDIR}
+ )
+
+-if(DEFINED KDE_INSTALL_SYSTEMDUSERUNITDIR)
+- ecm_install_configured_files(INPUT kio-fuse.service.in DESTINATION ${KDE_INSTALL_SYSTEMDUSERUNITDIR})
+-else()
+- ecm_install_configured_files(INPUT kio-fuse.service.in DESTINATION ${SYSTEMD_USER_UNIT_INSTALL_DIR})
++if(CMAKE_SYSTEM_NAME MATCHES "Linux")
++ if(DEFINED KDE_INSTALL_SYSTEMDUSERUNITDIR)
++ ecm_install_configured_files(INPUT kio-fuse.service.in DESTINATION ${KDE_INSTALL_SYSTEMDUSERUNITDIR})
++ else()
++ ecm_install_configured_files(INPUT kio-fuse.service.in DESTINATION ${SYSTEMD_USER_UNIT_INSTALL_DIR})
++ endif()
+ endif()
+
+ feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
diff --git a/sysutils/kio-fuse/files/patch-git-a98b95f49cd34be7da6371c74b871b8b1f7e734b b/sysutils/kio-fuse/files/patch-git-a98b95f49cd34be7da6371c74b871b8b1f7e734b
deleted file mode 100644
index 66b84ac1b15b..000000000000
--- a/sysutils/kio-fuse/files/patch-git-a98b95f49cd34be7da6371c74b871b8b1f7e734b
+++ /dev/null
@@ -1,25 +0,0 @@
-diff --git kiofusevfs.cpp kiofusevfs.cpp
-index 875da6f..b9c449f 100644
---- kiofusevfs.cpp
-+++ kiofusevfs.cpp
-@@ -2401,7 +2401,19 @@ int KIOFuseVFS::kioErrorToFuseError(const int kioError) {
- case KIO::ERR_CANNOT_RENAME_PARTIAL : return EIO;
- case KIO::ERR_NEED_PASSWD : return EACCES;
- case KIO::ERR_CANNOT_SYMLINK : return EIO;
-- case KIO::ERR_NO_CONTENT : return ENODATA;
-+ case KIO::ERR_NO_CONTENT :
-+#ifdef ENODATA
-+ /* ENODATA is defined by GNU libc, and C++ tr1 seems to have
-+ * it as well, as does Boost: these consistently define it
-+ * to the value 9919. There is no guarantee the underlying
-+ * FUSE implementation understands that if ENODATA doesn't
-+ * exist in libc, though -- in that case, fall back to
-+ * the more generic EIO.
-+ */
-+ return ENODATA;
-+#else
-+ return EIO;
-+#endif
- case KIO::ERR_DISK_FULL : return ENOSPC;
- case KIO::ERR_IDENTICAL_FILES : return EEXIST;
- case KIO::ERR_SLAVE_DEFINED : return EIO;
diff --git a/sysutils/kio-fuse/files/patch-git-daed23c4d7b944e486308d5f71fd48854a32cb2d b/sysutils/kio-fuse/files/patch-git-daed23c4d7b944e486308d5f71fd48854a32cb2d
deleted file mode 100644
index b1964af73b2f..000000000000
--- a/sysutils/kio-fuse/files/patch-git-daed23c4d7b944e486308d5f71fd48854a32cb2d
+++ /dev/null
@@ -1,32 +0,0 @@
-diff --git CMakeLists.txt CMakeLists.txt
-index cceec6c..4e97588 100644
---- CMakeLists.txt
-+++ CMakeLists.txt
-@@ -59,7 +59,11 @@ target_include_directories(kio-fuse PRIVATE ${FUSE3_INCLUDE_DIRS})
- target_compile_definitions(kio-fuse PRIVATE FUSE_USE_VERSION=31 ${FUSE3_CFLAGS_OTHER})
- target_link_libraries(kio-fuse PRIVATE Qt5::Core KF5::KIOCore ${FUSE3_LIBRARIES} ${FUSE3_LDFLAGS})
- install(TARGETS kio-fuse DESTINATION ${KDE_INSTALL_FULL_LIBEXECDIR})
--install(FILES kio-fuse-tmpfiles.conf DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/tmpfiles.d)
-+if(CMAKE_SYSTEM_NAME MATCHES "Linux")
-+ # We could argue that this needs a separate "if(LINUX_WITH_TMPFILES_D)".
-+ # or a "if(LINUX_WITH_SYSTEMD)".
-+ install(FILES kio-fuse-tmpfiles.conf DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/tmpfiles.d)
-+endif()
-
- # Once KF5 5.73 is required
- #
-@@ -80,7 +84,12 @@ SystemdService=kio-fuse.service
- ")
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/org.kde.KIOFuse.service DESTINATION ${KDE_INSTALL_DBUSSERVICEDIR})
-
--configure_file(kio-fuse.service.in ${CMAKE_CURRENT_BINARY_DIR}/kio-fuse.service)
--install(FILES ${CMAKE_CURRENT_BINARY_DIR}/kio-fuse.service DESTINATION ${SYSTEMD_USER_UNIT_INSTALL_DIR})
-+if(CMAKE_SYSTEM_NAME MATCHES "Linux")
-+ # We could argue that this needs a separate "if(LINUX_WITH_SYSTEMD)",
-+ # but the ECM macro (see above) is expected to do the right thing
-+ # when KF5 5.73 is required.
-+ configure_file(kio-fuse.service.in ${CMAKE_CURRENT_BINARY_DIR}/kio-fuse.service)
-+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/kio-fuse.service DESTINATION ${SYSTEMD_USER_UNIT_INSTALL_DIR})
-+endif()
-
- feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)