aboutsummaryrefslogtreecommitdiff
path: root/sysutils/kio-fuse/files
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2020-05-26 13:24:47 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2020-05-26 13:24:47 +0000
commitfb2feeedd39f4c7ca81d74581a81f8d2737cdc1c (patch)
treebd50861721f8f58443340d7991d6570df975d877 /sysutils/kio-fuse/files
parent0c58982c26edc09827889efd4c6950a3ad6f8452 (diff)
downloadports-fb2feeedd39f4c7ca81d74581a81f8d2737cdc1c.tar.gz
ports-fb2feeedd39f4c7ca81d74581a81f8d2737cdc1c.zip
Update sysutils/kio-fuse to latest upstream
These are progressive betas, basically; this release drops Boost from the dependencies. Reported by: portscout
Notes
Notes: svn path=/head/; revision=536630
Diffstat (limited to 'sysutils/kio-fuse/files')
-rw-r--r--sysutils/kio-fuse/files/patch-CMakeLists.txt25
-rw-r--r--sysutils/kio-fuse/files/patch-kiofusevfs.cpp11
2 files changed, 7 insertions, 29 deletions
diff --git a/sysutils/kio-fuse/files/patch-CMakeLists.txt b/sysutils/kio-fuse/files/patch-CMakeLists.txt
index 0edb433ba9ed..8c04301fa2e2 100644
--- a/sysutils/kio-fuse/files/patch-CMakeLists.txt
+++ b/sysutils/kio-fuse/files/patch-CMakeLists.txt
@@ -1,27 +1,16 @@
---- CMakeLists.txt.orig 2019-12-21 15:13:04 UTC
+Don't install the systemd exceptions file; we have our own (on-reboot)
+cleanup of temp mounts which wouldn't be affected.
+
+--- CMakeLists.txt.orig 2020-05-17 18:36:57 UTC
+++ CMakeLists.txt
-@@ -22,6 +22,7 @@ include(ECMQtDeclareLoggingCategory)
- include(ECMSetupVersion)
-
- find_package(PkgConfig REQUIRED)
-+find_package(Boost)
- find_package(Qt5 ${Qt5_MIN_VERSION} COMPONENTS Core REQUIRED)
- find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
- CoreAddons
-@@ -53,12 +54,14 @@ ecm_qt_declare_logging_category(KIOFUSE_SOURCES
- DEFAULT_SEVERITY Warning)
-
- add_executable(kio-fuse ${KIOFUSE_SOURCES})
--target_include_directories(kio-fuse PRIVATE ${FUSE3_INCLUDE_DIRS})
-+target_include_directories(kio-fuse PRIVATE ${FUSE3_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
+@@ -57,7 +57,9 @@ target_include_directories(kio-fuse PRIVATE ${FUSE3_IN
target_compile_definitions(kio-fuse PRIVATE FUSE_USE_VERSION=31 ${FUSE3_CFLAGS_OTHER})
- target_link_options(kio-fuse PRIVATE ${FUSE3_LDFLAGS})
- target_link_libraries(kio-fuse PRIVATE Qt5::Core KF5::KIOCore ${FUSE3_LIBRARIES})
+ target_link_libraries(kio-fuse PRIVATE Qt5::Core KF5::KIOCore ${FUSE3_LIBRARIES} ${FUSE3_LDFLAGS})
install(TARGETS kio-fuse DESTINATION ${KDE_INSTALL_FULL_LIBEXECDIR})
-install(FILES kio-fuse-tmpfiles.conf DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/tmpfiles.d)
+if(LINUX)
+ install(FILES kio-fuse-tmpfiles.conf DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/tmpfiles.d)
+endif()
- kdbusaddons_generate_dbus_service_file(kio-fuse org.kde.KIOFuse ${KDE_INSTALL_FULL_LIBEXECDIR})
+ kdbusaddons_generate_dbus_service_file("kio-fuse -f" org.kde.KIOFuse ${KDE_INSTALL_FULL_LIBEXECDIR})
feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
diff --git a/sysutils/kio-fuse/files/patch-kiofusevfs.cpp b/sysutils/kio-fuse/files/patch-kiofusevfs.cpp
deleted file mode 100644
index 74f376c42bdc..000000000000
--- a/sysutils/kio-fuse/files/patch-kiofusevfs.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- kiofusevfs.cpp.orig 2020-02-04 12:37:00 UTC
-+++ kiofusevfs.cpp
-@@ -43,6 +43,8 @@
- #include "debug.h"
- #include "kiofusevfs.h"
-
-+#include <boost/cerrno.hpp>
-+
- // Flags that don't exist on FreeBSD; since these are used as
- // bit(masks), setting them to 0 effectively means they're always unset.
- #ifndef O_NOATIME