aboutsummaryrefslogtreecommitdiff
path: root/sysutils/linux-miniconda-installer/Makefile
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-04-16 16:23:56 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-04-16 16:25:47 +0000
commited41b3295ccf8c6653298dc333766392e556bd28 (patch)
treed36bbff484ed4817804b2f869cb1de0a48c20f8f /sysutils/linux-miniconda-installer/Makefile
parent8ec65400199bf32888b9642cbaf0d37072de43e9 (diff)
downloadports-ed41b3295ccf8c6653298dc333766392e556bd28.tar.gz
ports-ed41b3295ccf8c6653298dc333766392e556bd28.zip
sysutils/linux-miniconda-installer: Aid for installing and using miniconda
Conda, like pip and CRAN, is a popular system that allows non-root users to install many binary software packages in their own directories. The system includes a base "channel" (repository) as well as 3rd party community channels, such as "bioconda". QC for community channels is generally below that of the base channel and FreeBSD ports, but they provide users with a convenient way to install software not yet available in FreeBSD ports. Packages are available for Linux, MacOS, and Windows. Linux Conda packages work about as well on FreeBSD as they do on CentOS, which is the basis of FreeBSD's Linux compatibility tool set. However, Conda and its packages require a complete Linux environment for full functionality. Typical Conda users do not know how to configure this environment on FreeBSD. Miniconda-installer ensures a proper environment for installing and using Miniconda and the packages it provides.
Diffstat (limited to 'sysutils/linux-miniconda-installer/Makefile')
-rw-r--r--sysutils/linux-miniconda-installer/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/sysutils/linux-miniconda-installer/Makefile b/sysutils/linux-miniconda-installer/Makefile
new file mode 100644
index 000000000000..0ef78ba1af1b
--- /dev/null
+++ b/sysutils/linux-miniconda-installer/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= miniconda-installer
+DISTVERSION= 0.1.0
+CATEGORIES= sysutils linux
+PKGNAMEPREFIX= linux-
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Aid for installing and using miniconda
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+ONLY_FOR_ARCHS= amd64
+
+RUN_DEPENDS= auto-admin>=0.7.2:sysutils/auto-admin
+
+USES= linux python:3.8
+USE_GITHUB= yes
+
+GH_ACCOUNT= outpaddling
+NO_BUILD= yes
+PLIST_FILES= bin/miniconda-installer bin/conda-shell
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/miniconda-installer ${WRKSRC}/conda-shell \
+ ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>