aboutsummaryrefslogtreecommitdiff
path: root/sysutils/logrotate/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2017-12-20 02:31:40 +0000
committerSteve Wills <swills@FreeBSD.org>2017-12-20 02:31:40 +0000
commit4aa1a457357e19a8ae4ff1de6144cf0670392aba (patch)
tree2ed4eaca6bbbf137ff484425fe4471b2237c02cb /sysutils/logrotate/Makefile
parentc00d963486c00a963f143165b4ddd527509d72b0 (diff)
downloadports-4aa1a457357e19a8ae4ff1de6144cf0670392aba.tar.gz
ports-4aa1a457357e19a8ae4ff1de6144cf0670392aba.zip
sysutils/logrotate: fix paths after upate to 3.13.0
While here add USES=localbase and unmute post-install tasks PR: 223227 Submitted by: a.ulasov@gmail.com (inspired by) Approved by: js@iksz.hu (maintainer)
Notes
Notes: svn path=/head/; revision=456774
Diffstat (limited to 'sysutils/logrotate/Makefile')
-rw-r--r--sysutils/logrotate/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/sysutils/logrotate/Makefile b/sysutils/logrotate/Makefile
index ff1c05543887..ad87b1f921d3 100644
--- a/sysutils/logrotate/Makefile
+++ b/sysutils/logrotate/Makefile
@@ -3,6 +3,7 @@
PORTNAME= logrotate
PORTVERSION= 3.13.0
+PORTREVISION= 1
CATEGORIES= sysutils
MAINTAINER= js@iksz.hu
@@ -15,15 +16,18 @@ LIB_DEPENDS= libpopt.so:devel/popt
USE_GITHUB= yes
PATCH_STRIP= -p1
-USES= gmake autoreconf
+USES= autoreconf gmake localbase
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_ARGS= --with-default-mail-command=/usr/bin/mailx \
+ --with-compress-command=/usr/bin/gzip \
+ --with-uncompress-command=/usr/bin/gunzip \
+ --with-state-file-path=/var/run/logrotate.status
post-install:
- @${SED} -e 's|__PREFIX__|${PREFIX}|' \
+ ${SED} -e 's|__PREFIX__|${PREFIX}|' \
< ${FILESDIR}/logrotate.conf.sample > ${STAGEDIR}${PREFIX}/etc/logrotate.conf.sample
- @${MKDIR} ${STAGEDIR}${ETCDIR}.d
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${ETCDIR}.d
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${FILESDIR}/syslog.sample ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>