aboutsummaryrefslogtreecommitdiff
path: root/sysutils/lscpu
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2017-12-11 09:24:41 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2017-12-11 09:24:41 +0000
commit0588c692f17e42e51f9d3cc7d18b763c1bcea8a9 (patch)
treec71524de02c22ea28fcfa452a2d873f6d9685665 /sysutils/lscpu
parentdf26ed850bf428a3464bde58f4063e25915fc399 (diff)
downloadports-0588c692f17e42e51f9d3cc7d18b763c1bcea8a9.tar.gz
ports-0588c692f17e42e51f9d3cc7d18b763c1bcea8a9.zip
Follow up on r455926 and just set ONLY_FOR_ARCHS instead of a bunch of
BROKEN_* statements: this software is inherently x86-only. While here, remove redundant ${PORTNAME}.1 from destination path and thus make the line fit under 80 characters.
Notes
Notes: svn path=/head/; revision=455934
Diffstat (limited to 'sysutils/lscpu')
-rw-r--r--sysutils/lscpu/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/sysutils/lscpu/Makefile b/sysutils/lscpu/Makefile
index e5f95e74af8e..d243a61c8e97 100644
--- a/sysutils/lscpu/Makefile
+++ b/sysutils/lscpu/Makefile
@@ -10,13 +10,7 @@ COMMENT= Display information about the CPU architecture
LICENSE= BSD3CLAUSE
-BROKEN_aarch64= fails to compile: lib/clang/3.8.0/include/cpuid.h:25:2: error: this header is for x86 only
-BROKEN_armv6= fails to compile: lib/clang/5.0.0/include/cpuid.h:25:2: error: this header is for x86 only
-BROKEN_armv7= fails to compile: lib/clang/5.0.0/include/cpuid.h:25:2: error: this header is for x86 only
-BROKEN_mips= fails to compile: lscpu.c:10:19: error: cpuid.h: No such file or directory
-BROKEN_mips64= fails to compile: lscpu.c:10:19: error: cpuid.h: No such file or directory
-BROKEN_powerpc= fails to compile: lscpu.c:10:19: error: cpuid.h: No such file or directory
-BROKEN_powerpc64= fails to compile: lscpu.c:10:19: error: cpuid.h: No such file or directory
+ONLY_FOR_ARCHS= amd64 i386
USE_GITHUB= yes
GH_ACCOUNT= NanXiao
@@ -25,6 +19,6 @@ PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1/${PORTNAME}.1
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>