aboutsummaryrefslogtreecommitdiff
path: root/sysutils/lxqt-powermanagement/Makefile
diff options
context:
space:
mode:
authorJesper Schmitz Mouridsen <jsm@FreeBSD.org>2021-05-08 16:41:45 +0000
committerJesper Schmitz Mouridsen <jsm@FreeBSD.org>2021-05-08 16:52:00 +0000
commitc70abd00dc17a76865e70153e73b1de01dba2b46 (patch)
tree7cd7980da31a8a07da5c9c2abd03c7ee31ba369b /sysutils/lxqt-powermanagement/Makefile
parentf8f6ed4aabdcbc2ad837c07a86eb0140dad0c267 (diff)
downloadports-c70abd00dc17a76865e70153e73b1de01dba2b46.tar.gz
ports-c70abd00dc17a76865e70153e73b1de01dba2b46.zip
New port: sysutils/lxqt-powermanagement
lxqt-powermanagement can monitor power management events and optionally triggers actions like e.g. shut down a system when laptop batteries are low on power.
Diffstat (limited to 'sysutils/lxqt-powermanagement/Makefile')
-rw-r--r--sysutils/lxqt-powermanagement/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/sysutils/lxqt-powermanagement/Makefile b/sysutils/lxqt-powermanagement/Makefile
new file mode 100644
index 000000000000..297182eeb839
--- /dev/null
+++ b/sysutils/lxqt-powermanagement/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= lxqt-powermanagement
+PORTVERSION= 0.17.0
+CATEGORIES= sysutils
+MASTER_SITES= LXQT
+
+MAINTAINER= jsm@FreeBSD.org
+COMMENT= LXQt power management
+
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= upower:sysutils/upower
+
+USES= cmake compiler:c++14-lang gettext-runtime kde:5 qt:5 \
+ localbase:ldflags lxqt pkgconfig tar:xz gnome
+USE_QT= buildtools_build qmake_build core svg widgets x11extras \
+ dbus gui xml
+USE_GNOME= glib20
+USE_KDE= idletime solid windowsystem
+USE_LXQT= buildtools lxqt globalkeys
+
+.include <bsd.port.mk>