aboutsummaryrefslogtreecommitdiff
path: root/sysutils/memtest86
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-06-06 09:47:40 +0000
committerJohn Marino <marino@FreeBSD.org>2014-06-06 09:47:40 +0000
commitae32bd7e356c66ff7cecb5779b5fb32e43a3ba66 (patch)
treec77295dfca4ce30b9a91c76b25db4a4ddaadbded /sysutils/memtest86
parent0357c9b32b930bd40eeb696a67054726663ec0f8 (diff)
downloadports-ae32bd7e356c66ff7cecb5779b5fb32e43a3ba66.tar.gz
ports-ae32bd7e356c66ff7cecb5779b5fb32e43a3ba66.zip
sysutils/memtest86: Clean up, reset maintainer, remove post-extract
Tidy up this unmaintained (but surprisingly staged) port. It has multiple distfiles of different types, but no special post-extract target or extraction tool is needed. Make a small adjustment to remove an unnecessary build/extract dependency.
Notes
Notes: svn path=/head/; revision=356756
Diffstat (limited to 'sysutils/memtest86')
-rw-r--r--sysutils/memtest86/Makefile24
1 files changed, 10 insertions, 14 deletions
diff --git a/sysutils/memtest86/Makefile b/sysutils/memtest86/Makefile
index 51a4b59c94d0..cd6794d0864d 100644
--- a/sysutils/memtest86/Makefile
+++ b/sysutils/memtest86/Makefile
@@ -5,37 +5,33 @@ PORTNAME= memtest86
PORTVERSION= 4.0b
CATEGORIES= sysutils
MASTER_SITES= http://www.memtest86.com/
-DISTFILES= ${DISTNAME:S,b,s,}${EXTRACT_SUFX} ${DISTNAME:S,b,s,}.iso.zip
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/b/s/}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}.iso.zip
-MAINTAINER= sylvio@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Stand alone memory test for x86 architecture computers
-EXTRACT_DEPENDS= ${UNZIP_CMD}:${PORTSDIR}/archivers/unzip
-
ONLY_FOR_ARCHS= i386
NO_BUILD= yes
+ISO= Memtest86_${PORTVERSION:S/b/s/}.iso
+ISODEST= Memtest86_${PORTVERSION:S/b//}.iso
PORTDOCS= README
PLIST_FILES= %%DATADIR%%/floppy.bin \
- %%DATADIR%%/Memtest86_4.0.iso
+ %%DATADIR%%/${ISODEST}
PLIST_DIRS= %%DATADIR%%
-
SUB_FILES= pkg-message
OPTIONS_DEFINE= DOCS
-post-extract:
- @${UNZIP_CMD} -qo ${DISTDIR}/${DISTNAME:S,b,s,}.iso.zip -d ${WRKSRC}
-
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} ${WRKSRC:S,b,s,}/precomp.bin ${STAGEDIR}${DATADIR}/floppy.bin
- ${INSTALL_DATA} ${WRKSRC}/Memtest86_${PORTVERSION:S,b,s,}.iso \
- ${STAGEDIR}${DATADIR}/Memtest86_${PORTVERSION:S,b,,}.iso
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/precomp.bin ${STAGEDIR}${DATADIR}/floppy.bin
+ ${INSTALL_DATA} ${WRKDIR}/${ISO} ${STAGEDIR}${DATADIR}/${ISODEST}
.for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC:S,b,s,}/${i} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
.include <bsd.port.mk>