aboutsummaryrefslogtreecommitdiff
path: root/sysutils/metalog/Makefile
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2003-04-09 08:28:44 +0000
committerKevin Lo <kevlo@FreeBSD.org>2003-04-09 08:28:44 +0000
commit1b347c345c4ee964fd8e956847357d0843692f53 (patch)
tree2702ed3e1876fa793e060efd3b7ae9b96adce072 /sysutils/metalog/Makefile
parent2c2587e36733025da7c9bd01ab4ed356e919be67 (diff)
downloadports-1b347c345c4ee964fd8e956847357d0843692f53.tar.gz
ports-1b347c345c4ee964fd8e956847357d0843692f53.zip
- Update to 0.7 and bump PORTEPOCH since 0.7 < 0.7b
- Silence configure warning by adding CONFIGURE_TARGET - Allow user to override CPFLAGS/LDFLAGS - Do not install yet another copy of GPL - Use DOCSDIR/EXAMPLESDIR in pkg-plist PR: 50717 Submitted by: MAINTAINER
Notes
Notes: svn path=/head/; revision=78652
Diffstat (limited to 'sysutils/metalog/Makefile')
-rw-r--r--sysutils/metalog/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/sysutils/metalog/Makefile b/sysutils/metalog/Makefile
index 680ccff104f3..e337b6a4d714 100644
--- a/sysutils/metalog/Makefile
+++ b/sysutils/metalog/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= metalog
-PORTVERSION= 0.7b
+PORTVERSION= 0.7
+PORTEPOCH= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/b/beta/}
-EXTRACT_SUFX= .tgz
MAINTAINER= sergei@kolobov.com
COMMENT= Modern syslogd replacement with PCRE support
@@ -19,20 +18,22 @@ COMMENT= Modern syslogd replacement with PCRE support
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+# Needed for metalog's configure to find installed devel/pcre port
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAN8= metalog.8
-DOCS= COPYING NEWS README
+DOCS= AUTHORS NEWS README
-.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/metalog.conf ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
.include <bsd.port.mk>