aboutsummaryrefslogtreecommitdiff
path: root/sysutils/mptd
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2013-09-18 18:10:59 +0000
committerMark Felder <feld@FreeBSD.org>2013-09-18 18:10:59 +0000
commit480f5bfc9c95dabe181494e17cd1f057b399d99a (patch)
treea6665d8f85cbe98689235d0e251f994ff5594b9c /sysutils/mptd
parent61d86c14a11d4231abf67ab8b421e29294ea6622 (diff)
downloadports-480f5bfc9c95dabe181494e17cd1f057b399d99a.tar.gz
ports-480f5bfc9c95dabe181494e17cd1f057b399d99a.zip
add new port: sysutils/mptd
mptd is a monitoring daemon for mpt raid controllers designed by our very own jhb@ when he worked at Yahoo. Approved by: crees (mentor), sbruno Sponsored by: Yahoo
Notes
Notes: svn path=/head/; revision=327571
Diffstat (limited to 'sysutils/mptd')
-rw-r--r--sysutils/mptd/Makefile18
-rw-r--r--sysutils/mptd/distinfo2
-rw-r--r--sysutils/mptd/files/mptd.in28
-rw-r--r--sysutils/mptd/pkg-descr3
4 files changed, 51 insertions, 0 deletions
diff --git a/sysutils/mptd/Makefile b/sysutils/mptd/Makefile
new file mode 100644
index 000000000000..c6ab095b18e0
--- /dev/null
+++ b/sysutils/mptd/Makefile
@@ -0,0 +1,18 @@
+# Created by: Mark Felder <feld@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mptd
+PORTVERSION= 0.01
+CATEGORIES= sysutils
+MASTER_SITES= https://www.glenbarber.us/ports/${CATEGORIES}/${PORTNAME}/
+
+MAINTAINER= feld@FreeBSD.org
+COMMENT= Monitoring daemon for mpt RAID controllers
+
+USE_RC_SUBR= mptd
+PLIST_FILES+= sbin/mptd
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/mptd ${PREFIX}/sbin/mptd
+
+.include <bsd.port.mk>
diff --git a/sysutils/mptd/distinfo b/sysutils/mptd/distinfo
new file mode 100644
index 000000000000..ea3f91f20b11
--- /dev/null
+++ b/sysutils/mptd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mptd-0.01.tar.gz) = efa6d9c463b4064a220019d89e14d9ca3cfd0d7b645f99e20456d05b8dcef220
+SIZE (mptd-0.01.tar.gz) = 8342
diff --git a/sysutils/mptd/files/mptd.in b/sysutils/mptd/files/mptd.in
new file mode 100644
index 000000000000..c2bc871c8a2a
--- /dev/null
+++ b/sysutils/mptd/files/mptd.in
@@ -0,0 +1,28 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: mptd
+# REQUIRE: dumpon root ldconfig devfs syslogd mail
+# KEYWORD: nojail noyroot shutdown
+
+. /etc/rc.subr
+
+name=mptd
+rcvar=mptd_enable
+load_rc_config $name
+
+raid_alert_mailto=${mptd_raid_alert_mailto:-"root@localhost"}
+start_cmd=mptd_start
+stop_cmd="killall -9 mptd > /dev/null 2>&1"
+
+mptd_start()
+{
+ if [ -x "%%PREFIX%%/bin/mptd" -a -e "/dev/mpt0" ]; then
+ echo "Starting mptd."
+ %%PREFIX%%/bin/mptd ${raid_alert_mailto}
+ fi
+}
+
+run_rc_command "$1"
diff --git a/sysutils/mptd/pkg-descr b/sysutils/mptd/pkg-descr
new file mode 100644
index 000000000000..baac8e688d25
--- /dev/null
+++ b/sysutils/mptd/pkg-descr
@@ -0,0 +1,3 @@
+Monitoring daemon for mpt RAID controllers
+
+WWW: http://www.freebsd.org/