aboutsummaryrefslogtreecommitdiff
path: root/sysutils/mtpfs
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-08-01 09:37:54 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-08-01 09:37:54 +0000
commit566f374f71aac0fd40308e81e7f2010849784ef8 (patch)
tree7aa3a4cddb02266c01177df8d3eed40781ae4ffc /sysutils/mtpfs
parent44a409d321655a0d1862a0058ebefd660f5de12a (diff)
downloadports-566f374f71aac0fd40308e81e7f2010849784ef8.tar.gz
ports-566f374f71aac0fd40308e81e7f2010849784ef8.zip
- Add LICENSE
- Regenerate patches - Update WWW Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=476169
Diffstat (limited to 'sysutils/mtpfs')
-rw-r--r--sysutils/mtpfs/Makefile3
-rw-r--r--sysutils/mtpfs/files/patch-Makefile.in6
-rw-r--r--sysutils/mtpfs/files/patch-mtpfs.c12
-rw-r--r--sysutils/mtpfs/files/patch-mtpfs.h8
-rw-r--r--sysutils/mtpfs/pkg-descr2
5 files changed, 17 insertions, 14 deletions
diff --git a/sysutils/mtpfs/Makefile b/sysutils/mtpfs/Makefile
index 5b56931d1b22..236ef2b65c6d 100644
--- a/sysutils/mtpfs/Makefile
+++ b/sysutils/mtpfs/Makefile
@@ -10,6 +10,9 @@ MASTER_SITES= http://www.adebenham.com/files/mtp/
MAINTAINER= jhixson@gmail.com
COMMENT= MTP device filesystem
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= libmtp.so:multimedia/libmtp \
libid3.so:audio/id3lib \
libid3tag.so:audio/libid3tag \
diff --git a/sysutils/mtpfs/files/patch-Makefile.in b/sysutils/mtpfs/files/patch-Makefile.in
index ff70cb0a0c94..bbc8ef99eb93 100644
--- a/sysutils/mtpfs/files/patch-Makefile.in
+++ b/sysutils/mtpfs/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in 2012-02-26 17:02:28.000000000 -0800
-+++ Makefile.in 2012-12-12 19:11:25.155523995 -0800
-@@ -181,7 +181,7 @@
+--- Makefile.in.orig 2012-02-27 01:02:28 UTC
++++ Makefile.in
+@@ -181,7 +181,7 @@ top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
mtpfs_SOURCES = mtpfs.c mtpfs.h $(am__append_1)
diff --git a/sysutils/mtpfs/files/patch-mtpfs.c b/sysutils/mtpfs/files/patch-mtpfs.c
index a544c3c9665a..7a0a9c372681 100644
--- a/sysutils/mtpfs/files/patch-mtpfs.c
+++ b/sysutils/mtpfs/files/patch-mtpfs.c
@@ -1,6 +1,6 @@
---- mtpfs.c 2012-02-26 16:59:39.000000000 -0800
-+++ mtpfs.c 2012-12-12 19:11:46.955525173 -0800
-@@ -1270,7 +1270,7 @@
+--- mtpfs.c.orig 2012-02-27 00:59:39 UTC
++++ mtpfs.c
+@@ -1270,7 +1270,7 @@ mtpfs_rename (const char *oldname, const
}
static int
@@ -9,7 +9,7 @@
{
DBG("mtpfs_statfs");
stbuf->f_bsize=1024;
-@@ -1282,7 +1282,7 @@
+@@ -1282,7 +1282,7 @@ mtpfs_statfs (const char *path, struct s
}
void *
@@ -18,7 +18,7 @@
{
LIBMTP_devicestorage_t *storage;
DBG("mtpfs_init");
-@@ -1298,8 +1298,14 @@
+@@ -1298,8 +1298,14 @@ mtpfs_blank()
// Do nothing
}
@@ -34,7 +34,7 @@
.release = mtpfs_release,
.readdir = mtpfs_readdir,
.getattr = mtpfs_getattr,
-@@ -1428,7 +1434,7 @@
+@@ -1428,7 +1434,7 @@ main (int argc, char *argv[])
DBG("Start fuse");
diff --git a/sysutils/mtpfs/files/patch-mtpfs.h b/sysutils/mtpfs/files/patch-mtpfs.h
index b0b0eafa318b..ac1cd9323d2e 100644
--- a/sysutils/mtpfs/files/patch-mtpfs.h
+++ b/sysutils/mtpfs/files/patch-mtpfs.h
@@ -1,5 +1,5 @@
---- mtpfs.h 2012-02-23 20:37:14.000000000 -0800
-+++ mtpfs.h 2012-12-12 19:10:01.055523958 -0800
+--- mtpfs.h.orig 2012-02-24 04:37:14 UTC
++++ mtpfs.h
@@ -18,7 +18,9 @@
#include <fcntl.h>
#include <dirent.h>
@@ -11,7 +11,7 @@
#include <libmtp.h>
#include <glib.h>
-@@ -49,7 +51,7 @@
+@@ -49,7 +51,7 @@ static int find_storage(const gchar * pa
/* fuse functions */
@@ -20,7 +20,7 @@
static int mtpfs_blank ();
static int mtpfs_release (const char *path, struct fuse_file_info *fi);
void mtpfs_destroy ();
-@@ -62,7 +64,7 @@
+@@ -62,7 +64,7 @@ static int mtpfs_write (const gchar * pa
static int mtpfs_unlink (const gchar * path);
static int mtpfs_mkdir (const char *path, mode_t mode);
static int mtpfs_rmdir (const char *path);
diff --git a/sysutils/mtpfs/pkg-descr b/sysutils/mtpfs/pkg-descr
index 76d5a222815e..b48ea877ec01 100644
--- a/sysutils/mtpfs/pkg-descr
+++ b/sysutils/mtpfs/pkg-descr
@@ -1,4 +1,4 @@
MTPFS is a FUSE filesystem that supports reading and writing from any
MTP device (as supported by libmtp)
-WWW: http://www.adebenham.com/mtpfs/
+WWW: https://www.adebenham.com/mtpfs/