aboutsummaryrefslogtreecommitdiff
path: root/sysutils/munin-contrib
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-01-24 12:53:54 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-01-24 12:53:54 +0000
commit727cc2bd6125651285503eef67ecba0ba57197ba (patch)
tree68543b6f9b27c8405e9376be68247ba22f50819a /sysutils/munin-contrib
parent0c89b0ef964bd81b27158c8a4103c1189a049d85 (diff)
downloadports-727cc2bd6125651285503eef67ecba0ba57197ba.tar.gz
ports-727cc2bd6125651285503eef67ecba0ba57197ba.zip
Add a munin-contrib port, a collection of contributed plugins,
templates, tools, and other "stuff" for munin. Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=432335
Diffstat (limited to 'sysutils/munin-contrib')
-rw-r--r--sysutils/munin-contrib/Makefile40
-rw-r--r--sysutils/munin-contrib/distinfo3
-rw-r--r--sysutils/munin-contrib/files/pkg-message.in12
-rw-r--r--sysutils/munin-contrib/pkg-descr6
4 files changed, 61 insertions, 0 deletions
diff --git a/sysutils/munin-contrib/Makefile b/sysutils/munin-contrib/Makefile
new file mode 100644
index 000000000000..e7aca5e43839
--- /dev/null
+++ b/sysutils/munin-contrib/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= contrib
+DISTVERSION= git.2017-01-21
+CATEGORIES= sysutils
+PKGNAMEPREFIX= munin-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= Contributed plugins and other for munin
+
+RUN_DEPENDS= munin-node>=0:sysutils/munin-node
+
+USE_GITHUB= yes
+GH_ACCOUNT= munin-monitoring
+GH_TAGNAME= 9990b16
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+USES= shebangfix uniquefiles:dirs
+SHEBANG_REGEX= ./(${PORTEXAMPLES:tW:S/ /|/g})/.*
+SHEBANG_LANG= python3 expect gawk zsh
+ruby_OLD_CMD= /opt/csw/bin/ruby
+zsh_CMD= ${LOCALBASE}/bin/zsh
+python3_CMD= ${LOCALBASE}/bin/python${PYTHON3_DEFAULT}
+
+# Most of the installed files are scripts, so give them a "correct" mode.
+BINMODE= 755
+
+PORTDOCS= README.md
+PORTEXAMPLES= plugins samples templates tools
+
+SUB_FILES= pkg-message
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${COPYTREE_BIN} '${PORTEXAMPLES}' ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/sysutils/munin-contrib/distinfo b/sysutils/munin-contrib/distinfo
new file mode 100644
index 000000000000..61a1296ea469
--- /dev/null
+++ b/sysutils/munin-contrib/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1485260343
+SHA256 (munin-monitoring-contrib-git.2017-01-21-9990b16_GH0.tar.gz) = 0527da8633bc35ada2da3dcf0d681d6c4621c4be8dc2b26785970de9347e4ec0
+SIZE (munin-monitoring-contrib-git.2017-01-21-9990b16_GH0.tar.gz) = 2806526
diff --git a/sysutils/munin-contrib/files/pkg-message.in b/sysutils/munin-contrib/files/pkg-message.in
new file mode 100644
index 000000000000..46527119176c
--- /dev/null
+++ b/sysutils/munin-contrib/files/pkg-message.in
@@ -0,0 +1,12 @@
+To avoid having too many plugins activating at once when this port
+is installed, the contributed plugins from this port are NOT installed
+in munin's plugins directory.
+
+The best way to use a contributed plugin is to make a symlink to
+it to munin's plugins directory, for example:
+
+ ln -s %%EXAMPLESDIR%%/plugins/cyrus/cyrus-imapd %%PREFIX%%/share/munin/plugins/
+
+Note that as this is a "contrib" port, some plugins may need some
+dependencies to run that are not provided by this port.
+
diff --git a/sysutils/munin-contrib/pkg-descr b/sysutils/munin-contrib/pkg-descr
new file mode 100644
index 000000000000..8027ab91530d
--- /dev/null
+++ b/sysutils/munin-contrib/pkg-descr
@@ -0,0 +1,6 @@
+Contributed stuff for munin.
+
+It contains plugins, templates, tools, sample configuration and
+some other things.
+
+WWW: https://github.com/munin-monitoring/contrib