aboutsummaryrefslogtreecommitdiff
path: root/sysutils/munin-master/Makefile
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2010-02-23 13:55:00 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2010-02-23 13:55:00 +0000
commit6f830b33ee46bafffcffc04a7f4dc24eecd40f8e (patch)
treebccdd75ce1d3d1c9c0141cfaf6475ff63356abe5 /sysutils/munin-master/Makefile
parent57a370406dee64a0b3f0a8836a7a7bdad33563a3 (diff)
downloadports-6f830b33ee46bafffcffc04a7f4dc24eecd40f8e.tar.gz
ports-6f830b33ee46bafffcffc04a7f4dc24eecd40f8e.zip
Upgrade Munin to 1.4.3. Thanks to Sean Rees <sean@rees.us> for providing
the initial patches and getting me started with this. Note that munin-main has been renamed to munin-master (see MOVED). Approved by: portmgr (erwin) Feature safe: yes
Notes
Notes: svn path=/head/; revision=250230
Diffstat (limited to 'sysutils/munin-master/Makefile')
-rw-r--r--sysutils/munin-master/Makefile83
1 files changed, 60 insertions, 23 deletions
diff --git a/sysutils/munin-master/Makefile b/sysutils/munin-master/Makefile
index 129dd62c12d8..28167e6cacc9 100644
--- a/sysutils/munin-master/Makefile
+++ b/sysutils/munin-master/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: munin-main
+# New ports collection makefile for: munin-master
# Date created: 25 Januar 2004
# Whom: Lupe Christoph <lupe@lupe-christoph.de>
#
@@ -6,49 +6,86 @@
#
PORTNAME= munin
-PORTVERSION= 1.2.6
-PORTREVISION= 1
+PORTVERSION= 1.4.3
CATEGORIES= sysutils perl5
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20stable/${PORTVERSION}
-PKGNAMESUFFIX= -main
-DISTNAME= ${PORTNAME}_${PORTVERSION:S/.r/rc/}
+PKGNAMESUFFIX= -master
MAINTAINER= des@FreeBSD.org
COMMENT= Collector part of Munin
-USE_PERL5= yes
-
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/RRDs.pm:${PORTSDIR}/databases/rrdtool \
+BUILD_DEPENDS= ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build \
+ ${SITE_PERL}/Munin/Common/Defaults.pm:${PORTSDIR}/sysutils/munin-common \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
+ ${SITE_PERL}/${PERL_ARCH}/RRDs.pm:${PORTSDIR}/databases/rrdtool \
+ ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/converters/p5-Storable-AMF \
+ ${SITE_PERL}/DateTime/HiRes.pm:${PORTSDIR}/devel/p5-DateTime-HiRes \
+ ${SITE_PERL}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long \
+ ${SITE_PERL}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template \
+ ${SITE_PERL}/Log/Log4perl.pm:${PORTSDIR}/devel/p5-Log-Log4perl \
+ ${SITE_PERL}/Text/Balanced.pm:${PORTSDIR}/textproc/p5-Text-Balanced
+RUN_DEPENDS= ${SITE_PERL}/Munin/Common/Defaults.pm:${PORTSDIR}/sysutils/munin-common \
+ ${SITE_PERL}/${PERL_ARCH}/RRDs.pm:${PORTSDIR}/databases/rrdtool \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
+ ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/converters/p5-Storable-AMF \
+ ${SITE_PERL}/DateTime/HiRes.pm:${PORTSDIR}/devel/p5-DateTime-HiRes \
+ ${SITE_PERL}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long \
${SITE_PERL}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template \
- ${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip
-BUILD_DEPENDS= ${RUN_DEPENDS}
+ ${SITE_PERL}/Log/Log4perl.pm:${PORTSDIR}/devel/p5-Log-Log4perl \
+ ${SITE_PERL}/Text/Balanced.pm:${PORTSDIR}/textproc/p5-Text-Balanced
+USE_PERL5= yes
USE_GMAKE= yes
PATCH_STRIP= -p1
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.r/rc/}
PKGMESSAGE= ${WRKDIR}/pkg-message
-ALL_TARGET= WWWDIR=${WWWDIR} DATADIR=${DATADIR} PERL=${PERL} build build-man
-INSTALL_TARGET= WWWDIR=${WWWDIR} DATADIR=${DATADIR} PERL=${PERL} SITE_PERL_REL=$(SITE_PERL_REL) install-main
+MAKE_ARGS= LIBDIR=${DATADIR} CONFDIR=${ETCDIR} \
+ WWWDIR=${WWWDIR} CGIDIR=${WWWDIR}/cgi-bin \
+ PERL=${PERL} SITE_PERL_REL=${SITE_PERL_REL}
+ALL_TARGET= build-master build-man
+INSTALL_TARGET= install-master-prime
+
+MAN3= Munin::Master::Config.3 \
+ Munin::Master::Group.3 \
+ Munin::Master::GroupRepository.3 \
+ Munin::Master::HTMLOld.3 \
+ Munin::Master::Host.3 \
+ Munin::Master::Logger.3 \
+ Munin::Master::Node.3 \
+ Munin::Master::ProcessManager.3 \
+ Munin::Master::Update.3 \
+ Munin::Master::UpdateWorker.3 \
+ Munin::Master::Utils.3 \
+ Munin::Master::Worker.3
MAN5= munin.conf.5
-MAN8= munin-cron.8 munin-graph.8 munin-html.8 munin-limits.8 munin-update.8
+MAN8= munin-cron.8 \
+ munin-graph.8 \
+ munin-html.8 \
+ munin-limits.8 \
+ munin-update.8
-SUB_FILES=pkg-message
+SUB_FILES= pkg-message
pre-install:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGDIR}/pkg-install ${PKGNAME} PRE-INSTALL
post-install:
- @${INSTALL_DATA} ${WRKSRC}/build/server/munin.conf ${PREFIX}/etc/munin/munin.conf.sample
- @for man in ${MAN5}; do \
- ${INSTALL_MAN} -C ${WRKSRC}/build/doc/$$man ${PREFIX}/man/man5; \
- done
- @for man in ${MAN8}; do \
- ${INSTALL_MAN} -C ${WRKSRC}/build/doc/$$man ${PREFIX}/man/man8; \
- done
+ @${INSTALL_DATA} ${WRKSRC}/build/master/munin.conf ${PREFIX}/etc/munin/munin.conf.sample
+ @(cd ${WRKSRC}/master/blib/libdoc && for man in ${MAN3}; do \
+ ${INSTALL_MAN} -C $$man ${PREFIX}/man/man3; \
+ done)
+ @(cd ${WRKSRC}/build/doc && for man in ${MAN5}; do \
+ ${INSTALL_MAN} -C $$man ${PREFIX}/man/man5; \
+ done)
+ @(cd ${WRKSRC}/build/doc && for man in ${MAN8}; do \
+ ${INSTALL_MAN} -C $$man ${PREFIX}/man/man8; \
+ done)
@DATADIR=${DATADIR} PKG_PREFIX=${PREFIX} ${SH} ${PKGDIR}/pkg-install ${PKGNAME} POST-INSTALL
- @${CHOWN} munin /var/log/munin-main
- @${CHGRP} munin /var/run/munin /var/log/munin-main ${WWWDIR} ${PREFIX}/var/munin
+ @${CHOWN} munin /var/log/munin-master
+ @${CHGRP} munin /var/run/munin /var/log/munin-master ${WWWDIR} ${PREFIX}/var/munin
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>