aboutsummaryrefslogtreecommitdiff
path: root/sysutils/nomad
diff options
context:
space:
mode:
authorJohn Hixson <jhixson@FreeBSD.org>2020-05-23 03:27:18 +0000
committerJohn Hixson <jhixson@FreeBSD.org>2020-05-23 03:27:18 +0000
commite7b4bdeb3523adec11f30b73327b347946ba99c7 (patch)
tree0eba306ce1619d084c151627a2658f5862564dbe /sysutils/nomad
parent5878555e76fd38ef009b57965014060a72b3707b (diff)
downloadports-e7b4bdeb3523adec11f30b73327b347946ba99c7.tar.gz
ports-e7b4bdeb3523adec11f30b73327b347946ba99c7.zip
sysutils/nomad: update to version 0.11.2
Notes
Notes: svn path=/head/; revision=536263
Diffstat (limited to 'sysutils/nomad')
-rw-r--r--sysutils/nomad/Makefile2
-rw-r--r--sysutils/nomad/distinfo6
-rw-r--r--sysutils/nomad/files/patch-vendor_github.com_shirou_gopsutil_disk_disk__freebsd.go22
3 files changed, 26 insertions, 4 deletions
diff --git a/sysutils/nomad/Makefile b/sysutils/nomad/Makefile
index 6636df155cf2..0fdee102f91a 100644
--- a/sysutils/nomad/Makefile
+++ b/sysutils/nomad/Makefile
@@ -2,7 +2,7 @@
PORTNAME= nomad
DISTVERSIONPREFIX= v
-DISTVERSION= 0.11.0
+DISTVERSION= 0.11.2
CATEGORIES= sysutils
MAINTAINER= jhixson@FreeBSD.org
diff --git a/sysutils/nomad/distinfo b/sysutils/nomad/distinfo
index b8c542ba7aad..c0703cec9a87 100644
--- a/sysutils/nomad/distinfo
+++ b/sysutils/nomad/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1586453982
-SHA256 (hashicorp-nomad-v0.11.0_GH0.tar.gz) = 4868a493b83ad833eaf94f7b5552d1ee58aa1a5e9f6a20d86baf7b78b282c307
-SIZE (hashicorp-nomad-v0.11.0_GH0.tar.gz) = 52708805
+TIMESTAMP = 1590199997
+SHA256 (hashicorp-nomad-v0.11.2_GH0.tar.gz) = d0da412d23dfeba313a9824e9cc56c4aeb6180156d540d5a13313c510f6d549b
+SIZE (hashicorp-nomad-v0.11.2_GH0.tar.gz) = 53217187
diff --git a/sysutils/nomad/files/patch-vendor_github.com_shirou_gopsutil_disk_disk__freebsd.go b/sysutils/nomad/files/patch-vendor_github.com_shirou_gopsutil_disk_disk__freebsd.go
new file mode 100644
index 000000000000..990d768d9fbe
--- /dev/null
+++ b/sysutils/nomad/files/patch-vendor_github.com_shirou_gopsutil_disk_disk__freebsd.go
@@ -0,0 +1,22 @@
+--- vendor/github.com/shirou/gopsutil/disk/disk_freebsd.go.orig 2020-05-14 21:25:30 UTC
++++ vendor/github.com/shirou/gopsutil/disk/disk_freebsd.go
+@@ -84,9 +84,9 @@ func PartitionsWithContext(ctx context.Context, all bo
+ }
+
+ d := PartitionStat{
+- Device: common.IntToString(stat.Mntfromname[:]),
+- Mountpoint: common.IntToString(stat.Mntonname[:]),
+- Fstype: common.IntToString(stat.Fstypename[:]),
++ Device: common.ByteToString(stat.Mntfromname[:]),
++ Mountpoint: common.ByteToString(stat.Mntonname[:]),
++ Fstype: common.ByteToString(stat.Fstypename[:]),
+ Opts: opts,
+ }
+ if all == false {
+@@ -170,5 +170,5 @@ func parseDevstat(buf []byte) (Devstat, error) {
+ }
+
+ func getFsType(stat unix.Statfs_t) string {
+- return common.IntToString(stat.Fstypename[:])
++ return common.ByteToString(stat.Fstypename[:])
+ }