aboutsummaryrefslogtreecommitdiff
path: root/sysutils/nsysctl
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2021-03-03 05:34:21 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-03-03 05:34:21 +0000
commitd7e4dc00b7a653f63a2b097533f1e197c887e4c6 (patch)
tree47c8cd8532f448c65428af442d83cb36b9dbfae7 /sysutils/nsysctl
parent2f8f27882fe132f2be083f41102040810f105104 (diff)
downloadports-d7e4dc00b7a653f63a2b097533f1e197c887e4c6.tar.gz
ports-d7e4dc00b7a653f63a2b097533f1e197c887e4c6.zip
sysutils/nsysctl: Update to 2.0
Changes: https://gitlab.com/alfix/nsysctl/-/blob/master/CHANGELOG PR: 253971 Submitted by: Alfonso S. Siciliano <alfix86 AT gmail DOT com> (maintainer)
Notes
Notes: svn path=/head/; revision=567020
Diffstat (limited to 'sysutils/nsysctl')
-rw-r--r--sysutils/nsysctl/Makefile11
-rw-r--r--sysutils/nsysctl/distinfo6
-rw-r--r--sysutils/nsysctl/files/patch-src_nsysctl.c12
-rw-r--r--sysutils/nsysctl/files/patch-src_opaque.c10
-rw-r--r--sysutils/nsysctl/files/patch-src_special__value.c11
-rw-r--r--sysutils/nsysctl/files/patch-src_sysctlinfo__helper.c13
-rw-r--r--sysutils/nsysctl/pkg-descr17
7 files changed, 18 insertions, 62 deletions
diff --git a/sysutils/nsysctl/Makefile b/sysutils/nsysctl/Makefile
index 55512fad2440..b5968cca8e3d 100644
--- a/sysutils/nsysctl/Makefile
+++ b/sysutils/nsysctl/Makefile
@@ -1,24 +1,21 @@
# $FreeBSD$
PORTNAME= nsysctl
-DISTVERSION= 1.2.1
-PORTREVISION= 4
+DISTVERSION= 2.0
CATEGORIES= sysutils
MAINTAINER= alfix86@gmail.com
-COMMENT= Utility to get or set the kernel state supporting libxo output
+COMMENT= Utility to get and set kernel state at runtime
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${LOCALBASE}/include/sysctlinfo.h:sysutils/sysctlinfo-kmod
-LIB_DEPENDS= libsysctlmibinfo.so:devel/libsysctlmibinfo
-RUN_DEPENDS= ${KMODDIR}/sysctlinfo.ko:sysutils/sysctlinfo-kmod
+LIB_DEPENDS= libsysctlmibinfo2.so:devel/libsysctlmibinfo2
USE_GITLAB= yes
GL_ACCOUNT= alfix
-GL_COMMIT= 61f2bacc1d374ba357e6f67e07372eee0d765cda
+GL_COMMIT= 0e2408202e9c6da7d33f3a65a1e09bca0c6458a8
PLIST_FILES= man/man8/${PORTNAME}.8.gz \
sbin/${PORTNAME}
diff --git a/sysutils/nsysctl/distinfo b/sysutils/nsysctl/distinfo
index 0326c7c6e241..f5335983e0e6 100644
--- a/sysutils/nsysctl/distinfo
+++ b/sysutils/nsysctl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1612906310
-SHA256 (alfix-nsysctl-61f2bacc1d374ba357e6f67e07372eee0d765cda_GL0.tar.gz) = 8e4bdbef243ad5e2f652609fa4aba0c7f5a13fe275ad1fd2005a66c53f929e56
-SIZE (alfix-nsysctl-61f2bacc1d374ba357e6f67e07372eee0d765cda_GL0.tar.gz) = 25724
+TIMESTAMP = 1614701213
+SHA256 (alfix-nsysctl-0e2408202e9c6da7d33f3a65a1e09bca0c6458a8_GL0.tar.gz) = fe3b0ed52f5441da307b03df849f1a70c01aff62232438a11b7ad1a5c2cd6392
+SIZE (alfix-nsysctl-0e2408202e9c6da7d33f3a65a1e09bca0c6458a8_GL0.tar.gz) = 18852
diff --git a/sysutils/nsysctl/files/patch-src_nsysctl.c b/sysutils/nsysctl/files/patch-src_nsysctl.c
deleted file mode 100644
index 3ca414555e2d..000000000000
--- a/sysutils/nsysctl/files/patch-src_nsysctl.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/nsysctl.c.orig 2021-02-09 21:47:51 UTC
-+++ src/nsysctl.c
-@@ -25,7 +25,9 @@
- * SUCH DAMAGE.
- */
-
-+#include <sys/types.h>
- #include <sys/queue.h>
-+#include <sys/sysctl.h>
-
- #include <inttypes.h>
- #include <libutil.h>
diff --git a/sysutils/nsysctl/files/patch-src_opaque.c b/sysutils/nsysctl/files/patch-src_opaque.c
deleted file mode 100644
index 93952e9d4dfa..000000000000
--- a/sysutils/nsysctl/files/patch-src_opaque.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/opaque.c.orig 2021-02-09 21:56:37 UTC
-+++ src/opaque.c
-@@ -32,6 +32,7 @@
- /* Original: https://svnweb.freebsd.org/base/head/sbin/sysctl/sysctl.c */
-
- #include <sys/param.h>
-+#include <sys/queue.h>
- #include <sys/resource.h>
- #include <sys/time.h>
- #include <sys/vmmeter.h>
diff --git a/sysutils/nsysctl/files/patch-src_special__value.c b/sysutils/nsysctl/files/patch-src_special__value.c
deleted file mode 100644
index a8bc1916197e..000000000000
--- a/sysutils/nsysctl/files/patch-src_special__value.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/special_value.c.orig 2021-02-09 21:57:57 UTC
-+++ src/special_value.c
-@@ -27,6 +27,8 @@
-
- /* 'Special values' are strings parsed for xo-output */
-
-+#include <sys/queue.h>
-+
- #include <libxo/xo.h>
- #include <string.h>
-
diff --git a/sysutils/nsysctl/files/patch-src_sysctlinfo__helper.c b/sysutils/nsysctl/files/patch-src_sysctlinfo__helper.c
deleted file mode 100644
index c5a9ce95064d..000000000000
--- a/sysutils/nsysctl/files/patch-src_sysctlinfo__helper.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/sysctlinfo_helper.c.orig 2021-02-09 21:52:37 UTC
-+++ src/sysctlinfo_helper.c
-@@ -25,6 +25,10 @@
- * SUCH DAMAGE.
- */
-
-+#include <sys/types.h>
-+#include <sys/queue.h>
-+#include <sys/sysctl.h>
-+
- #include <stdbool.h>
- #include <stdlib.h>
- #include <string.h>
diff --git a/sysutils/nsysctl/pkg-descr b/sysutils/nsysctl/pkg-descr
index 028d316d7afd..93995119433d 100644
--- a/sysutils/nsysctl/pkg-descr
+++ b/sysutils/nsysctl/pkg-descr
@@ -1,10 +1,15 @@
-The nsysctl utility is a sysctl(8) clone to get or set the
-kernel state supporting libxo and extra options, features:
+Utility to get and set the kernel state at runtime, features:
- * new options to show the properties of a state,
- * output is explicitly indicated by the options,
- * the options are not mutually exclusive,
+ * get or set the system state at runtime,
+ * handle an object up to CTL_MAXNAME levels,
+ * print the right object also with an empty level name,
+ * options to show the properties of a parameter,
+ * output explicitly indicated by the options,
+ * options not mutually exclusive,
* output via libxo in human and machine readable formats,
- * some value is parsed to show structured output.
+ * isolated code to manage opaque values,
+ * some string value is parsed to show structured output,
+ * avoid non-primitive data types hardcode via libnv,
+ * debug without recompiling the kernel with SYSCTL_DEBUG.
WWW: https://gitlab.com/alfix/nsysctl/